Error al instalar

+1
0
-1

SI alguien me puede ayudar xq tengo un problema, me bajo paketes de webs de programas y tal y al meterme en la terminal y poner lo tipico: $ sudo apt-get -i y el nombre del pakete me dice ke no existe con un mensaje de error, o a veces me pone que no tengo privilegios para ejecutar y instalar nose ke...
que hago? los paketes ke me vajo vienen en formato .tgz o .tar.gz o .rpm

Ke arguien me ayude yaaaaaaaaaaaaaaaa

Comentarios

Imagen de RastaFary

Bueno, no se si dará igual, pero la manera de instalar las cosas por medio de apt-get es con el parametro install seguido del paquete que te quieras bajar e instalar. por ejemplo, apt-get install xxxxx (apt-get es para instalar paquetes desde las fuentes que tengas en tu source.list, no para instlar paquetes que ya te has bajado previamente tú)

otra cosa, para instalar paquetes en ubuntu, tienes que bajartelos del tipo .deb para poderlos instalar con dpkg -i xxxxxx.deb (creo que te estas liando y mezclando cosas de ambos comandos). con el dpkg solo funcionan (creo) los paquetes *.deb. si te bajas paquetes rpm, por ejemplo, puedes transformarlos en deb para poderlos instalar mediante la utilidad "alien". Si te los bajas en formato .tgz tar.gz o similar, deberas de descomprimirlos y mirarte como se instalan ya que en este caso la mayoria de las veces se hace a mano y configurando un instalador que suelen traer...

espero que te sirva de ayuda

Imagen de Johnny

Sí tienes razón, confundia alguno de los comandos, dime alguna guente para poder poner en mi source.list, xq me digeron que era recomendable borrar todas las que ponian deb# o algo así ya que no dejan bajar nada me dijeron. OK por aclararme lo de apt-get y dpkg, por cierto donde esta la utilidad "alien"?como se usa?la tengo ya instalada en mi ubuntu?etc... gracias por tu ayuda ah! se me olvidaba, es ke los drivers para mi impresora creo que estan .tgz y al descomprimirlos me aparecen solo dos archivos, uno que es el Readme y otro ke es formato .sh y le doy para ke se ejecute y no va... si no instalo eso no me servirá de nada tener Ubuntu ya que no podré imprimir. Can you help me again please?!

Iron

Imagen de RastaFary

te voy a dejar un enlace muy bueno para que te aclares con estas cosillas y con mas (tambien viene como actualizar la lista de fuentes y tal)

http://guia-ubuntu.org/doku.php

lo del alien creo que viene con ubuntu, simplemente con poner alien ya funcionará...

Imagen de RastaFary

y lo de la impresora mirate la pagina de cups, si es muy nueva seguro que no, pero si tiene 2 meses o asi seguro que trae ya ubuntu el driver para tu impresora, a mi me ha pasado. De todas maneras "alien" con los tgz en este caso creo que no te va a servir. si te has bajdo el driver dde la pagina de tu impresora bajate un rpm o un deb