¿Qué versión de los fuentes del kernel?

Imagen de danielGT
0 puntos

Hola gente...

Y heme aqui atreviendome cada vez mas desde que instale Ubuntu, ahora estoy desafiando al kernel XDDD.

Este novato tiene problemas con un joystick, especificamente con el modulo gamecon, el cual no me reconoce el modo digital, asi que investigue y lo que debo hacer es parchear dicho modulo y luego compilar, y aqui viene mi duda:

Tengo mas o menos claro que debo obtener el fuente del patch, hacer un patch p1 < fuente_de_mi_patch.patch y luego un make menuconfig, y por supuesto, los fuentes del kernel. Mi duda es, tengo que tener el codigo fuente el cual debe ser EXACTAMENTE la misma version del que tengo instalado? Actualmente tengo el kernel 2.6.17-10, entonces los fuentes del kernel tienen que ser exactamente esos, verdad? (perdon por la pregunta tan tonta).

Lo que no me queda tan claro es que hago despues......... debo instalar mi modulo? es decir, segun se make modules-install, instala los modulos, pero ¿todos los modulos? yo solo quiero el mio que necesito parchar (y por supuesto, que todo lo demas siga funcionando como antes).

Alguna ayuda por favor.

Un saludo y gracias.

Imagen de Anónimo
+1
0
-1

la version del kernell sale en la consola cuando se le da un
$uname -r

como sea

+1
0
-1