AXIS 1.6

Imagen de jacschapu
0 puntos

Hola.

Son mis primeras incursiones en Linux y pues tengo muchos problemillas ...

1.-
estoy tratando de ejecutar el ejemplo de la calculadora en axis 1.6b y a la hora de levantar la pagina que contiene el servicio me indica lo siguiente :
deployment descriptor not found ...

Estoy copiando la biblioteca de Xerces-c-2_7_0 (libxerces-c.so) en libaxis_xmlparser.so ya que la distribucion binaria de axis tiene la biblioteca libaxis_xerces.so la cual fue compilada con una version diferente de xerces-c ( esta buscando la biblioteca libxerces-c.so.22 ) y esta ocasionando problemas al no encontrar la biblioteca.

checo la bitacora que nos da apache ( error.log ) y encuentro lo siguiente :
An error occurred while Axis was initializing: DLOPEN FAILED in loading parser library DLOPEN FAILED in loading parser library /usr/local/axiscpp_deploy/lib/axis/libaxis_xmlparser.so

Alguien me podria decir que esta sucediendo ???

Ya probe de varias formas y no encuentro alguna solucion para esto.

2.-
Ante esta problematica estoy tratando de compilar los archivos fuente de axis 1.6b con xerces 2.7.0 , pero tambien me marca errores ;
si utilizo ANT :
Buildfile: build.xml
[taskdef] Could not load definitions from resource cpptasks.tasks. It could not be found.
[typedef] Could not load definitions from resource cpptasks.types. It could not be found.

BUILD FAILED
/home/jacschapu/Desktop/axis-c-1.6b-Linux-trace-src/build.xml:39: The following error occurred while executing this line:
/home/jacschapu/Desktop/axis-c-1.6b-Linux-trace-src/build/buildInitialize.xml:44: Could not create task or type of type: compiler

si utilizo autoconf :
configure.ac:2: error: possibly undefined macro: AM_INIT_AUTOMAKE
If this token and others are legitimate, please use m4_pattern_allow.
See the Autoconf documentation.
configure.ac:3: error: possibly undefined macro: AM_CONFIG_HEADER
configure.ac:294: error: possibly undefined macro: AC_PROG_LIBTOOL

que onda con esto ???

alguien me podria dar los pasos para poder compilar los fuentes de manera correcta ???

Gracias.
Salu2.

Imagen de jacschapu
+1
0
-1

Hola de nuevo .

ejecute nuevamente el autoconf con sudo y no marca errores, pero cuando trato de ejecutar la instruccion
sudo ./configure --prefix=$AXISCPP_HOME --with-apache2=/etc/apache2 --with-xercesc=$XERCES_HOME

Me marca el siguiente error :

./configure: line 1288: syntax error near unexpected token `3.80'
./configure: line 1288: `AM_INIT_AUTOMAKE(3.80)'

Espero que alguien me ayude, por que si no voy a ser un desempleado mas :-)

El estudio es el camino del triunfo

+1
0
-1

El estudio es el camino del triunfo