Wine AMD64 duda

Imagen de spacetree
0 puntos

Que tal, estuve leyendo unos foros y dicen que debo crear un entorno chroot o algo de las ia34 libs .

El caso es que yo tengo instaladas las libs y por ejemplo, puedo usar el swiftfox de 32 bits asi como el mplayer.

Ahora, cuando trato de poner apt-get build-dep wine , me dice que no puede cumplir las dependencias., les pongo lo que me sale

spacetree@spacetree-laptop:~$ sudo apt-get build-dep wine
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias... Hecho
Nota, seleccionando libicu34-dev en lugar de libicu-dev
E: No se pudieron satisfacer las dependencias de construcción de wine.

Alguien puede ayudamre?
grax

Imagen de lmd
+1
0
-1

Descarga ese archivo, descromprímelo y en console ./wine
Espera a que termine y listo. Ya tienes wine sin chroot ni movidas raras.

http://www.telefonica.net/web2/tp7/wine_9.27_Edgy_64.tar.gz

En dapper no lo he probado.

+1
0
-1
Imagen de Anónimo
+1
0
-1

Y te deja escribir eñes y acentos?

+1
0
-1
Imagen de spacetree
+1
0
-1

Gracias voy a ver eso al rato que llegue a mi JAULA

XD

+1
0
-1
Imagen de XoneW
+1
0
-1

Lo he probado desde Dapper, y me da varios errores, ya que intenta instalar el paquete para 6.10 y las librerías correspondientes de versiones más altas de Edgy. Como mi experiencia con Edgy no fue muy buena, decidí permanecer en la 6.06 LTS hasta la siguiente LTS (7.10 supongo), no prebí que podría tener este tipo de problemas. Por si alguno como yo se ha visto en algo semejante, paso a contar la solución que he puesto en práctica. En cualquier caso, espero que funcione. Es una forma muy elegante de instalar aplicaciones de 32 en arquitecturas de 64.

He hecho lo siguiente:
Me he bajado el paquete de aquí http://wine.budgetdedicated.com/archive/index.html, y sustituido la línea en el bash wine, donde hace referencia al paquete para 6.10, he colocado la correspondiente a la 6.06. Todo parece ir bien. Luego me ha dado un error al decirme que no puede configurarse sidenet como root. Pues nada, se sale de root, y se ejecuta dentro de sidenet ./setup, y después de algunos mensajes de error, que no he podido analizar porque se han borrado de mi consola, me dice que wine está instalado. Me falta probarlo.

Otra solución hubiera consistido en instalar las librerías que pide el paquete para la 6.10, pero eso no se que consecuencias podría tener en el sistema. Me decanté por utilizar las librerías de la versión 6.06 instalando el .deb correspondiente a ella.

Ahora van los siguientes interrogantes;

1º ¿Que puedo hacer para probar si me funciona wine? Es que nunca lo he utilizado, y me gustaría empezar por algo que se que puede funcionar, y cómo hacerlo con seguridad.

2º ¿Este forma de instalar paquetes para arquitectura de 32bits en amd64 es válida para otras aplicaciones?

+1
0
-1

Eso es lo que hay.

Imagen de abrahamtamayo
+1
0
-1

Que yo sepa no hay archivos .deb de wine en amd64. lo tienes que compílar con los parametros de tu prosesador. ok ..ok .. no es tan facil y esto se trata de ayudar y facil
copia y pega esto en consola la letra cursiva y listo "todo lo que este en letra cursiva

wget abrahamtamayo.iespana.es/wine_0.9.28-1_amd64.deb
sudp dpkg -i wine_0.9.28-1_amd64.deb
sudo apt-get -f install
sudo mv wine_0.9.28-1_amd64.deb /var/cache/apt/archives/

puedes instalar IE con motor 7 pero apariencia de 6

http://inicioubuntu.blogspot.com/2006/12/ies4linux.html

www.docerios.com

+1
0
-1
Imagen de Anónimo
+1
0
-1

exacto no hay pero pueden compilarse e instalar.

por mi parte yo hice uno y aca explico como instalarlo y tiene link para bajarlo, nada dificil :P

http://biza.wordpress.com/2007/01/10/wine-en-amd64/

+1
0
-1
Imagen de spacetree
+1
0
-1

Bien,

El paquete que hiciste se instalo con exito, pero cuando pongo wine en la linea de comandos sale

spacetree@spacetree-laptop:~$ wine
wine: /lib32/libc.so.6: version `GLIBC_2.4' not found (required by /usr/local/bin/../lib/libwine.so.1)

Por cierto, intento compilar pero siempre se queja que no puede resolver algunas dependencias, y creo que las mencionan en la pagina de wine, el caso, es ¿como puedo conseguir algo si no es mediante apt-get??

Grax

+1
0
-1
Imagen de Anónimo
+1
0
-1

bueno pues puedes poner en google "debian package" lo que t ellevara a la pagina oficial de debian, ahi puedes descargar librerias via web y luego instalalas como mas te guste.

ahi te esta diciendo que te faltan algunas dependencias, deberias poner sudo apt-get install libgc y aprietas tabulador varias veces para ver los paquetes disponibles.. deberia funcionar

+1
0
-1
Imagen de spacetree
+1
0
-1

Una vez hice algo asi, tenia que ver con el metacity (queria que compilara el heliodor y me faltaban unas librerias...) y pues force una que otra cosita y chiiiiiiiiiiiiiiiiin se habia corrompido todo el sistema de paquetes fue espantoso. Espero que no me pase asi otra vez....

+1
0
-1
Imagen de spacetree
+1
0
-1

Con respecto a la pregunta anterior, sucede que la libreria que pide wine si existe.

spacetree@spacetree-laptop:~$ locate libc.so.6
/lib/libc.so.6
/lib32/libc.so.6
/usr/chroot32/lib/tls/libc.so.6
/usr/chroot32/lib/tls/i686/cmov/libc.so.6
/usr/chroot32/lib/libc.so.6

¿}Que sucede, acaso no lo encuentra wine?
¿Que debo hacer para que wine encuentre esa libreria o la pueda usar?

El mismo problema lo tengo con mis aplicaciones openGL, la libreria existe pero no se puede acceder a ella (o no "la encuentra" el programa.

+1
0
-1
Imagen de Anónimo
+1
0
-1

a mi me ha pasado eso en ubuntu 6.10, no se cual fue la razon.. no me quede lidiando con el problema porque como no me gusto el gnome volvi corriendo a mi kubuntu que nunca me ha hecho eso :p

+1
0
-1
Imagen de jajajavi
+1
0
-1

en ubuntu dapper "version `GLIBC_2.4' not found" aunque libc.so.6 existe... ¿¿qué hacemos??

+1
0
-1
Imagen de spacetree
+1
0
-1

Pude resolver parte del problema de esta forma:

En cuanto a las librerias libGL.so.x , simplemente habia que agregar su path a un archivo (creo que se llama /lib/ld.config algo asi, tiene que ver coin ld.config, y luego ejecutar un programa que actualiza el cache de las librerias dinamicas, creo que se llama ldconfig (con sudo).

El problema es que aun no encuentra las de wine, creo que los usuarios de AMD64 no tenemos la version del glibc que requiere wine (estuve checando en el synaptic), porque aunque tenemos el libc.so.6 existe, nuestro GLIBC esta por ahi del 2.3.x . Chin, aqui si necesito ayuda.

+1
0
-1
Imagen de JoZ3
+1
0
-1

Hola estoy tratando de compilar la ultima version de wine (0.9.32) sigo obteniendo este error:

configure: WARNING: Wine will be build without OpenGL or Direct3D support
configure: WARNING: because something is wrong with the OpenGL setup:
configure: WARNING: No OpenGL library found on this system.

Configure finished. Do ‘make depend && make’ to compile Wine.

He seguido con calma las instrucciones y las siguientes guias y nada:

http://wiki.winehq.org/WineOn64bit
http://ubuntuforums.org/showthread.php?t=291620
http://biza.wordpress.com/2007/01/30/wine-0930-en-amd64-debian

Tengo instalado el ubuntu 6.10 AMD64 + Beryl , con el ultimo kernel y los ultimos driver de nvidia que los instale con el archivo oficial de nvidia para que me trabajara en el kernel mas reciente. Si pudieras ayudarme te lo agradeceria (llevo solo 8 dias con ubuntu :))

He isntaldo el paquete que esta aca http://biza.wordpress.com/2007/01/30/wine-0930-en-amd64-debian que es la version 0.9.30 instala bien pero tengo problemas con las fuentes,no aparecen biem y tengo isntado el paquete de las fuentes de ms, y siguen igual de feas y no se pueden leer los menues de las apalicaciones de windows.

SI alguien me pudiera ayudar se lo agradeceria :)

+1
0
-1
Imagen de elmateador
+1
0
-1

Hola chicos.... la verdad es que hay muchos link rotos, o sea que no puedo entrar a las teóricas soluciones que dan.

 

Saludos y sigamos que de alguna manera AMD64 debe poder funcionar enWiner. 

+1
0
-1
Imagen de r2d2
+1
0
-1

WineHQ - Ubuntu 7.04 "Feisty Fawn"

http://wine.budgetdedicated.com/apt

este repositorio te permite instalar wine instalando librerias32, y tb permite usr otras aplicaciones win-32b

+1
0
-1