Aceleracion 3D con ATI Radeon 7000, error glxgears

Imagen de jgarcia1709
0 puntos

Bajo Ubuntu 6.10

Hola, escribo esto después de llevar días consultando en foros y páginas para configurar el soporte 3D de mi tarjeta gráfica ATI Radeon 7000 y no conseguir que funcione, al parecer no necesito intalar los drivers de ATI (fglrx), pues mi tarjeta esta totalmete soportada por el driver libre de linux, ver: https://help.ubuntu.com/community/RadeonDriver .Aunque me ocurre el mismo problema en otro ordenador con una ATI 9200 PRO.

Resulta que las aplicaciones 3D hacen que se me cuelgue todo el sistema, y en particular el comando glxgears me devueve lo siguiente:

javi@ubuntu:~$ glxgears
libGL warning: 3D driver claims to not support visual 0x4b

Las ruedecitas siguen girando indefinidamente hasta que cierro la ventana, pero luego no me devuelven los FPS.

He probado mil configuraciones del archivo xorg.conf sin cambios aparentes con ninguna (reiniciando, claro), adjunto el contenido del fichero abajo.

Muchas gracias por adelantado por su ayuda.

---------------------------------------------------------------------------

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
FontPath "/usr/share/X11/fonts/misc"
FontPath "/usr/share/X11/fonts/cyrillic"
FontPath "/usr/share/X11/fonts/100dpi/:unscaled"
FontPath "/usr/share/X11/fonts/75dpi/:unscaled"
FontPath "/usr/share/X11/fonts/Type1"
FontPath "/usr/share/X11/fonts/100dpi"
FontPath "/usr/share/X11/fonts/75dpi"
FontPath "/usr/share/fonts/X11/misc"
# path to defoma fonts
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "i2c"
Load "bitmap"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "type1"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "es"
Option "XkbOptions" "lv3:ralt_switch"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ExplorerPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "stylus"
Option "Device" "/dev/wacom" # Change to
# /dev/input/event
# for USB
Option "Type" "stylus"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "eraser"
Option "Device" "/dev/wacom" # Change to
# /dev/input/event
# for USB
Option "Type" "eraser"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "cursor"
Option "Device" "/dev/wacom" # Change to
# /dev/input/event
# for USB
Option "Type" "cursor"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "Device"
Identifier "ATI Technologies, Inc. Radeon RV100 QY [Radeon 7000/VE]"
Driver "ati"
BusID "PCI:1:0:0"
###############################################añadidas por mi
Option "XAANoOffscreenPixmaps"
Option "AGPMode" "4"
# Option "AGPFastWrite" "yes"
# Option "RenderAccel" "on"
Option "AccelMethod" "XAA" # or EXA
Option "ColorTiling" "on"
###############################################añadidas por mi fin
EndSection

Section "Monitor"
Identifier "SDM-HS73P"
Option "DPMS"
###############################################añadidas por mi (ajuste monitor)
Modeline "1280x1024" 108.00 1280 1336 1448 1688 1024 1025 1028 1066 +hsync +vsync
###############################################añadidas por mi fin
EndSection

Section "Screen"
Identifier "Default Screen"
Device "ATI Technologies, Inc. Radeon RV100 QY [Radeon 7000/VE]"
Monitor "SDM-HS73P"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1280x1024" "1024x768" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1280x1024" "1024x768" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x1024" "1024x768" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1280x1024" "1024x768" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x1024" "1024x768" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024" "1024x768"
EndSubSection
EndSection

Section "ServerLayout"
###############################################añadidas por mi
Option "AIGLX" "true"
###############################################añadidas por mi fin
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "stylus" "SendCoreEvents"
InputDevice "cursor" "SendCoreEvents"
InputDevice "eraser" "SendCoreEvents"
EndSection

Section "DRI"
Mode 0666
EndSection

###############################################añadidas por mi
Section "Extensions"
Option "Composite" "Enable"
EndSection
###############################################añadidas por mi fin

-------------------------------------------------------------

Imagen de Anónimo
+1
0
-1

Me pasa lo mismo
libGL warning: 3D driver claims to not support visual 0x4b
hasta ahora solo he conseguido congelar el PC y conocer la legendaria pantalla azul que me dice que no se puede iniciar el servidor x
Si alguen sabe activar la aceleracion para esta tarjeta se lo agradeceria

+1
0
-1
Imagen de el64
+1
0
-1

Creo que el fglrx ni lo puedes usar. No he buscado nada sobre tu tarjeta, pero sospecho que te tendrás que olvidar del aiglx. Una cosa es tener la aceleración 3D y otra cosa es ponerse el beryl. Lo de "libGL warning: 3D driver claims to not support visual 0x4b" viene a decir que te olvides de beryl porque el controlador no incluye ciertas características(aun). Así que, en la última linea, Option "composite" "disable". Unas cuantas antes, Option "AIGLX" "false". Para que salgan los fotogramas por segundo, tienes que poner "glxgears -printfps".
Mira esto sobre una tnt2 probando una xubuntu, hay algunas cosas que te servirán.
_________________________
Mas información en...
el64.blogspot.com
_________________________
CUIDADO: NO COMPRES dispositivos con DRM.

+1
0
-1
_________________________
Mas información en... el64.blogspot.com
_________________________
CUIDADO: NO COMPRES dispositivos con DRM.
Imagen de Anónimo
+1
0
-1

Hola, tengo una X600 y me sale el mismo error "visual 04b", pero tengo aceleración 3D y Beryl funcionando. Las diferencias en mi xorg.conf son que en vez del driver "ati" yo utilizo el driver "radeon", y en esa misma sección no tengo las lineas añadidas por tí.
Si has intentado instalar el driver propietario de ati "fglrx" tendras que eliminar toda existencia de el en la maquina pues si no tendras conflictos con el driver libre.
Espero que te sirva de algo.
goyito666

+1
0
-1