¿Cómo instalar Gambas2?

Imagen de cologarc1
0 puntos

Alguien podría decirme como instalar el Gambas2 , o mejor dicho instalar todas las depencias de los paquetes de gp. No encuentro el modo. Gracias ante todo y felices fiestas y que el año que viene desbanquemos al gigante mico-chof.

Imagen de Anónimo
+1
0
-1

nadie sabe como instalar gambas2? o es que esta versión no funciona? me gustaria saber algo. gracias por la paciencia

+1
0
-1
Imagen de pochu
+1
0
-1

gambas2 todavía es beta, por lo que no está en los repositorios. Puedes instalar la última versión estable desde los repositorios, o si necesitas la versión inestable, compilarla tú mismo, o hacer un .deb (o buscarlo por si alguien ya lo ha hecho).

Saludos
Pochu
------------------------
CÓMOs de la web

+1
0
-1

Saludos Pochu ------------------------ CÓMOs de la web

Imagen de Cristobal López
+1
0
-1

Según la web de Gambas, abre terminal y escribe:

$ sudo apt-get install autoconf libtool automake1.9 build-essential

E instalar qt3.2.
Lo puedes instalar desde synaptic
Para instalar:

$./configure -C
$make
$sudo make install

Y ya está. Si falta algo más que lo pongan en su web.
Saludos y suerte :smile:

P.D. Parece bastante inestable, mejor instala la que viene en synaptic y espérate a que sea estable y aparezca en los repositorios.

MiBlog
MiWeb

+1
0
-1
Imagen de cologarc1
+1
0
-1

He seguido las directrices que me ha comentado nuestro amigo Cristobal López y ha funcionado. He instalado la versión del gambas2 1.9.46. Al instalarlo de todas maneras no lo ha incorporado al menú de Programación, lo tengo que ejecutar desde la línea de comandos. No es que me importe demasiado , pues al ser una versión inestable, de momento lo he instalado para ver como va. Tiene parece ser cosas bastantes interesantes, como el acceso a las bases de datos generales , postgree , mysql y firebird.

Gracias por todo, seguramente seguiré dando el coñazo por aquí, pues estoy en un mundo nuevo, pero que a la postre es reconfortante, sobre todo el echo mismo de haber tirado el guindous a la basura y disfrutar de este sistema que por otra parte aunque tiene ciertos fallitos, parece robusto y rápido.

+1
0
-1
Imagen de Cristobal López
+1
0
-1

Me alegro de que lo hayas podido instalar con éxito, si quieres crearte un acceso directo en tu escritorio Pincha Aquí.
Saludos

MiBlog
MiWeb

+1
0
-1
Imagen de Anónimo
+1
0
-1

revisa el archivo README, donde dice To compile Gambas, you must install the following libraries on your system :

ahí están el listado de dependencias, tendrás que darte el trabajo de buscar cada una con aptitude o synaptic, y de ahí recién compilar gambas.

suerte :)

+1
0
-1
Imagen de cologarc1
+1
0
-1

Es ahí donde tengo el problema. No consigo dar con las librerías del listado de dependencias.

Perdonadme, pero es que soy un poco novato. ¿Dónde puedo encontrar esas dependencias? Busqué en Debian.org y no lo he encontrado. ¿Qué es lo que estoy haciendo mal (que es lo más segur)?

Sé que es una Beta. Pero parece bastante interesante, pues parece que ha metido controles para firebird. La versión estable se mete sin ningún problema desde los repositorios.

Gracias por la paciencia y Felíz Navidad a todos.

+1
0
-1
Imagen de Anónimo
+1
0
-1

buenas,
hago el ./configure -C del gambas2:

checking for XOpenDisplay in -lX11... (cached) yes
checking for XShmAttach in -lXext... (cached) yes
checking for QT meta-object compiler... no
configure: error: QT moc compiler not found. Try --with-moc option.
configure: error: ./configure failed for gb.qt

y me da este error!!!

por favor si alguien me puede ayudar.

gracias popon

+1
0
-1
Imagen de Cristobal López
+1
0
-1

Abre synaptic e instala desde ahí QT3, luego sigue con lo que estabas haciendo.
Saludos :smile:

MiBlog
MiWeb

+1
0
-1
Imagen de cologarc1
+1
0
-1

Instalando las QT3 te irá bien , además he visto que tiene la posibilidad también abrir un proyecto para Gnome, creo que esta herramienta está evolucionando a pasos agigantados , lo único que no tiene que para mi seria bueno es la herencia en los formularios.

+1
0
-1
Imagen de eroze
+1
0
-1

Hola muchas gracias por la aportacion que hace cada uno de vosotros con las experiencias que hacen que otros con los conocimientos justitos hagamos cosas dificiles de forma mas facil.

Por cierto si me voy a synaptic, y busco qt3, la version que tengo instalada es 3.3.3.6

y cuando me baje, el gambas2, para poder instalarlo me dice que tengo que instalar la version 3.3.3.7 o
superior.

¿de donde se saca una version superior a la que tengo, y por cierto esto va afectar a más aplicaciones?

Gracias a todos.

ErOzE

+1
0
-1
Imagen de Anónimo
+1
0
-1

Necesitas los paquetes libqt3-mt-dev ! Y algunos otros si quieres todos los components de Gambas2.

+1
0
-1
Imagen de Zinnia45
+1
0
-1

Hola,

Reabro el hilo porque llevo unos cuantos días intentando instalar gambas y nada de nada.

He usado synaptic, he instalado gambas con y sin gambas2, y no encuentro nada que pueda ejecutar.

He instalado un paquete desde sourceforge, he compilado y todo, y tampoco hay resultado (gambas-1.0.19.tar.bz2).

He probado también lo que dice en este hilo, he instalado QT3 y silencio total.

¿Qué pasos debo seguir para instalar el dichoso crustáceo?

Tengo el 7.10 en arquitectura AMD64. 

Sigo siendo una novata iletrada...

¡Por favor, una ayudita!

Gracias

+1
0
-1
Imagen de kr105
+1
0
-1

pues como ya saben ubuntu haciendonos las cosas mas faciles, mira yo tengo instalado gambas2 en ubuntu 7.10 y lo instale asi:

abri el firefox -> en la barra de direcciones escribi -> apt://gambas2 -> lugo aparece un cuadro de texto y dale si -> lugo te pide que insertes el disco de ubuntu -> te instala dependencias y todo -> y ya

yo asi lo instale espero te sirva.

+1
0
-1
Imagen de Emeka
+1
0
-1

He hecho todo lo que venia en este foro y no me ha funcionado :/

Desde la consola:

  gambas2: Depende: gambas2-gb-compress-bzlib2 (>= 1.9.49-1) pero no es instalable
           Depende: gambas2-gb-compress-zlib (>= 1.9.49-1) pero no es instalable
           Depende: gambas2-gb-crypt (>= 1.9.49-1) pero no es instalable
           Depende: gambas2-gb-db-firebird pero no es instalable
           Depende: gambas2-gb-db-mysql (>= 1.9.49-1) pero no es instalable
           Depende: gambas2-gb-db-postgresql (>= 1.9.49-1) pero no es instalable
           Depende: gambas2-gb-db-odbc (>= 1.9.49-1) pero no es instalable
           Depende: gambas2-gb-db-sqlite (>= 1.9.49-1) pero no es instalable o
                    gambas2-gb-db-sqlite2 (>= 1.9.49-1) pero no es instalable
           Depende: gambas2-gb-form (>= 1.9.49-1) pero no es instalable
           Depende: gambas2-gb-form-mdi (>= 1.9.49-1) pero no es instalable
           Depende: gambas2-gb-gtk (>= 1.9.49-1) pero no es instalable
           Depende: gambas2-gb-gtk-svg pero no es instalable
           Depende: gambas2-gb-image (>= 1.9.49-1) pero no es instalable
           Depende: gambas2-gb-info (>= 1.9.49-1) pero no es instalable
           Depende: gambas2-gb-ldap (>= 1.9.49-1) pero no es instalable
           Depende: gambas2-gb-net-curl (>= 1.9.49-1) pero no es instalable
           Depende: gambas2-gb-net-smtp (>= 1.9.49-1) pero no es instalable
           Depende: gambas2-gb-opengl (>= 1.9.49-1) pero no es instalable
           Depende: gambas2-gb-pcre (>= 1.9.49-1) pero no es instalable
           Depende: gambas2-gb-pdf (>= 1.9.49-1) pero no es instalable
           Depende: gambas2-gb-qt-ext (>= 1.9.49-1) pero no es instalable
           Depende: gambas2-gb-qt-kde-html (>= 1.9.49-1) pero no es instalable
           Depende: gambas2-gb-qt-opengl pero no es instalable
           Depende: gambas2-gb-sdl (>= 1.9.49-1) pero no es instalable
           Depende: gambas2-gb-settings (>= 1.9.49-1) pero no es instalable
           Depende: gambas2-gb-vb pero no es instalable
           Depende: gambas2-gb-v4l (>= 1.9.49-1) pero no es instalable
           Depende: gambas2-gb-web pero no es instalable
           Depende: gambas2-gb-xml (>= 1.9.49-1) pero no es instalable
           Depende: gambas2-ide (>= 1.9.49-1) pero no es instalable
E: Paquetes rotos
 

Desde FireFox:

 No se pudo instalar 'gambas2' (E: No se pudieron corregir los problemas, ustedha retenido paquetes rotos.)

Desde Synaptic:

 gambas2:
 Depende: gambas2-gb-compress-bzlib2 (>=1.9.49-1) but it is not installable
 Depende: gambas2-gb-compress-zlib (>=1.9.49-1) but it is not installable
 Depende: gambas2-gb-crypt (>=1.9.49-1) but it is not installable
 Depende: gambas2-gb-db-firebird  but it is not installable
 Depende: gambas2-gb-db-mysql (>=1.9.49-1) but it is not installable
 Depende: gambas2-gb-db-postgresql (>=1.9.49-1) but it is not installable
 Depende: gambas2-gb-db-odbc (>=1.9.49-1) but it is not installable
 Depende: gambas2-gb-db-sqlite (>=1.9.49-1) but it is not installable o
     gambas2-gb-db-sqlite2 (>=1.9.49-1) pero no es instalable
 Depende: gambas2-gb-form (>=1.9.49-1) but it is not installable
 Depende: gambas2-gb-form-mdi (>=1.9.49-1) but it is not installable
 Depende: gambas2-gb-gtk (>=1.9.49-1) but it is not installable
 Depende: gambas2-gb-gtk-svg  but it is not installable
 Depende: gambas2-gb-image (>=1.9.49-1) but it is not installable
 Depende: gambas2-gb-info (>=1.9.49-1) but it is not installable
 Depende: gambas2-gb-ldap (>=1.9.49-1) but it is not installable
 Depende: gambas2-gb-net-curl (>=1.9.49-1) but it is not installable
 Depende: gambas2-gb-net-smtp (>=1.9.49-1) but it is not installable
 Depende: gambas2-gb-opengl (>=1.9.49-1) but it is not installable
 Depende: gambas2-gb-pcre (>=1.9.49-1) but it is not installable
 Depende: gambas2-gb-pdf (>=1.9.49-1) but it is not installable
 Depende: gambas2-gb-qt-ext (>=1.9.49-1) but it is not installable
 Depende: gambas2-gb-qt-kde-html (>=1.9.49-1) but it is not installable
 Depende: gambas2-gb-qt-opengl  but it is not installable
 Depende: gambas2-gb-sdl (>=1.9.49-1) but it is not installable
 Depende: gambas2-gb-settings (>=1.9.49-1) but it is not installable
 Depende: gambas2-gb-vb  but it is not installable
 Depende: gambas2-gb-v4l (>=1.9.49-1) but it is not installable
 Depende: gambas2-gb-web  but it is not installable
 Depende: gambas2-gb-xml (>=1.9.49-1) but it is not installable
 Depende: gambas2-ide (>=1.9.49-1) but it is not installable

 

¿Qué hago mal? ¿Es problema mio?

Uso la versión 8.04 desde hace 5 días...

 

Gracias

+1
0
-1
Imagen de caicer78
+1
0
-1

Antes que nada un saludo a todos, mi problema es el siguiente, estoy tratando de instalar gambas2 en mi ubuntu 8.04 amd64, seguí las instrucciones que que da la pagina de gambas para la instalación en ubuntu... las cuales son...
instalar las siguientes librerías.

“$ sudo apt-get install build-essential g++ automake autoconf libbz2-dev libgnorba-dev libfbclient2 libmysqlclient15-dev
unixodbc-dev libpq-dev libsqlite0-dev libsqlite3-dev libgtk2.0-dev libldap2-dev libcurl3-dev libgtkglext1-dev
libqt3-mt-dev kdebase-dev libpcre3-dev libsdl-sound1.2-dev libsdl-mixer1.2-dev libsdl-image1.2-dev libsage-dev
libxml2-dev libxslt1-dev build-essential libbonobo2-dev libcos4-dev libomniorb4-dev firebird2.0-dev librsvg2-dev
libpoppler-dev libpoppler-dev libpoppler-glib-dev libasound2-dev libartsc0-dev libesd0-dev libesd-alsa0 libdirectfb-dev
libaa1-dev libarts1-dev kdelibs4-dev libffi4-dev libxtst-dev gettext”

luego bajar y copiar los archivos fuente en “/usr/src/gambas2-2.6.0(es la versión que use de gambas es la 2.6.0)” y luego dentro de esa dirección realizar lo siguiente:
“$ cd /usr/src/gambas2-2.6.0
$ sudo ./configure -C
$ sudo make
$ sudo make install”

lo cual al parecer no genera ningun error, sin embargo quiero ejecutarlo me marca el siguiente error...
”ERROR: #27: Cannot load component 'gb.qt': cannot find library file”

algo que no te es que cuando realizo la configuración me aparece lo siguiente:

“THESE COMPONENTS ARE DISABLED:

- gb.corba

- gb.db.firebird

- gb.db.odbc

- gb.db.postgresql

- gb.db.sqlite2

- gb.db.sqlite3

- gb.desktop

- gb.net.curl

- gb.opengl

- gb.pcre

- gb.pdf

- gb.qt

- gb.qt.kde

- gb.qte

- gb.sdl

- gb.sdl.sound

entre esos componentes que deshabilita esta el que al final cuando ejecuto el programa me indica que falta... entonces que esta pasando? Alguien que pueda asesorarme para solucionarlo, aya que quiero crear programas para este sistema como lo hacia y sigo haciendo en guindos con VB, Esta de mas decir que soy nuevo en ubuntu. Te antemano muchas gracias por toda la ayuda que brinden.
P.D. Disculpen por el pequeño testamento que coloque, ya que trate de que no quede nada en duda en cuanto los pasos que realice :D

+1
0
-1
Imagen de pedroen
+1
0
-1

Hola:
Hace ya un rato que deseaba postear pidiendo una guía para instalar gambas2. (hay que leer primero...)
Pues hoy (30-5-2008) ingrese a los foros de desarroyo y me encontre con este hilo; Segui los pasos que da kr105 abrí firefox y en la barra de direccion ingrese apt://gambas2 clickie enter y efectivamente salió un dialogo al que clickie "si" y comenzó a instalar gambas2, terminó y abrí desde aplicaciones-> Programación-> Gambas2 y listo; hasta ahí todo va bien; no lo he escudriñado, aún no se como funcione pero ya despues saldrá. no me pidió nada. yo uso ubuntu 8.04, pentium d a 3.2mhz y 512mb en memoria.
Gracias a todos por sus respuestas. Los que aún tienen dudas sigan posteando que seguramente encontrarán su respuesta, no desesperen.
Saludos.

+1
0
-1

"Vengan todos a mí, y los haré libres"

Imagen de hjmelgarr
+1
0
-1

Para instalar Gambas2 en hardy, yo hice lo siguiente:

Agregué esta linea al final del archivo /etc/apt/sources.list

deb http://azores.linex.org/gambas-other/ hardy main

luego en una terminal hice el consabido

apt-get update

y luego:

apt-get install gambas2

Y se instaló sin problemas.

El problema lo tengo ahora, porque no hay mucha ayuda para crear y compilar un proyecto.
Pero eso parece ser tema para otro hilo. Suerte

+1
0
-1
Imagen de squall-leonhart
+1
0
-1

ola termino de instalar gambas2 y cuando lo ejecuto en el terminal me sale este error

ERROR: #2: Cannot load class 'Project': Unable to load class file

como podria solucionarlo,y gracias de antemano.

+1
0
-1