Necesito ayuda para compilar

Imagen de Arkard
0 puntos

Hola gente de la comunidad espero que esten bien y tengan Feliz Año Nuevo!!!

Bueno, mi problema es el siguiente recien tengo Ubuntu y he bajado unas aplicaciones y paquetes de codecs pero estos me piden ser compilados e instalados (Funciones Make e Install) pero resulta que cada vez que doy ./configure me solicita o un paquete o una libreria que no tengo, tambien he descargado algunas librerias y paquetes pero cada vez me pide otra, incluso uno de tantos me pidio tener instalado NASM, otro me dijo que no se encontro algo de "FLEX" y asi muchas cosas; bueno el punto es que me gustaria que me dijeran cuales son todos los paquetes y librerias necesarios para compilar lo que sea.

Gracias y espero su pronta respuesta

Imagen de extremss
+1
0
-1

Cada programa tiene sus dependencias propias, no porque satisfagas las dependencias ahora ya no tendras más ningun problema de compilacion en otros programas.

¿Has probado a instalar esos codecs por otra via? como no dices de que son no te podemos ayudar mucho.
Aun asi te pongo un enlace donde te explican como instalar codecs, sin compilar nada:

http://www.guia-ubuntu.org/index.php/Instalar_codecs_multimedia

+1
0
-1
Imagen de Arkard
+1
0
-1

Pues el paquete de codecs se llama speex, lo baje de codecs-download creo, pero cada vez que le hago el intento de instalarlo me pide algo nuevo, tambien me pasa con aplicaciones como wine o Xwine.

+1
0
-1
Imagen de Cristobal López
+1
0
-1

Puedes hacerlo de otra forma, bájate Speex de este enlace http://www.speex.org/downloads/ , elije el enlace que pone i386-RPM y te lo guardas en tu carpeta personal, luego abre terminal e instala el paquete Alien así:

$sudo apt-get install alien

Una vez instalado, teclea:

$sudo alien -d speex-1.0.5-1.i386.rpm

$sudo dpkg -i speex-1.0.5-1.i386.deb

Y ya está
Saludos :smile:

MiBlog
MiWeb

+1
0
-1
Imagen de Arkard
+1
0
-1

Justo ahora a las 1:25am estaba leyendo acerca del tal alien pero no lo podia instalar, lo que pasa es que tambien tengo los CD's de RedHat y una aplicaicon de Ubuntu me pedia NASM y buscando en los CD de RedHat lo encontre pero venia en extension RPM y lei sobre alien que los convierte a deb, pero el mismo manual recomienda mejor usar los paquetes nativos de Ubuntu, no me dara problemas luego?

+1
0
-1
Imagen de Cristobal López
+1
0
-1

Si instalas Alien como te he dicho no creo, yo he instalado paquetes con alien y no problem.
Si quieres también tienes .deb para tu programa pero no te he puesto enlace alguno antes porque son inestables y hechos para Debian pura y dura.
Saludos

MiBlog
MiWeb

+1
0
-1
Imagen de Arkard
+1
0
-1

Bueno, simple y sencillamente me rindo con el Ubuntu, va a pasar una de 2 cosas:

1- Consigo internet e instalo todo desde internet(Paquetes, Librerias, etc)
2- Consigo Debian Completo, los 17 CD's

Pero gracias de todos modos :D

+1
0
-1