Problemas compilación nuevo kernel

Imagen de ernjive
0 puntos

Hola a todos. Estoy intentando compilar un nuevo nucleo para mi Ubuntu 5.04 , para pasar del 2.6.10 a un 2.6.18, según una guía que hay por aqui(COMO:Compilar un Kernel en Ubuntu) . El problema que tengo es que para poder compilar el nuevo kernel necesito instalar algunos paquetes como el 'kernel-packages' (apt-get install build-essential kernel-package) o el 'libncurses5-dev' (apt-get install libncurses5-dev) y al ejecutar estos comandos me dice que no encuentra dichos paquetes. ¿Sabe alguien que puede pasar?

Muchas Gracias de antemano

Imagen de Goyo
+1
0
-1

El paquete kernel-packages no existe en ninguna versión de Ubuntu. En cambio libncurses5-dev está en el repositorio main, así que no deberías tener problemas para instalarlo. Actualiza la lista de paquetes y vuelve a intentarlo:

$ sudo apt-get update
$ sudo apt-get upgrade
$ sudo apt-get install libncurses5-dev

+1
0
-1
Imagen de ernjive
+1
0
-1

Hola. Ahh, perdona, el paquete es 'kernel-package'.
He hecho lo que dices, pero me sigue diciendo lo mismo:

e80jive@ubuntu:/$ sudo apt-get install libncurses5-dev
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias... Hecho
E: No se pudo encontrar el paquete libncurses5-dev

He leido lo que hace el 'apt-get update' y dice que busca los paquetes en los repositorios que especifiques en el archivo /etc/apt/sources.list. He editado el arhivo y tengo la siguiente linea:

deb cdrom:[Ubuntu 5.04 _Hoary Hedgehog_ - Release i386 (20050407)]/ hoary main restricted

y luego otras de direcciones de Http, pero comentadas. Supongo que es porque no tengo conexión a Internet ( justamente quiero actualizar el nucleo para que me reconozca la tarjeta de red inalambrica, que me indica que el kernel debe ser como minimo de versión 2.6.13+)

¿tendría que meter en algun directorio (por ejemplo, de una partición Windows) los repositorios y luego poner la ruta en el archivo sources.list?si fueran por aqui los tiros, como se haría?

Muchas gracias

+1
0
-1