Configuración de una nultifuncional Epson Stylus CX3700 (Impresora y escaner)

+1
0
-1

Esto es una pequña explicación para hacer funcionar la multifuncional Epson CX3700 (Impresora + escaner), para los que tienen una o han intentado usarla se dieron cuenta que hacer que la impresora funcione es bastante facil, el problema es el escaner. Esto lo hice en Edgy Eft pero las intruciones originales que estan en inglés eran para Dapper Drake, las pueden encontrar en http://www.davidsudjiman.info/?p=122

Mejor comencemos con la explicación. Primero encendamos la impresora y conectemosla a computador, ahora vamos por partes:

1) La impresora: Esta en la lista de impresoras soportadas asi que simplemente nos vamos a Sistema-->Administracion-->Impresora alli nos saldra una ventana en donde nos vamos a impresora-->Añadir impresora y el asiatente la va a detectar y nos va ayudar a configurarla, esto no presenta ningun problema, asi que mejor siguamos con lo mas complicado.

2) El escaner: Extrañamente Xsane no lo detecta asi que vamos a tener que hacer algunos cambios, asi que no se asusten. Lo primero que hay que hacer es abrir el terminal (Aplicaciones-->accesorios-->terminal) una vez abierto escribimos el siguente comando y damos enter:

dmesg

Este comando nos va a mostrar bastante información, pero a nosotros solo nos interesa las lineas que correspoden a tu puerto USB, en mi caso son estas:

[17183898.072000] usb 1-1: new full speed USB device using ohci_hcd and address 2
[17183898.292000] usb 1-1: configuration #1 chosen from 1 choice
[17183898.988000] drivers/usb/class/usblp.c: usblp0: USB Bidirectional printer dev 2 if 1 alt 0 proto 2 vid 0x04B8 pid 0x0818
[17183898.988000] usbcore: registered new driver usblp
[17183898.988000] drivers/usb/class/usblp.c: v0.13: USB Printer Device Class driver

De aquí vamos a obtener informacion que nos va a servir mas adelante asi que fijense bien, sobre todo en la parte que en mi caso dice 0x04B8 pid 0x0818.

Ahora vamos a modificar un archivo de configuracion, para ello escribimos en el terminal:

sudo gedit /etc/sane.d/epson.conf

A continuación nos va a preguntar la clave para modificar el archivo y luego lo abrira para que podamos modificarlo. Ahora una vez que podamos modificar el archivo agregamos la siguente linea, en base a la información que obtuviste anteriormente:

usb 0x04b8 0x0818

Fiejense bien que hay que poner un espacio antes de usb para que funcione. Una vez que modificamos el archivo lo guardamos y salimos. Y eso es todo, ahora inicia Xsane (está en Aplicaciones--> Graficos--> Escaner de imagen Xsane) para comprobar que todo esté bien, y ahora ya podemos usar el scaner de la multifuncional

Fácil y rápido :)

Comentarios

Imagen de RAMON HERNANDEZ JIMENEZ

tengo una lexmark 605 pero perdi el cd de configuracion y quiero que me ayuden a buscarlo o si alguien sabe que me aga el fabor de desirme como le hago para poderla instalar

Imagen de e m i l i a n o

Muchísimas gracias, hace tiempo que necesitaba configurar el scanner del cx3700

Saludos!

e m i l i a n o

e m i l i a n o

Imagen de Eral

Jaja para mi que ubuntu me odia, siempre tuve problemas para hacer andar dispositivos, primero fue el modem, ahora la multifuncion, segui todos los pasos a rajatabla pero cuando abro el XSane me salta una ventanita "no hay dispositivos obtenibles".

Donde agregan la linea " usb 0x04B8 pid 0x0818"?, yo la agregue al final y despues probe al principio. (Curiosamente al igual que el tutorial tengo 0x04B8 pid 0x0818)

¿Alguna idea? 

<a href="http://ubuntucounter.geekosophical.net" title="The Ubuntu Counter Project - user number # 15353"><img src="http://ubuntucounter.geekosophical.net/img/ubuntu-user2.php?user=15353" alt="The Ubuntu Counter

Imagen de e m i l i a n o

Lo que se me ocurre es que estás poniendo "pid", cuando en realidad no hay que hacerlo. Solo tiene que haber un espacio entre los números.

La línea tiene que quedarte así:

usb 0x04B8 0x0818

 

Saludos! 

 

 

e m i l i a n o

e m i l i a n o

Imagen de Eral

Efectivamente, ese era el problema, ahora anda de maravillas, muchas gracias!!

 

Edit: Mi ubuntu es Feisty Fawn asi que la configuracion anda tambien para esta version. 

<a href="http://ubuntucounter.geekosophical.net" title="The Ubuntu Counter Project - user number # 15353"><img src="http://ubuntucounter.geekosophical.net/img/ubuntu-user2.php?user=15353" alt="The Ubuntu Counter

Imagen de Mestizo

Buenas: en primer lugar, gracias por las instrucciones.

 Creo que hice algo mal: tengo una Epson Stylus 3850 e instalé la impresora sin problemas. A continuación, seguí los pasos para el scanner que, sorprendentemente, funcionó dos o tres veces (con baja calidad, por cierto), para luego dejar de hacerlo.

Lo extraño es que ahora no funciona ni la impresora ni el scanner. Desinstalé la impresora para volver a instalarla y ahora el Ubuntu no me la reconoce (ni siquiera aparece en el usbview)!! Y si la instalo manualmente, no funciona.

 Alguien sabe que pudo ocurrir y echarme una mano?

 Gracias

"No quiero pasarme la vida escupiendo lo que soy sobre el espejo de lo que fui"

Imagen de Mestizo

Lo he solucionado de la siguiente manera (por si a alguien le pasa algo similar):

he conectado al puerto usb donde suelo conectar la impersora mi ratón usb. Lo he desconectado y he vuelto a conectar la impresora... y ahora sí, el instalador me la vuelve a reconocer

Eso sí, no me pregunten cómo ha podido ocurrir esto.

Suerte,

 

"No quiero pasarme la vida escupiendo lo que soy sobre el espejo de lo que fui"

Imagen de gatoapilas

Funcionó como lo prometido, rápido y fácil
GRACIAS!

Koke "Gatoapilas" Pardo

Ojo con la mente!

Koke "Gatoapilas" Pardo

Ojo con la mente!

Imagen de aguml

he seguido las instrucciones y no me funciona. Hice esto:
En la consola escribí dmesg y me mostró el listado y me apunté la linea esta que creo que es la que necesito:
[ 7548.576535] usblp0: USB Bidirectional printer dev 10 if 1 alt 0 proto 2 vid 0x04B8 pid 0x0802
Con ese vid y ese pid hice esto:
sudo gedit /etc/sane.d/epson.conf
y añadi la siguiente linea al archivo
usb 0x04b8 0x0802
me aseguré de poner el espacio delante de usb.
Al ver que no funcionaba lei mas abajo en el texto del archivo de configuracion y veo que dice que hay que añadir esto tambien:
usb /dev/usbscanner0
usb /dev/usb/scanner0
asi que lo añadí pero nada, sigue igual, cuando intento escanear me dice que hay un fallo al iniciar el escaner: argumento incorrecto
Ya no se que hacer.
Se me olvidaba decir que desde el principio me lo reconoce como Epson CC-570L, tipo: escaner plano, dispositivo: 7, motor cargado: epson2:libusb: 002, version de sane: 1.0.21

Imagen de rcjorge

el comando dmesg
[ 196.614382] usb 1-2: new high-speed USB device number 4 using ehci_hcd
[ 196.754677] usb 1-2: New USB device found, idVendor=04b8, idProduct=0863
[ 196.754701] usb 1-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 196.754710] usb 1-2: Product: EPSON Epson Stylus Office TX320F Series
[ 196.754717] usb 1-2: Manufacturer: EPSON
[ 196.754723] usb 1-2: SerialNumber: 4D4857593033313878
[ 196.833202] usblp 1-2:1.1: usblp0: USB Bidirectional printer dev 4 if 1 alt 0 proto 2 vid 0x04B8 pid 0x0863
[ 196.833264] usbcore: registered new interface driver usblp
[ 197.886832] usblp0: removed
[ 197.903319] usblp 1-2:1.1: usblp0: USB Bidirectional printer dev 4 if 1 alt 0 proto 2 vid 0x04B8 pid 0x0863

y en la configuración del /etc/sane.d/epson.conf

#usb
usb 0x04B8 0x0863
usb /dev/usbscanner0
usb /dev/usb/scanner0

Pero ejecuto el xsane me dice que no hay dispositivos

Estoy usando Ubuntu 12.04

jrc