De nuevo actualizar a hoary y sin sonido

Ya se que hay muchos post sobre este tema en el foro, y creedme que cuando me ocurrio el problema me los mire todos, pero sigo sin sonido, a mi modo de entender ubuntu configura como tarjeta de sonido por defecto la de la placa base con los drivers oss, y deja a mi pci creative audigy 2 Zs con los controladores alsa.

Probe a cambiar en lo de dispositivos de sonido a la pci por defecto, y configure xmms para que usara alsa como salida, pero nada sigue sin sonido y mplayer no usa alsa, asi que no se que hacer.

La idea es si alguien sabe como hacer para que mi tarjeta de sonido utilice oss en lugar de alsa.

Lo siento por el rollazo, pero estoy por volver a warty :(
Gracias.

Imagen de nak
+1
0
-1

a mi me ocurre lo mismo, me pilla la integrada como tarjeta por defecto y no hay manera de poner la otra. Yo lo que he hecho es en cada aplicacion elegir alsa y luego elegir en dispositivo de audio la pci. por ejem, en xmms eliges como plugin de salida ALSA, le das a Configurar y en Dispositivos de audio cambias Dispositivo por defecto por la PCI, en mplayer eliges OSS y en Configurar eliges como device, /dev/dsp1. La idea es no dejar nunca "driver default" o semejante activado, sino escoger la otra tarjeta o bien por su nombre o por su ruta (dev/dsp1). A ver si esto te sirve, un saludo

+1
0
-1

Enterate de todo sobre cine, música, licores, informática, etc...

 www.quebienteveo.es 

Imagen de bull3tpr00f
+1
0
-1

Pero no lo entiendo, porque tener dos tarjetas de sonido?? si lo que quereis es multiples sonidos simmultaneos miraros esto

http://ubuntuforums.org/showthread.php?t=25548

Existe otro howto en Ubuntuforums.org para este proposito. Buscar un poco y vereis lo util que és.

Salu2

________________________________________
Canal de ayuda: #ubuntu-es [irc.freenode.net]
JabberID: cut0ff@jabberes.org
~ PoloNorte ~

+1
0
-1
Imagen de dragu
+1
0
-1

Soy el que inicio el post, pero estaba en la uni.

Yo no quiero tener dos tarjetas de sonido, es mas por mi ojala ninguna placa base la trajera integrada, el problema es que ubuntu la dectecta y la configura, cuando mi tarjeta pci es 100 veces mejor.

Voy a volver a intentarlo y si no suena de cabeza a warty... aunque hoary me iba mas rapido :(

+1
0
-1
Imagen de nak
+1
0
-1

entonces, si solo quiers tener la pci es mucho mas facil. solo tienes que meterte en la bios y deshabilitarla. yo pense q tu querías conservar las dos tarjetas. un saludo

+1
0
-1

Enterate de todo sobre cine, música, licores, informática, etc...

 www.quebienteveo.es 

Imagen de dragu
+1
0
-1

Es que esto es lo mejor... esta deshabilitada! en fin no se si es para llorar o reir, pero voy a volver a warty.

+1
0
-1
Imagen de bull3tpr00f
+1
0
-1

si no te importa, postea las salidas de los siguientes comandos:

$ lsmod|grep snd
$ cat /etc/modules

Salu2
________________________________________
Canal de ayuda: #ubuntu-es [irc.freenode.net]
JabberID: cut0ff@jabberes.org
~ PoloNorte ~

+1
0
-1
Imagen de dragu
+1
0
-1

Te pongo la salida de warty ahora volvere otra vez.... a hoary y te la vuelvo a pegar.

Salida warty:

dragu@ubuntu:~ $ lsmod | grep snd
snd_emu10k1 99496 3
snd_rawmidi 25664 1 snd_emu10k1
snd_pcm_oss 53864 0
snd_mixer_oss 19744 3 snd_pcm_oss
snd_pcm 99552 2 snd_emu10k1,snd_pcm_oss
snd_timer 26756 1 snd_pcm
snd_seq_device 8296 2 snd_emu10k1,snd_rawmidi
snd_ac97_codec 68772 1 snd_emu10k1
snd_page_alloc 11688 2 snd_emu10k1,snd_pcm
snd_util_mem 4736 1 snd_emu10k1
snd_hwdep 9632 1 snd_emu10k1
snd 57828 12 snd_emu10k1,snd_rawmidi,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer,snd_seq_device,snd_ac97_codec,snd_util_mem,snd_hwdep
soundcore 10688 3 snd
dragu@ubuntu:~ $ cat /etc/modules
# /etc/modules: kernel modules to load at boot time.
#
# This file should contain the names of kernel modules that are
# to be loaded at boot time, one per line. Comments begin with
# a "#", and everything on the line after them are ignored.

sd_mod
sr_mod
psmouse
mousedev
ide-cd
ide-disk
ide-generic
sbp2
lp
fglrx
dragu@ubuntu:~ $

+1
0
-1
Imagen de dragu
+1
0
-1

dragu@ubuntu:~ $ lsmod | grep snd
snd_emu10k1 98532 2
snd_rawmidi 25024 1 snd_emu10k1
snd_seq_device 8716 2 snd_emu10k1,snd_rawmidi
snd_ac97_codec 74336 1 snd_emu10k1
snd_pcm_oss 52836 1
snd_mixer_oss 19968 2 snd_pcm_oss
snd_pcm 95780 3 snd_emu10k1,snd_ac97_codec,snd_pcm_oss
snd_timer 25572 1 snd_pcm
snd_page_alloc 9988 2 snd_emu10k1,snd_pcm
snd_util_mem 4640 1 snd_emu10k1
snd_hwdep 9700 1 snd_emu10k1
snd 56580 9 snd_emu10k1,snd_rawmidi,snd_seq_device,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer,snd_hwdep
soundcore 10400 3 snd
dragu@ubuntu:~ $ cat /etc/modules
# /etc/modules: kernel modules to load at boot time.
#
# This file should contain the names of kernel modules that are
# to be loaded at boot time, one per line. Comments begin with
# a "#", and everything on the line after them are ignored.

sd_mod
sr_mod
psmouse
mousedev
ide-cd
ide-disk
ide-generic
sbp2
lp
fglrx
dragu@ubuntu:~ $

Pd Citar tambien que al arrancar el sistema me da error hw_random y pciehp, con warty solo me daba hw_random
Si ha alguien se le ocurre alguna idea?

+1
0
-1
Imagen de nak
+1
0
-1

no es por tener multiples sonidos (eso ya lo tengo). la historia es que para algunas aplicaciones uso los altavoces normales conectados a la pci pero para el skype prefiero usar unos auriculares. y me resulta mas comodo tenerlos enchufados en el frontal todo el tiempo q no estar cambiando los conectores cada vez q lo uso.

para mi lo perfecto sería tener como tarjeta por defecto la pci y en el skype especificarle la integrada, pero no consigo hacerlo. siempre me pillar por defecto la integrada. asi q la unica solucion que he encontrado es la q puse mas arriba. un saludo

+1
0
-1

Enterate de todo sobre cine, música, licores, informática, etc...

 www.quebienteveo.es