¿Cómo soluciono esto?

Llevo dos días que no puedo instalar nada con apt. Por ejemplo, intento instalar el amor (puestos a perder tiempo...), y me dice:

Se instalarán los siguientes paquetes NUEVOS:
amor
0 actualizados, 1 se instalarán, 0 para eliminar y 310 no actualizados.
Necesito descargar 329kB de archivos.
Se utilizarán 2126kB de espacio de disco adicional después de desempaquetar.
Des:1 http://es.archive.ubuntu.com hoary/main amor 4:3.4.0-0ubuntu1 [329kB]
Descargados 329kB en 1m18s (4210B/s)

Preconfiguring packages ...
Autentificando /var/cache/apt/archives/amor_4%3a3.4.0-0ubuntu1_amd64.deb ...
debsig: Origin Signature check failed. This deb might not be signed.

dpkg: error al procesar /var/cache/apt/archives/amor_4%3a3.4.0-0ubuntu1_amd64.deb (--unpack):
¡Falló la verificación del paquete /var/cache/apt/archives/amor_4%3a3.4.0-0ubuntu1_amd64.deb!
Se encontraron errores al procesar:
/var/cache/apt/archives/amor_4%3a3.4.0-0ubuntu1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Y así con todos los paquetes. Tenía metidos también los repositorios de debian64, para un par de paquetes que no estaban en ubuntu (no me acuerdo cuáles), pero ya los he quitado, y ni haciendo update ni nada, me dice que no puede autenticarlos, con lo cual, no los instala; sólo los descarga y los tengo que instalar a mano con dpkg.

¿Cómo lo arreglo?

Imagen de wraith
+1
0
-1

veamos..

nose si abras probrado ya esto:

sudo apt-get update
sudo apt-get dist-upgrade
sudo apt-get -f install ( si falla dist-upgrade )

salu2:)

Wr4a1th@ubuntu$ /*V1V1eND0 eN BReeZY*/

+1
0
-1

Solo sé que no sé nada.

Imagen de Anónimo
+1
0
-1

No, eso exactamente no. He instentado el apt-get -f install cuando falla alguno de los paquetes que intento instalar. ¿Debería funcionar mejor haciendo el dist-upgrade?

Verás, el problema es que tengo una conexión de 56k, y me tocaría descargar 330 MB. Eso es un día y medio aproximadamente. Si crees que merece la pena el intento, no me lo pienso, pero por probar simplemente, puede ser triste quedarme igual que estaba después de tanto tiempo esperando a que termine.

¿Qué hago?

+1
0
-1
Imagen de Anónimo
+1
0
-1

He hecho el dist-upgrade y sigue igual. Puede ser también un par de paquetes de 32 bits que forcé a instalar los que me hayan vuelto loco el apt. No sé qué hacer, y me da un poco de pereza reinstalar. ¿A nadie le ha pasado esto? Al final, reinstalaré y listo, pero me gustaría tener una idea de la causa, para no volver a meter la pata.

+1
0
-1
Imagen de Anónimo
+1
0
-1

Me faltaba el /etc/apt/apt.conf. Le he puesto uno de ejemplo, y en la sección DPkg, la opción "--no-debsig", con lo que no comprueba si los paquetes están autenticados y los instala sin más problema. Puede ser una burrada, pero funciona. Al fin y al cabo, me fío de los repositorios.

+1
0
-1