Asignar ip estatica

Imagen de javier___
0 puntos

Hola,
estoy configurando una maquina con Ubuntu 5.10 como servidor.
He configurado la interfaz eth0 con ip estatica editando el archivo /etc/networking/interfaces :

iface eth0 inet static
address "alguna ip"
netmask "alguna mascara "
gateway " alguna puerta de enlace"

Como puedo agergar el Dns?, lo hago en el mismo archivo?.
Ayuda por favor.

Muchas gracias.

Imagen de Anónimo
+1
0
-1

Las dns se establecen el el archivo /etc/resolv.conf con el formato:

nameserver aqui.dns.mi.proveedor
nameserver aqui.dns2.mi.proveedor

Un saludo.

Juanjo. AGP

+1
0
-1
Imagen de falceto
+1
0
-1

Hola Juanjo.

Una pregunta estupida, pero no tengo ni idea:
Quiero fijar esa DNS, que significa "nameserver aqui.dns.mi.proveedor" Tengo que poner(p.ej)_"nameserver.aqui.62.81.31.250.ONO"?
Es que no se a q te refieres con lo de mi proveedor y eso.
Supongo por otra paerte que el archivo se modifica con gedit no?

Gracias (y perdon por mi ignorancia)

+1
0
-1
Imagen de jmvidalvia
+1
0
-1

No, basta con poner:
nameserver 87.216.1.65
Si no te quieres molestar en editar el fichero, puedes hacer:
echo "nameserver 87.216.1.65" > /etc/resolv.conf

87.216.1.65 es mi dns de jazztel, solo como ejemplo.

+1
0
-1
Imagen de javier___
+1
0
-1

Gracias juanjo!

+1
0
-1
Imagen de neoraist
+1
0
-1

venia a preguntar eso mismo, así que gracias por adelantado.
Lo que pasa es que si lo intentas hacer desde el gestor de conexiones de gnome, propiedades - ip estatita - tal y cual en el icono que sale arriba, no hace caso. Tampoco me hace caso para configurar la wifi, así que supongo que se tendrá que hacer igual, cambiando eth0 por eth1 y añadiendo essid "mi_essid" key "mi_key" no?

Gracias

+1
0
-1
Imagen de brauntec
+1
0
-1

Hola chic@s,
llevo intentando establecer una ip statica en mi pc d sobremesa 1 mes y algo
aparentemente sencillo se complica, pq al cambiar la ip se queda sin internet.
Pego mi conf de el /etc/network/interfaces:

auto eth0
iface eth0 inet static
address 192.168.1.160
netmask 255.255.255.0
network 192.168.1.0
broadcast 192.168.1.255
gateway 192.168.1.1
nameserver 87.216.1.65 87.216.1.66
y lo mismo para la otra targeta (cambiando la ip).
Reinicio los servicios /etc/init.d/networking restart;
Tengo dhcp en el router pero si lo deshabilito y realizo este proceso estamos igual.

Agradeco cualquier sugerencia, gracias por leerlo
Saludos y R&R

+1
0
-1
Imagen de mottitag
+1
0
-1

Te quedas sin internet porque la linea de codigo: nameserver 87.216.1.65 87.216.1.66 no va en /etc/network/interfaces, sino que la debes colocar en: /etc/resolv.conf
Saludos!!!

+1
0
-1
Imagen de brauntec
+1
0
-1

Hola de nuevo tarde en ver la respuesta,
Hize la prueba sin meter las dns(nameserver 87.216.1.65) en /etc/network/interfaces
y tampoco funcionaba por desesperacion lo prove asi pero tampoco resulto.
Gracias x el intento,Otra sugerencia?
Saludos y R&R

+1
0
-1
Imagen de brauntec
+1
0
-1

Hola chic@s,el original que tenia era el sig con la linea nameserver comentada,
ya que fue un intento x desesperacion que tampoco funciono:

auto eth0
iface eth0 inet static
address 192.168.1.160
netmask 255.255.255.0
network 192.168.1.0
broadcast 192.168.1.255
gateway 192.168.1.1
#nameserver 87.216.1.65 87.216.1.66

Reinicio los servicios /etc/init.d/networking restart;
Y me encuentro en el mismo problema.
Gracias por la sugerencia.
Un saludo y R&R

+1
0
-1
Imagen de akjode
+1
0
-1

el servidor de dns podrias configurarlo en el router y poner como servidor de dns el propio router, de todos modos, yo hace tiempo que no uso los dns de jazztel por una vulnerabilidad que tienen, que permite que sean suplantados por un atacante (no soy muy bueno explicandome) yo uso los de opendns que son un poco mas rapidos 208.67.222.222 y 208.67.220.220 como los introduces, directamente o por linia de comandos?, prueba a hacer ping a una ip externa, por ejemplo a alguna ip de google, (208.69.34.231) i luego ping www.google.com teoricamente con ubuntu te deberia dar el mismo resultado asi sabras si es un problema de dns o de configuracion de red

+1
0
-1
Imagen de Paraguayito
+1
0
-1

Yo tenía el mismo problema, al configurar:

iface eth0 inet static
address 192.168.1.71
netmask 255.255.255.0
gateway 192.52.136.138
nameserver 208.67.222.222 208.67.220.200

me quedaba sin internet.. después de ver varios ejemplos pensé que los 3 primeros grupos de 'address' y de 'gateway' deben ser iguales, es decir:
Si el ip gateway es 192.52.136.138
entonces el ip address debe ser 192.52.136.71

y quedaría así:

iface eth0 inet static
address 192.52.136.71
netmask 255.255.255.0
gateway 192.52.136.138
nameserver 208.67.222.222 208.67.220.200

Y me funcionó!!

Lo importante es saber el IP de nuestro gateway, para ello se utiliza:

ip route show |grep default| awk'{print $3}'

y nos devuelve el IP de nuestro router (gateway), luego solo modificamos el último grupo de dígitos de nuestro IP address.

Sé que esta ayuda no consta de fundamentos (solo soy principiante!!) y creo que sería muy bueno que alguien entendido en esto responda por qué funciona de esta manera (y es demasiado importante saberlo!!). Pero por el momento creo que esta ayuda mía servirá para algún caso de urgencia...

+1
0
-1

Paraguayito

Imagen de CHuLoYo
+1
0
-1

No es más fácil asignar una ip estática a una MAC en el panel de configuración del router y olvidarse de intentarlo por medio de software? A veces, la solución más sencilla es la mejor,

---------
Marcos Pérez
Grupo de aprendizaje de programación

+1
0
-1
Imagen de gasparsi
+1
0
-1

El detalle de asignar una ip estática desde el router o modem ruteador, es que si por alguna razón falla éste dispositivo, ya no se puede ver tu equipo en la red, esto debido a que la dirección no la tiene físicamente tu maquina sino que depende de otro dispositivo.
Por eso a mi parecer, no hay como configurar en el equipo esta dirección, de esta manera, aunque no se tenga el router funcionando, con un simple switch trabaja la red.

Saludos

+1
0
-1
Imagen de gaboubuntu
+1
0
-1

como puedo saber cual es mi problema, que no logro conectarme a internet, hago ping a la puerta de elnace y me funciona, peron no logro navegar, muchas gracias por la ayuda

+1
0
-1
Imagen de Lustorgan
+1
0
-1

Y tu router el que suministra la compañía ¿verdad?

Lo digo porque si es así para empezar tendrás que pensar en cambiar el hardware. No se como lo han montado pero sencillamente si no te da la IP el router no van. Aunque cambiando de router lo puedes arreglar.

+1
0
-1

------------------------------------------

Imagen de gaboubuntu
+1
0
-1

no es de une (epm)en medellin colombia

+1
0
-1
Imagen de Lustorgan
+1
0
-1

usando directamente la IP y no un nombre.
Quiero decir en lugar de ping google.es que requiere el uso de las DNS prueba con ping 216.239.59.104

+1
0
-1

------------------------------------------

Imagen de jonamen
+1
0
-1

necesito configurar una ip estatica la realic desde l modo grafico dando click derecho n la parte superior izq dl scritorio dond stan 2 flechitas

al asignarle la puerta de enlace cuando doy click n aplicar se cambia la direccion que le asigno y se pone en 0.0.0.0 y no m permite conexion como puedo solucionar aquello???

ya realice los pasos que lei en esta ventana y continuo sin conexion

les agradezco su comprension

+1
0
-1
Imagen de CHuLoYo
+1
0
-1

qué puerta de enlace le estás poniendo? Prueba con la IP del router.

Sino lo haces desde el fichero /etc/network/interfaces

Lo abres como root y le configuras una inet static.
Más información: http://www.tribulinux.com/tutoriales-como-configurar-la-red-de-ubuntu-de...

+1
0
-1