screensaver en kubuntu no funciona

Un saludo a todos los ubunteros!

Escribo rapidamente por una inquietud un poco tonta pero molesta para mi.... resulta que el salvapantallas no se activa en mi ubuntu y no se por que !. Al configurar el tema del salvapantallas funciona perfectamente en todos, al hacer una prueba todos van de maravilla!!.. luego lo configuro a 15min para que se active y no ocurre nada!!!
pense quiza que se trataba de alguna opcion en las X ¿?, o en el ahorro de energia de la pantalla.. pero todo parece estar bien.... ¿? no entiendo que ocurre.. alguien le pasa o le ha pasado lo mismo? .... bueno a mi no me gusta no tener salvapantallas cuando es necesario dejarla durante un largo tiempo "inactiva" :S

Tengo tarjeta nvidia configurada perfectamente con 3D, xgl+beryl (pero lo uso eventualmente, es decir entro en kde sin correr el script para beryl...) en kubuntu dapper actualizado a la fecha.

Cualquier comentario al respecto lo agradeceria!

Imagen de Adrian Montoya Lince
+1
0
-1

ningún comentario?.... :( ... esto es un desierto!

Adrián Montoya Lince
Linux User #319165
Ubuntu dapper
Medellin-Colombia

+1
0
-1

Adrián Montoya Lince
Linux User #319165

Imagen de Horus_7
+1
0
-1

a ver comencemos a descartar:

duda 1)  el scrensaver tampoco funciona sin beryl?

 eso implica que el problema es netamente de UBUNTU

 

duda 2) tienes aceleración gráfica si no no podrías ver la vista previa, pero de todos modos puedes checar de esta forma.

 escribe esto en terminal

 $ glxinfo

lo normal seria que en una de las primeras lineas nos lo ponga…en mi caso en la segunda linea sale:

direct rendering: Yes

 ( si no pues instálasela )

 duda 3) antes te funcionaba y dejó de funcionar o nunca lo ha hecho?

 

duda 4) supongo que tmb lo probaste ya a un minuto de tiempo y nada vdd?... tu mouse está en una superficie apropiada? si no puede ser que te ponga algo de movimiento y nunca se cargue el screensaver, para eliminar esta duda, ponlo a un minuto y desconecta el mouse... o dime si usas mousepad y ya.

 

5) no tengo idea de qué pueda ser, pero puedo ayudarte a investigar... sólo dame tiempo, ahorita aqui son las 2:53 am. y debo dormir... 

+1
0
-1
Imagen de Adrian Montoya Lince
+1
0
-1

Gracia por tus comentarios..

1.) Sin y con beryl.. es igual

2.) Aceleracion grafica perfectamente configurada en Nvidia

direct rendering: Yes
server glx vendor string: NVIDIA Corporation
server glx version string: 1.4
......

3.) Funciono solo en la primera instalacion... al reiniciar solo funciona si le doy "prueba" o "bloqueo sesion"

4.) Si claro, a 1 min y tengo mouse pad....

Solo funciona si le doy "prueba" o si bloqueo la sesion. Jamas se activa solo a los minutos que le ponga.. solo se pone la pantalla negra...

estoy por creer que es un "bug" en el driver nvidia? .... seria muy curioso..

 

Linux User #319165

Kubuntu Feisty

 

+1
0
-1

Adrián Montoya Lince
Linux User #319165

Imagen de Horus_7
+1
0
-1

estoy investigando, pero se me acaba de ocurrir... abre Beryl Settings Manager y vete a extras

si tienes el plugin de Screensaver, desmárcalo... 

es solo una pequeña posibilidad.

+1
0
-1
Imagen de Adrian Montoya Lince
+1
0
-1

Actualmente no estoy corrriendo beryl... entro en sesion KDE normal con kwin...

 Probe un script screensaver del amarok y ese si funciona!... me parece que debe ser un bug del screeensavers de kde... esta como raro el asunto... 

 

Linux User #319165

Kubuntu Feisty

+1
0
-1

Adrián Montoya Lince
Linux User #319165

Imagen de Horus_7
+1
0
-1

 de todos modos, me puedes responder la duda de si tienes instalado el plugin de screensaver en beryl? por favor, no me quiero quedar con esa duda.

 

 Es que me llegó a la mente, si tienes todo bien no debes tener problemas por que si genera los screensavers, mas bien es que está bloqueado por alguna manera y no se depliega el screensaver, y lo único que se me ocurrió es que tuvieras activado el plugin de screensaver en beryl (cuando este está activado no se ejectua el screensaver KDE) y que no funcionara bien el de beryl y por eso no ves ningún screensaver....

y con lo que me dijiste de que con el Amarok si funciona, ps puede ser por que es otra aplicación y probablemente el plugin de Beryl no lo bloquea... sólo respóndeme esa duda por favor.

+1
0
-1
Imagen de Adrian Montoya Lince
+1
0
-1

Hola Horus,

Pues estuve buscando y no veo en el manager del beryl ninguna opcion de screensaver...   a donde se supone que debe estar¿

 

Linux User #319165

Kubuntu Feisty

+1
0
-1

Adrián Montoya Lince
Linux User #319165

Imagen de Horus_7
+1
0
-1

Beryl Settings Manager > Extras > Screensaver

 

Está en la misma parte donde se encuentran:

Splash

Nieve

Efecto de Onda

Vistas Previas de las ventanas

Dbus

Capturar pantalla

etc. 

 

 

... si no lo tienes ps es una posibiliad descartada

+1
0
-1
Imagen de Adrian Montoya Lince
+1
0
-1

Hola ... en esa ruta solo tengo activados:

-capturar pantalla

-Dbus

-Splash

-Window previews

no aparece screensaver...

Bueno igual no estoy corriendo beryl cuando entro en la sesion...

 

Linux User #319165

Kubuntu Feisty

+1
0
-1

Adrián Montoya Lince
Linux User #319165

Imagen de Horus_7
+1
0
-1

y qué tal tu gestor de energia? si funciona bien?

 

sistema > Preferencias > Gestor de Energía

+1
0
-1
Imagen de Adrian Montoya Lince
+1
0
-1

El ahorro de energia esta desabilitado....

Esa fue de las primeras cosas que mire... ;)

Esto es un dilema... la verdad no me explico que pueda pasar... no he podido encontrar el programa que esta bloqueando el screensaver.. o la razon porla que no funcione...

De todas maneras gracias por tus comentarios... 

 

Linux User #319165

Kubuntu Feisty

+1
0
-1

Adrián Montoya Lince
Linux User #319165

Imagen de Horus_7
+1
0
-1

lamento mucho no poder ayudarte... pero bueno, de todas formas... una solución temporal y paralela a tu problema, si sabes que vas a estar fuera por mucho tiempo o que se va a quedar ahi toda la noche o lo que sea, ponle donde seleccionas el screensaver y ahi le pones en Vista Previa, te lo pondrá a pantalla completa y listooo!!! jajajajaja

 

como te dije antes, lamento no poder ayudarte en la solución de tu problema pero te doy una alternativa....

 

estaré al pendiente. 

+1
0
-1
Imagen de Adrian Montoya Lince
+1
0
-1

De toda formas muchas gracias por la pacienci ay tus comentarios..

 Realmente es algo muy curioso ese "problema" que tengo con el screensaver, sin embargo realmente no lo es tanto pues si voy a dejar el PC encendido muhco tiempo, bloqueo el teclado y el salvapantallas funciona... de otra forma no se activa..

Solo queria saber si alguien tiene o ha tenido ese mismo problema y encontrar la razon por la cual sucede....

Saludos! 

 

Linux User #319165

Kubuntu Feisty

+1
0
-1

Adrián Montoya Lince
Linux User #319165

Imagen de Janay
+1
0
-1

  Hola.  No sé si esto te servirá, pero yo tenía el mismo problema y lo he arreglado como te cuento.  Adjunto el enlace que me ayudó a resolverlo :  (http://bbs.archlinux.org/viewtopic.php?id=19647).

  Bueno.  La cuestión es que tienes que editar en tu directorio el archivo ~/.kde/share/config/kdesktoprc .  Ahora lo digo para gente de mi mismo nivel, o sea, novatos:  Si tu nombre de usuario es "nombreusuario", el archivo a editar será /home/nombreusuario/.kde/share/config/kdesktoprc       .  Pues bien, debajo de la línea "[ScreenSaver]" pones "DPMS-dependent=false".   Después de eso, a mí me ha vuelto a funcionar.  Tenía el mismo problema, y no estaba usando gestión de energía, así que todavía no imagino qué tendrá que ver el dpms en este caso, pero la cuestión es que hacer esto ha funcionado.

  Por si alguien como yo (novato, insisto) tiene dudas, mi archivo kdesktoprc queda como:

 ##(Otras secciones, hasta la línea 55 o así, y luego lo que sigue.)

 
[ScreenSaver]
DPMS-dependent=false
Enabled=true
Lock=false
LockGrace=60000
Saver=KEuphoria.desktop
Timeout=60

[Version]
KDEVersionMajor=3
KDEVersionMinor=5
KDEVersionRelease=8

 ##(Fin del archivo)

 

  Un saludo, espero que esto te ayude. 
 

+1
0
-1
Imagen de Adrian Montoya Lince
+1
0
-1

 Hola Janay 

 Gracias a tu ayuda se soluciono el problema!!!.. era justo eso!, poner la opcion : DPMS-dependent=false

 

Linux User #319165

Kubuntu Feisty

+1
0
-1

Adrián Montoya Lince
Linux User #319165

Imagen de Janay
+1
0
-1

  Un placer, me alegro de que te haya servido.  Un saludo.

+1
0
-1
Imagen de IRENKA
+1
0
-1

Hola:

Si bien uso otra distribución (Ubuntu Gutsy 7.10), tuve el mismo problema y estaba relacionado con la instalación de los drivers para la placa aceleradora de gráficos. Parece que el sistema salvapantallas por defecto no está preparado para actuar cuando hay aceleración gráfica, y debe actualizarse. Yo entré al Gestor de Paquetes Synaptic e instalé "xscreensaver". Espero que se pueda aplicar a su distribución.

Saludos

 

+1
0
-1
Imagen de niajoma
+1
0
-1

esto me venia pasando hace bastante tiempo y supuse que era algo con la tarjeta ati que tengo porque con la intel de la compu no tenia ningun problema, gracias de nuevo :)

+1
0
-1