Ati y salida TV

Imagen de KapitanKannabis
0 puntos

Aupa, saludos.
Tengo una shappire radeon x800 gto2, procesador amd64 3700 (2200), etc, etc,(no sé si es necesario ponerlo todo...)
Vamos a ver; he seguido los tutoriales para instalar los drivers de ati y he conseguido el tema de la aceleración. No obstante, al intentar lanzar el panel de control de ati me aparece el error siguiente: "/usr/bin/fireglcontrolpanel» (No existe el fichero ó directorio)", cosa que no es cierta porque el mencionado archivo lo he buscado y si que existe.
Intento editar el xorg.conf por el tema de la salida de TV, pero la verdad es que no me aclaro mucho, y no sé que parte corresponde a la TV, al monitor y tal.
Por otro lado las resoluciones máximas que me aparecen 1024x768, son las que puse a la hora de instalar (se me olvidaba) la versión ubuntu6.10 edgy desktop amd 64, pero resulta que el monitor (LG flatron L1952s lcd) está en su resolución nativa, es decir 1280x1024@75hz, y sin tocar nada (mejor).
Bueno, el caso es que a ver si un alma caritativa me puede echar una mano con esto, ya que en la TV veo el escritorio pero en balnco y negro. Pego a continuación mi xorgconf:

Section "Monitor"
Identifier "Generic Monitor"
HorizSync 30.0 - 83.0
VertRefresh 56.0 - 75.0
Option "DPMS"
EndSection

Section "Monitor"
Identifier "aticonfig-Monitor[0]"
Option "VendorName" "ATI Proprietary Driver"
Option "ModelName" "Generic Autodetecting Monitor"
Option "DPMS" "true"
EndSection

Section "Device"
Identifier "ATI Technologies, Inc. Radeon X800 (R430 UO)"
Driver "fglrx"
Option "UseFBDev" "true"
BusID "PCI:1:0:0"
EndSection

Section "Device"
Identifier "aticonfig-Device[0]"
Driver "fglrx"
Option "VideoOverlay" "on"
Option "OpenGLOverlay" "off"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "ATI Technologies, Inc. Radeon X800 (R430 UO)"
Monitor "Generic Monitor"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "Screen"
Identifier "aticonfig-Screen[0]"
Device "aticonfig-Device[0]"
Monitor "aticonfig-Monitor[0]"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

Section "DRI"
Mode 0666
EndSection

Section "Extensions"
Option "Composite" "0"
ENDSection

Imagen de Madset
+1
0
-1

Bueno pues yo ya logre configurar el driver de ATI y tengo aceleración gráfica y el Beryl me esta funcionando pero no se como debo hacer para activar la salida de TV. No tengo ni idea como ponerle en el Xorg para que me detecte el Monitor (CRT) y el TV 21". Cuando conecto la salida de TV al televisor e inicio el Ubuntu se muere con un pantallazo negro y despues cuando reviso el informe de error me dice que detecto ambas pantallas pero que ninguna tenia una configuracion que se pudiera usar. Bueno me gustaria al menos saber como hiciste para activar la salida de TV y que te saliera en Blanco y Nego el TV. Al menos eso sería un comienzo.

+1
0
-1
Imagen de rggrinberg
+1
0
-1

Hola yo tambien siendo nuevo en linux y mas aun en ubuntu, logre instalar el Beryl con el ubuntu 7.04 festy y anda todo bien, pero tampoco tengo habilitada la salida a tv. tengo una Ati radeon 9800se, si alguien sabe o descubre como se habilita desde ya muchisimas gracias!

+1
0
-1
Imagen de pacmanman
+1
0
-1

Mira yo tengo una ati radeon rx9550 y un monitor lcd flatron l1730s conectado a la salida crt de la tarjeta, a veces se veía la tv en blanco y negro, pero solo era cosa de mover un poco el cable s-video de la tarjeta porque la conexión no era total...

Por otro lado ¿qué es lo que deseas? ¿un escritorio extendido entre el lcd y el tv, el mismo escritorio para cada aparato, o cada uno con su escritorio independiente?

Mi distribución de escritorios era la siguiente, la tv al lado izq. del monitor y cada uno con su escritorio independiente, y lo logré de la siguienete manera:

ahora ya no estoy usando el controlador propietario de ati, por lo que no puedo probar los comandos de configuración, pero te puedo poner mi xorg.conf para que saques algunas ideas, si quieres lo reemplazas por completo por el tuyo pero recuerda hacer una copia de respaldo de tu archivo. Suerte.

xorg.conf:

 
# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
    Identifier     "Default Layout"
    Screen      0  "aticonfig-Screen[0]" 0 0
    Screen         "aticonfig-Screen[1]" LeftOf "aticonfig-Screen[0]"
    InputDevice    "Generic Keyboard"
    InputDevice    "Configured Mouse"
    InputDevice    "stylus" "SendCoreEvents"
    InputDevice    "cursor" "SendCoreEvents"
    InputDevice    "eraser" "SendCoreEvents"
EndSection

Section "Files"

    # path to defoma fonts
    FontPath     "/usr/share/fonts/X11/misc"
    FontPath     "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
    FontPath     "/usr/local/share/fonts"
EndSection

Section "Module"
    Load  "bitmap"
    Load  "ddc"
    Load  "dri"
    Load  "extmod"
    Load  "freetype"
    Load  "glx"
    Load  "int10"
    Load  "type1"
    Load  "vbe"
    Load  "dbe"
EndSection

Section "InputDevice"
    Identifier  "Generic Keyboard"
    Driver      "kbd"
    Option        "CoreKeyboard"
    Option        "XkbRules" "xorg"
    Option        "XkbModel" "pc105"
    Option        "XkbLayout" "es"
    Option        "XkbOptions" "lv3:ralt_switch"
EndSection

Section "InputDevice"
    Identifier  "Configured Mouse"
    Driver      "mouse"
    Option        "CorePointer"
    Option        "Device" "/dev/input/mice"
    Option        "Protocol" "ExplorerPS/2"
    Option        "ZAxisMapping" "4 5"
    Option        "Emulate3Buttons" "true"
EndSection

Section "InputDevice"

                                                      # /dev/input/event
                                                      # for USB
    Identifier  "stylus"
    Driver      "wacom"
    Option        "Device" "/dev/wacom"          # Change to
    Option        "Type" "stylus"
    Option        "ForceDevice" "ISDV4"               # Tablet PC ONLY
EndSection

Section "InputDevice"

                                                      # /dev/input/event
                                                      # for USB
    Identifier  "eraser"
    Driver      "wacom"
    Option        "Device" "/dev/wacom"          # Change to
    Option        "Type" "eraser"
    Option        "ForceDevice" "ISDV4"               # Tablet PC ONLY
EndSection

Section "InputDevice"

                                                      # /dev/input/event
                                                      # for USB
    Identifier  "cursor"
    Driver      "wacom"
    Option        "Device" "/dev/wacom"          # Change to
    Option        "Type" "cursor"
    Option        "ForceDevice" "ISDV4"               # Tablet PC ONLY
EndSection

Section "Monitor"
    Identifier   "Generic Monitor"
    HorizSync    28.0 - 51.0
    VertRefresh  43.0 - 60.0
    Option        "DPMS"
EndSection

Section "Monitor"
    Identifier   "aticonfig-Monitor[0]"
    Option        "VendorName" "ATI Proprietary Driver"
    Option        "ModelName" "Generic Autodetecting Monitor"
    Option        "DPMS" "true"
EndSection

Section "Monitor"
    Identifier   "aticonfig-Monitor[1]"
    Option        "VendorName" "ATI Proprietary Driver"
    Option        "ModelName" "Generic Autodetecting Monitor"
    Option        "DPMS" "true"
EndSection

Section "Device"
    Identifier  "Tarjeta de vídeo genérica"
    Driver      "ati"
    VideoRam    256000
    BusID       "PCI:1:0:0"
EndSection

Section "Device"
    Identifier  "aticonfig-Device[0]"
    Driver      "fglrx"
    Option        "VideoOverlay" "on"
    Option        "OpenGLOverlay" "off"
    Option        "EnableMonitor" "crt1,tv"
    Option        "ForceMonitors" "crt1,tv"
    Option      "XAANoOffscreenPixmaps"
    BusID       "PCI:1:0:0"
EndSection

Section "Device"
    Identifier  "aticonfig-Device[1]"
    Driver      "fglrx"
    BusID       "PCI:1:0:0"
    Screen      1
EndSection

Section "Screen"
    Identifier "Default Screen"
    Device     "Tarjeta de vídeo genérica"
    Monitor    "Generic Monitor"
    DefaultDepth     24
    DefaultFbBpp 32
    SubSection "Display"
        Depth     1
        Modes    "1280x1024" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
        Depth     4
        Modes    "1280x1024" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
        Depth     8
        Modes    "1280x1024" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
        Depth     15
        Modes    "1280x1024" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
        Depth     16
        Modes    "1280x1024" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
        Depth     24
        Modes    "1280x1024" "1024x768" "800x600" "640x480"
    EndSubSection
EndSection

Section "Screen"
    Identifier "aticonfig-Screen[0]"
    Device     "aticonfig-Device[0]"
    Monitor    "aticonfig-Monitor[0]"
    DefaultDepth     24
    DefaultFbBpp 32
    SubSection "Display"
        Viewport   0 0
        Depth     24
    EndSubSection
EndSection

Section "Screen"
    Identifier "aticonfig-Screen[1]"
    Device     "aticonfig-Device[1]"
    Monitor    "aticonfig-Monitor[1]"
    DefaultDepth     24
    DefaultFbBpp 32
    SubSection "Display"
        Viewport   0 0
        Depth     24
    EndSubSection
EndSection

Section "DRI"
    Mode         0666
EndSection

Section "Extensions"
    Option        "Composite" "0"
EndSection

-

Saludos

Mi aporte a la comunidad

+1
0
-1
Imagen de Madset
+1
0
-1

Bueno use tu Xorg y le configure unas cosas para que quedara compatible con mi sistema pero no funciono y me toco volver a instalar todo el driver para volver a tener aceleración.

Realmente no tengo ni idea como hacer. Supongo que debo considerar que mi board (ECS Elite Group RS482-M) tiene el video integrado (ATI X200) y que la salida a tv se usa por salida RCA o S-Video. Estas dos salidas no estan instaladas enla board sino que se usa una tarjeta aparte que se pone en un conector especial en la board. No se si todo eso influya. Creo que la forma más facíl de poder usar Ubuntu Beryl Aceleración 3D y Tv-Out es comprando una tarjeta Nvdia pero por el momento no encuentro una solución rápida y efectiva para este problema.

Realmente lo único que necesito es que poder ver peliculas en la pantalla de TV. Asi se configure como sea pero que se pueda. 

+1
0
-1
Imagen de Dubois.rg
+1
0
-1

Madset,

por favor, me puedes decir como instalaste tu ati x200 que te funciona el beryl y la aceleración gráfica?. yo no he logrado hacerla funcionar...

que driver utilizaste? 

gracias de antemano,

 

RGD 

+1
0
-1