Wine y sus dependencias inclumplidas, ¿Ahora que hago?

Imagen de khronos
0 puntos

Buenas noches,
Intente instalar el Wine pero me arroja lo siguiente:


No se pudieron instalar algunos paquetes. Esto puede significar que
usted pidió una situación imposible o, si está usando la distribución
inestable, que algunos paquetes necesarios no han sido creados o han
sido movidos fuera de Incoming.

Como sólo solicito una única operación, es extremadamente posible que el
paquete simplemente no sea instalable y debería de rellenar un informe de
error contra ese paquete.
La siguiente información puede ayudar a resolver la situación:

Los siguientes paquetes tienen dependencias incumplidas:
wine: Depende: libartsc0 (>= 1.5.2-0) pero 1.4.3-0ubuntu1 va a ser instalado
Depende: libasound2 (> 1.0.10) pero 1.0.9-2 va a ser instalado
Depende: libgcc1 (>= 1:4.0.2) pero 1:4.0.1-4ubuntu9 va a ser instalado
Depende: libglib2.0-0 (>= 2.10.0) pero 2.8.3-0ubuntu1 va a ser instalado
Depende: libgphoto2-2 (>= 2.1.6-5.2ubuntu8) pero 2.1.6-1ubuntu6.1 va a s er instalado
Depende: libgphoto2-port0 (>= 2.1.6-5.2ubuntu8) pero 2.1.6-1ubuntu6.1 va a ser instalado
Depende: libstdc++6 (>= 4.0.2-4) pero 4.0.1-4ubuntu9 va a ser instalado
Depende: libxml2 (>= 2.6.24) pero 2.6.21-0ubuntu1 va a ser instalado
E: Paquetes rotos

Ahora no se que debo hacer,¿Alguien me puede auydar?
De ante mano, muchas gracias.

Imagen de nane_13
+1
0
-1

Que repositorios estas usando, prueba con los de la pagina oficial que estan mas actualizados haber si lo solucionas.

Sacado de la pagna oficial de wine:

First, open a terminal window. Then add the repository's key to your system's list of trusted APT keys by copy and pasting the following:

wget -q http://wine.budgetdedicated.com/apt/387EE263.gpg -O- | sudo apt-key add -

Next, add the repository to your system's list of APT sources:

For Ubuntu Edgy (6.10):
sudo wget http://wine.budgetdedicated.com/apt/sources.list.d/edgy.list -O /etc/apt/sources.list.d/winehq.list

Despues haces un apt-get update , para actualzar repositorios y luego ya apt-get install wine
No se si te servira pero por probar, asi ya de paso tienes los repositorios ya añadidos.

+1
0
-1
Imagen de hugolino
+1
0
-1

el error parece ser que en los repositorios sólo encuentra versiones viejas de las librerías de quien depende el wine

tenés activados todos los repositorios (universe y multiverse)? quizás no encuentra las últimas versiones que necesita el programa por eso. si no los activste, andá a Sistema > Administración > Origen del software y tildá universe y multiverse además de lo que esté tildado y luego en el administrador de paquetes synaptic hacé click en Recargar para estar seguro de que está actualizado

si no podés bajar las librerías manualmente, hay una página para descargar paquetes pero no la recuerdo :P

+1
0
-1
Imagen de khronos
+1
0
-1

Tienes toda la razón, las dependencias del wine apestan en versiones mas viejas, instalé Ubuntu 6.10 y todo bien, te agradezco mucho!.

+1
0
-1