Ayuda con Ati Radeon 9800 SE y XGL

Imagen de pacos
0 puntos

Ayudarme pleaseeeeeeeeeeeee
Soy nuevo en linux y me instale Kubuntu Edgy 6.10 por recomendacion de un amigo q lleva varios años con linux.
La cuestion es que quiero instalarme Beryl y no hay manera de que funcione.
He instalado los ultimos drivers de ati para mi Radeon 9800 SE (los 8.34.8 ) y he activado la aceleracion 3D siguiendo este tutorial:

http://69.60.114.106/www.kubuntu-es.org/public_html/?q=node/1499

Todo correcto.Sigo los pasos del tutorial y sin problemas.
Continuo ahora con XGL/Beryl siguiendo el enlace que hay en el anteriormente citado tutorial y todo correcto igualemte.
Y ahora es cuando entra en accion el protagonista estrella: --> INICIAR SESION CON XGL <--
Si inicio sesion con XGL el ordenador no chuta! el escritorio va muy muy muy muy pero q muy lento! no va nada, bueno, si q va pero como sino pq van tan sumamente lento q no puedo hacer nada (para abrir una consola y comprobar si tenia aceleracion 3D, q va a ser q no, me sale Direct rendering = NO, tarda mas de 10 min reales, os lo juro) y no se pq sucede.
Por si sirve de algo, si ejecuto Beryl-manager desde sesion normal KDE, me sale lo siguiente:

pacos@srvkyto-pacos:~$ X Error: BadDevice, invalid or uninitialized input device 168
Major opcode: 148
Minor opcode: 3
Resource id: 0x0
Failed to open device
X Error: BadDevice, invalid or uninitialized input device 168
Major opcode: 148
Minor opcode: 3
Resource id: 0x0
Failed to open device

Y he intentado hacer lo mismo iniciando en sesion XGL, pero me ha sido imposible.
Espero que algun colega q entienda me ayude
Muchas Gracias

Imagen de Jorolo
+1
0
-1

Imagen de pacos
+1
0
-1

Hacer el que? no entiendo
por cierto... falta la mitad del post....

+1
0
-1
Imagen de hugolino
+1
0
-1

hacer lo que habías hecho, no está permitido abrir el mismo tema más de una vez... y menos que menos en menos de 2 minutos 5 temas idénticos

yo te había contestado pero al borrar los demás borraron mi respuesta supongo.. :/

había dicho algo de que pruebes NO agregar la parte de "Composite "0"" en tu xorg.conf porque CREO que el xgl lo necesita

+1
0
-1
Imagen de pacos
+1
0
-1

Lo siento pero no lo savia, lo hice mas q nada pq creia q el tema estaba relacionado con todos los foros en q los puse y como llevo dos semanas posteando y no encuentro respuesta pues era mi ultima carta a ver si alguien me prestaba atencion XD
Repito q no lo volvere hacer, pido disculpas.
Probare lo de quitar el composite "0" a ver q tal y ya os comentare
Muchas gracias

+1
0
-1
Imagen de pacos
+1
0
-1

He quitado lo de composite "0" y almenos ahora puedo trabajar en sesion XGL, va bastante mal, se va atrancando pero funciona, no como antes q se iva muy muy lento.
Pero sigue sin funcionar Beryl, si pongo en consola fglxinfo me sale:
pacos@srvkyto-pacos:~$ fglrxinfo
Xlib: extension "XFree86-DRI" missing on display ":1.0".
display: :0.0 screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.5.1)
y no entiendo esto pq antes de quitar el composite "0" me salia mis drivers Ati.... los 8.34.8...
y si ejecuto glxgears -printfps me sale:
pacos@srvkyto-pacos:~$ glxgears -printfps
Xlib: extension "XFree86-DRI" missing on display ":1.0".
513 frames in 5.5 seconds = 93.164 FPS
600 frames in 6.9 seconds = 86.660 FPS
600 frames in 6.9 seconds = 86.820 FPS
600 frames in 6.9 seconds = 87.048 FPS
600 frames in 6.9 seconds = 87.110 FPS
XIO: fatal IO error 104 (Connection reset by peer) on X server ":1.0"
after 6097 requests (30 known processed) with 0 events remaining.
Muy pocos FPS cuando en sesion normal KDE me sale de media unos 260 - 280 FPS Aprox y en teoria en sesion XGL me tendrian q salir muchos mas....
Espero q podais ayudarme...

+1
0
-1
Imagen de hugolino
+1
0
-1

recién me metí otra vez en el link que dejaste y dice que los drivers no soportan el Composite con DRI y por eso te hacían deshabilitarlo. puede ser que por eso cuando hacés fglrxinfo te cambie Ati por Mesa. probá volviéndolo a poner en: Composite "0".

ahora el error tiene que ver con la extensión "XFree86-DRI" parece.
en el archivo xorg.conf, está comentada la linea "Load DRI" en la sección módulos? podés probar descomentarla en ese caso en ese caso, o comentar la sección de abajo que también hace referencia al DRI, no se me ocurre más, sólo digo cosas que pienso porque no sé ni qué hace el DRI siquiera :P

+1
0
-1