"Volumen no montado" Que no me reconoce un CD vamos...

Imagen de sisq0
0 puntos

Hola.

Después de haber tenido una satisfactoria instalación de Ubuntu, de momento va todo bien.

Pero el otro día quise pasar al portatil donde tengo ubuntu, unos videos que había grabado en un CD (2 videos en formato mpg y avi) y cuando meto el CD parece que lo lee y lo carga, pero no me aparece el icono en el desktop (como suele aparecer cuando reconoce un CD)

Trato de acceder a CD mediante el icono Equipo, pero me dice que la unidad no está montado y pone además esto como posibles causas:

mount: dispositivo de bloques /dev/hdc está protegido contra escritura; se monta como sólo lectura

mount: tipo de sistema de ficheros incorrecto, opción incorrecta,

superbloque incorrecto en /dev/hdc, falta la página de códigos,

o algún otro error

en algunos casos se encuentra información en syslog, pruebe

dmesg | tail o algo parecido

Decir que es un CD que he probado en otros 2 pcs diferentes (ambos con windows) y si lo ha reconocido sin problemas... Fue un CD grabado con Nero en un windows Vista.
Por otro lado, probé un CD con una peli en avi que me grabó un colega, y este lo reconoce sin problemas... QUizás el metodo de grabado del CD que no funciona sea la razón? Creo que fue CD VIDEO-UDF con Nero.

Alguna idea? Es que me tiene un poco tocado la cosa...

salu2 y gracias!

Imagen de Goyo
+1
0
-1

Pues hombre, yo haría una búsqueda con UDF y Ubuntu a ver si sale algo.

+1
0
-1
Imagen de sisq0
+1
0
-1

Perdonadme, tenía que haber buscado antes, pero no se me ocurrió pensar que pudiese haber algún tipo de incompatibilidad (o lo que sea) que obligue a hacer esto...

De todas formas, no se qué ocurre, que cuando trato de montarlo haciendo:

sudo mount -t iso9660,udf /dev/hda /media/cdrom0

me dice:

mount: /dev/hda ya está montado o /media/cdrom0 está ocupado

he tratado de desmontarlo y volver a montarlo y nada...

He probado a montarlo como arriba pero en /dev/hdc tb, ya que no se cóo ver cual es su ruta, pero me dice esto:

mount: dispositivo de bloques /dev/hdc está protegido contra escritura; se monta como sólo lectura
mount: tipo de sistema de ficheros incorrecto, opción incorrecta,
superbloque incorrecto en /dev/hdc, falta la página de códigos,
o algún otro error
En algunos casos se encuentra información en syslog, pruebe
dmesg | tail o algo parecido

Alguna idea?

Un saludo y gracias por la ayuda.

+1
0
-1
Imagen de santi...
+1
0
-1

La primera entrada de una busqueda por udf:

http://www.ubuntu-es.org/index.php?q=node/38488

EDito:..

bueno..eso creo que ya lo habias visto... mira en el fstab a ver que tienes

+1
0
-1

.....................
...Pero no me hagas mucho caso... no soy ningun experto.

Imagen de Goyo
+1
0
-1

A ver, me parece que te estás liando. Tienes que montar /dev/hdc en /media/cdrom0 (o en cualquier otro directorio existente). Para /dev/hdc no debe estar previamente montado y en /media/cdrom0 (o el directorio que sea) no debe haber nada montado. Para asegurarte usa umount dos veces, que vale igual para dispositivos que para directorios. Algo así:

$ sudo umount /dev/hdc
$ sudo umount /media/cdrom0
$ sudo mount -t iso9660,udf /dev/hdc /media/cdrom0

creo que debería funcionar. Aparte el sietema de archivos del CD tendría que ser realmente UDF, que no sé hasta qué punto estás seguro. Tiene que haber un modo de comprobarlo pero no sé cuál puede ser.

+1
0
-1
Imagen de sisq0
+1
0
-1

He seguido los pasos, y...

sudo umount /dev/hdc
umount: /dev/hdc: no montado

sudo umount /media/cdrom0
umount: /media/cdrom0: no montado

sudo mount -t iso9660,udf /dev/hdc /media/cdrom0
mount: dispositivo de bloques /dev/hdc está protegido contra escritura; se monta como sólo lectura
mount: tipo de sistema de ficheros incorrecto, opción incorrecta,
superbloque incorrecto en /dev/hdc, falta la página de códigos,
o algún otro error
En algunos casos se encuentra información en syslog, pruebe
dmesg | tail o algo parecido

Coooonseguido ;)

Tendré que hacerlo siempre que use un CD grabdo en UDF?

salu2 y gracias

+1
0
-1
Imagen de Goyo
+1
0
-1

Casi seguro que sí. Pero puedes hacer un script para simplificar el proceso, que básicamente es poner los comandos en un archivo de texto y... bueno, no sé exactamente pero creo que en la guía Ubuntu viene (pincha en documentación) y si no por ahí hay tutoriales, yo nunca he programado en bash pero en este caso parece fácil. Luego creas un lanzador, lo añades al panel y ya da menos pereza.

+1
0
-1
Imagen de gregorio_brozyna
+1
0
-1

Hola.
Intenta hacer esto:(si usas Gnome)

Con boton derecho en el panel: agregar elemento nuevo - montador de discos. En el icono de CD presionas boton - montar CDrom. Para sacarlo: expulsar. Si no funciona, debes corregir la linea en /etc/fstab
Ojalá te funcione.
Saludos

+1
0
-1