Mi primer pegonazo en Linux, se me desconfiguró la resolución de pantalla y no lo puedo arreglar ¿KDE?

Imagen de carloscv-207
0 puntos

Después de habar bajado unos fondos de pantalla (con la utilidad que tiene Kubuntu en la configuración para eso) se quedó congelada la ventana de configuración. Como no hacía nada reinicié mi computadora con el botón respectivo de Kubuntu. También había reducido la resolución de pantalla de la que trae por defecto a 1024 x 768.

Al ingresar de nuevo me apareció una resolución de pantalla de 400 x 500. Y en la configuración de la pantalla solo permite aumentarla a 600 x 400 (datos aproximados). En modo gráfico no se puede arreglar, lo intenté con línea de comandos y nada http://www.ubuntu-es.org/index.php?q=node/37677

Tengo entendido que Kubuntu ocupa muchos recursos. Mi PC tiene las siguientes características: Procesador Intel 2,3 Mhz. RAM 512 MB. Memoria de video 128 mb (tarjeta Nvidia geforce fx5200). El monitor es CRT Samsung 793s. El disco duro esclavo donde instalé Kubuntu tiene suficiente espacio (35 gigas libres en la partición de linux).

¿Es suficiente ese equipo para correr con fluidez el escritorio KDE?

Ya antes había instalado Ubuntu 6.06 con Gnome y no tuve ningún problema con la tarjeta gráfica o el monitor. La nueva instalación la hice en limpio restaurando el modo de inicio de Windows.

Me gusta más el escritorio KDE que Gnome pues las fuentes tipográficas me resultan más fáciles de leer.

Imagen de YAFU
+1
0
-1

Yo tengo Kubuntu 6.10 y una PC que es la mitad de la tuya, y todo me funciona muy fluido.
Tengo una placa de video ATI, pero también tengo el problema de que cada vez que quiero modificar alguna configuración de pantalla (Resolución, gamma, etc) se me desconfigura todo. Creo que deberías pegar en el foro el contenido de tu archivo "xorg.conf" para ver si alguien te puede ayudar mejor. Para ver el archivo, en consola:
sudo kate /etc/X11/xorg.conf

+1
0
-1
Imagen de carloscv-207
+1
0
-1

Muchas gracias por su respuesta. Voy a probar más tarde. Mi horario es -6 GMT.

Los códigos que utilicé para reparar el problema son

Primer intento sudo gedit /etc/X11/xorg.conf

Segundo intento sudo dpkg-reconfigure -phigh xserver-xorg

En ninguno de los dos casos el sistema hizo nada.

Si alguien me da una solución con líneas de comando bien. Pero si el sistema no responde es probable que se necesite otra instalación en limpio.

+1
0
-1
Imagen de FaZerS
+1
0
-1

Saludos,

¿Has actualizado hoy tu Kubuntu?
Es que si tenias activada la aceleración gráfica posiblemente ese sea el motivo, debes reconfigurar el driver.
A mi me ha pasado lo mismo hoy con mi Ubuntu (NVidia GFX5500), he actualizado y el escritorio se ha quedado congelado, al reiniciar me ha dado error en las X.
Solución: reconfigurar
Como la aceleración la había hecho con ENVY solo he tenido que logearme en la consola y teclear sudo envy, en un par de minutos ya estaba todo solucionado.

Ubuntu 6.10 Edgy Eft
Linux user #409870
Ubuntu user #4082

+1
0
-1

Ubuntu 10.10 Maverick Meerkat
Linux user #409870 Ubuntu user #4082

Imagen de carloscv-207
+1
0
-1

La tarjeta y el monitor si están bien detectados, copio una parte del "xorg.conf"

Section "Screen"
Identifier "Default Screen"
Device "NVIDIA Corporation NV34 [GeForce FX 5200]"
Monitor "SyncMaster"
DefaultDepth 24
SubSection "Display"
depth 24
virtual 640 480
modes "640x480@60"
EndSubSection
EndSection

El problema me sale en sudo "dpkg-reconfigure -phigh xserver-xorg", un mensaje de error en el driver, pero como la pantalla está en 340 x 600 me resulta imposible trabajar y buscar como bajarlo. En automatix se encuentra pero así no lo puedo instalar.

Creo que tendré que instalar en limpio de nuevo.

En KDE de acuerdo a mi máquina es peligroso cambiar al mismo tiempo el Wallpaper y la resolución del monitor. Además del aparente problema del driver.

Y también debo buscar el infamante "Alt Ctrl Supr", aquí encontré la solución.
http://linux-altctrlsupr.notlong.com
No vuelvo a reiniciar con una ventana congelada. Las manías que uno arrastra del Windows.

+1
0
-1
Imagen de YAFU
+1
0
-1

Lo mas seguro es que se te haya modificado el contenido del archivo xorg.conf, que es algo que pasa muy a menudo en kubuntu edgy, por lo que te recomiendo que antes de intentar con una instalación nueva, intentes resolverlo modificando algúnas líneas de ese archivo.
Para ver y modificar ese archivo se utiliza en Gnome la instrucción:
sudo gedit /etc/X11/xorg.conf
Pero esta no funciona en KDE (kubuntu), por lo que tienes que usar:
sudo kate /etc/X11/xorg.conf

Luego puedes buscar en google una parte del contenido de ese archivo para ver si alguien que tenga nvidia y monitor syncmaster, ha tenido el mismo problema:
en google:"Section "Screen" Identifier "Default Screen" Device "NVIDIA Corporation NV34" "Monitor "SyncMaster""

y nos sale por ejemplo:
http://www.chilehardware.com/foro/drama-con-beryl-t64908.html

Solo para tener una idea de la estructura, no tiene por que ser igual los contenidos de los archivos.
Entonces lo que haría yo es primero hacer un backup del archivo xorg.conf que ya tienes (Copiandolo de /etc/X11 a otro lugar) y luego modificar el archivo abriéndolo con:

sudo kate /etc/X11/xorg.conf

Editando y reemplazando la parte que has puesto en tu post por:

Section "Screen"
Identifier "Default Screen"
Device "NVIDIA Corporation NV34 [GeForce FX 5200]"
Monitor "SyncMaster"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
EndSection

Guardas el archivo y reinicias.
Si funcionas y estas conforme, lo dejas así, sino puedes probar también agregando las siguientes lineas que seguramente son opciones de la tarjeta nvidea:

Option “RenderAccel” “True”

Option “RenderAccel” “True”
Option “AddARGBGLXVisuals” “True”
Option “DisableGLXRootClipping” “True”

Section “Extensions”
Option “RENDER” “Enable”
Option “Composite” “Enable”
EndSection

Poniéndolas en el el correcto lugar tal cual sale en esta página:
http://dudas.wordpress.com/2006/12/05/ubuntu-facil-12-como-saber-si-tene...

+1
0
-1