Ruby 1.8 - GLib error

Imagen de Akhram
0 puntos

Tengo un problema al ejecutar gnome-art, se ejecuta y sale en pantalla pero al intentar descargar un engine se cierra solo. Lo he ejecutado en el terminar para ver la salida que daba y es la siguiente:

Nada más ejecutar: $ gnome-art
/usr/lib/ruby/1.8/glib2.rb: line 55
GLib-GObject-CRITICAL **:g_boxed_type_register_static: assertion `g_type_from_name (name) == 0' failed
/usr/lib/ruby/1.8/glib2.rb: line 55
GLib-GObject-CRITICAL **:g_param_spec_boxed: assertion `G_TYPE_IS_BOXED (boxed_type)' failed
/usr/lib/ruby/1.8/glib2.rb: line 55
GLib-GObject-CRITICAL **:g_object_class_install_property: assertion `G_IS_PARAM_SPEC (pspec)' failed
/usr/lib/ruby/1.8/glib2.rb: line 55
GLib-GObject-CRITICAL **:g_param_spec_boxed: assertion `G_TYPE_IS_BOXED (boxed_type)' failed
/usr/lib/ruby/1.8/glib2.rb: line 55
GLib-GObject-CRITICAL **:g_object_class_install_property: assertion `G_IS_PARAM_SPEC (pspec)' failed

Y al pulsar "Download only": Gtk-WARNING **:Failed to set text from markup due to error parsing markup: Error·en la línea·2:·El carácter « »·no es válido al inicio del nombre de una entidad; el carácter «&» inicia una entidad; si el signo '&' no debiera ser una entidad, escápela como &
/usr/lib/ruby/1.8/rexml/encoding.rb: line 37
Gtk-WARNING **:Failed to set text from markup due to error parsing markup: Error·en la línea·2:·El carácter « »·no es válido al inicio del nombre de una entidad; el carácter «&» inicia una entidad; si el signo '&' no debiera ser una entidad, escápela como &
/usr/lib/ruby/1.8/rexml/encoding.rb: line 37
Gtk-WARNING **:Failed to set text from markup due to error parsing markup: Error·en la línea·2:·El carácter « »·no es válido al inicio del nombre de una entidad; el carácter «&» inicia una entidad; si el signo '&' no debiera ser una entidad, escápela como &
/usr/lib/ruby/1.8/rexml/encoding.rb: line 37
Gtk-WARNING **:Failed to set text from markup due to error parsing markup: Error·en la línea·2:·El carácter « »·no es válido al inicio del nombre de una entidad; el carácter «&» inicia una entidad; si el signo '&' no debiera ser una entidad, escápela como &
/usr/lib/ruby/1.8/rexml/encoding.rb: line 37
Gtk-WARNING **:Failed to set text from markup due to error parsing markup: Error·en la línea·2:·El carácter « »·no es válido al inicio del nombre de una entidad; el carácter «&» inicia una entidad; si el signo '&' no debiera ser una entidad, escápela como &
/usr/lib/ruby/1.8/rexml/encoding.rb: line 37
Gtk-WARNING **:Failed to set text from markup due to error parsing markup: Error·en la línea·2:·El carácter « »·no es válido al inicio del nombre de una entidad; el carácter «&» inicia una entidad; si el signo '&' no debiera ser una entidad, escápela como &
/usr/lib/ruby/1.8/rexml/encoding.rb: line 37
Gtk-WARNING **:Failed to set text from markup due to error parsing markup: Error·en la línea·2:·El carácter « »·no es válido al inicio del nombre de una entidad; el carácter «&» inicia una entidad; si el signo '&' no debiera ser una entidad, escápela como &
/usr/lib/ruby/1.8/rexml/encoding.rb: line 37
Gtk-WARNING **:Failed to set text from markup due to error parsing markup: Error·en la línea·2:·El carácter « »·no es válido al inicio del nombre de una entidad; el carácter «&» inicia una entidad; si el signo '&' no debiera ser una entidad, escápela como &
/usr/lib/ruby/1.8/rexml/encoding.rb: line 37
Gtk-WARNING **:Failed to set text from markup due to error parsing markup: Error·en la línea·2:·El carácter « »·no es válido al inicio del nombre de una entidad; el carácter «&» inicia una entidad; si el signo '&' no debiera ser una entidad, escápela como &
/usr/lib/ruby/1.8/rexml/encoding.rb: line 37
Gtk-WARNING **:Failed to set text from markup due to error parsing markup: Error·en la línea·2:·El carácter « »·no es válido al inicio del nombre de una entidad; el carácter «&» inicia una entidad; si el signo '&' no debiera ser una entidad, escápela como &
/usr/lib/ruby/1.8/rexml/encoding.rb: line 37
Gtk-WARNING **:Failed to set text from markup due to error parsing markup: Error·en la línea·2:·El carácter « »·no es válido al inicio del nombre de una entidad; el carácter «&» inicia una entidad; si el signo '&' no debiera ser una entidad, escápela como &
/usr/lib/ruby/1.8/gnome-art/gnome_art.rb:132: [BUG] Segmentation fault
ruby 1.8.4 (2005-12-24) [i486-linux]

Cancelado

Bien, con con esto deduzco que el problema viene ruby y/o glib así que lo que hago es en primer lugar y ya que no tengo ningún programa dependiente de ruby para ahorrarme problemas desinstalar [incluidos ficheros de configuración] todos los paquetes que tienen que ver con gnome-art y posteriormente reconfigurar libc6 [dpkg-reconfigure libc6]. Posteriormente reinstalar gnome-art.

Esto no tiene ningún efecto y el problema sigue siendo exactamente el mismo... sigo buscando y pruebo lo siguiente $ ruby -v
ruby 1.8.4 (2005-12-24) [i486-linux]
ruby -r gtk2 -e 'p Gtk::VERSION'
/usr/lib/ruby/1.8/glib2.rb: line 55
GLib-GObject-CRITICAL **:g_boxed_type_register_static: assertion `g_type_from_name (name) == 0' failed
/usr/lib/ruby/1.8/glib2.rb: line 55
GLib-GObject-CRITICAL **:g_param_spec_boxed: assertion `G_TYPE_IS_BOXED (boxed_type)' failed
/usr/lib/ruby/1.8/glib2.rb: line 55
GLib-GObject-CRITICAL **:g_object_class_install_property: assertion `G_IS_PARAM_SPEC (pspec)' failed
/usr/lib/ruby/1.8/glib2.rb: line 55
GLib-GObject-CRITICAL **:g_param_spec_boxed: assertion `G_TYPE_IS_BOXED (boxed_type)' failed
/usr/lib/ruby/1.8/glib2.rb: line 55
GLib-GObject-CRITICAL **:g_object_class_install_property: assertion `G_IS_PARAM_SPEC (pspec)' failed
[2, 10, 6]

La salida final [2, 10, 6] es correcta pero el error vuelve a aparecer. Mi conclusión es que se trata de un bug y no de un fallo de configuración o utilización, ¿Qué pensais vosotros?

¿Alguna alternativa a esperar revisión del paquete? No he mencionado que mi distribución es Edgy Eft.

Imagen de tziloarca
+1
0
-1

A mi me da el mismo problema al tratar de descargar un theme o cualquier otra cosa, he buscado por todas partes, pero no encuentro solucion.  Otra cosa es que yo tambien tengo ruby instalado, ese sera el problema??, nose tambien necesito ayuda....  sobre todo porque quiero que esten tanto ruby como el gnome-art funcionando al mismo tiempo

+1
0
-1

Estuardo Larca