Openoffice 2.1 se me resiste

Imagen de linxgalaico
0 puntos

Esto que voy a contar puede parecer cosa de tontos, pero, a veces creo que es verdad.

Hace ya un tiempo solicité ayuda para la actualización de mi Openoffice 2.0.4 al 2.1, dado que nadie respondía me busqué la vida y hete ahí que lo encontré y, es más, lo publiqué en esta sección para poder ayudar a otros con el mismo problema.

La sorpresa fue mayúscula cuando comienzo con el proceso de convertir los RPM a DEB con alien, resultando que "no hay tu tía". Visto lo visto vuelvo a indagar por Internet/Google/Ubuntu-es.org y encuentro un post en este último en donde marcaba como origen del problema la arquitectura del equipo al ser la versión del software sólo para 32 bits y no para 64; lo gracioso es que mi procesador es de 32, con lo cual harto improbable que esta sea la razón del fallo.

He seguido los pasos de descomprimir el tar.gz, acceder al directorio de RPM y usar alien -d *.rpm y la respuesta de mi Ubuntu Edgy 6.10 es la siguiente:

#OOE680_m6_native_packed-1_es.9095/RPMS$ sudo alien -d *.rpm
Password:
Package build failed. Here's the log:
dh_testdir
dh_testdir
dh_testroot
dh_clean -k -d
dh_installdirs
dh_installdocs
dh_installchangelogs
find . -maxdepth 1 -mindepth 1 -not -name debian -print0 | \
xargs -0 -r -i cp -a {} debian/openoffice.org-base
dh_compress
dh_makeshlibs
dh_installdeb
dh_shlibdeps
dpkg-shlibdeps: warning: format of `NEEDED libvcl680li.so' not recognized
dpkg-shlibdeps: warning: format of `NEEDED libtl680li.so' not recognized
dpkg-shlibdeps: warning: format of `NEEDED libsvt680li.so' not recognized
dpkg-shlibdeps: warning: format of `NEEDED libsvl680li.so' not recognized
dpkg-shlibdeps: warning: format of `NEEDED libsfx680li.so' not recognized
dpkg-shlibdeps: warning: format of `NEEDED libcomphelp4gcc3.so' not recognized
dpkg-shlibdeps: warning: format of `NEEDED libtk680li.so' not recognized
dpkg-shlibdeps: warning: format of `NEEDED libutl680li.so' not recognized
dpkg-shlibdeps: warning: format of `NEEDED libstlport_gcc.so' not recognized
dpkg-shlibdeps: warning: format of `NEEDED libsvt680li.so' not recognized
dpkg-shlibdeps: warning: format of `NEEDED libvcl680li.so' not recognized
dpkg-shlibdeps: warning: format of `NEEDED libtl680li.so' not recognized
dpkg-shlibdeps: warning: format of `NEEDED libsvl680li.so' not recognized
dpkg-shlibdeps: warning: format of `NEEDED libsfx680li.so' not recognized
dpkg-shlibdeps: warning: format of `NEEDED libdbtools680li.so' not recognized
dpkg-shlibdeps: warning: format of `NEEDED libcomphelp4gcc3.so' not recognized
dpkg-shlibdeps: warning: format of `NEEDED libstlport_gcc.so' not recognized
dpkg-shlibdeps: warning: format of `NEEDED libsvx680li.so' not recognized
dpkg-shlibdeps: warning: format of `NEEDED libsfx680li.so' not recognized
dpkg-shlibdeps: warning: format of `NEEDED libsb680li.so' not recognized
dpkg-shlibdeps: warning: format of `NEEDED libsvt680li.so' not recognized
dpkg-shlibdeps: warning: format of `NEEDED libtk680li.so' not recognized
dpkg-shlibdeps: warning: format of `NEEDED libvcl680li.so' not recognized
dpkg-shlibdeps: warning: format of `NEEDED libgo680li.so' not recognized
dpkg-shlibdeps: warning: format of `NEEDED libsvl680li.so' not recognized
dpkg-shlibdeps: warning: format of `NEEDED libsot680li.so' not recognized
dpkg-shlibdeps: warning: format of `NEEDED libutl680li.so' not recognized
dpkg-shlibdeps: warning: format of `NEEDED libtl680li.so' not recognized
dpkg-shlibdeps: warning: format of `NEEDED libucbhelper3gcc3.so' not recognized
dpkg-shlibdeps: warning: format of `NEEDED libdbtools680li.so' not recognized
dpkg-shlibdeps: warning: format of `NEEDED libcomphelp4gcc3.so' not recognized
dpkg-shlibdeps: warning: format of `NEEDED libso680li.so' not recognized
dpkg-shlibdeps: warning: format of `NEEDED libvos3gcc3.so' not recognized
dpkg-shlibdeps: warning: format of `NEEDED libstlport_gcc.so' not recognized
dpkg-shlibdeps: warning: could not find any packages for libuno_sal.so.3
dpkg-shlibdeps: warning: unable to find dependency information for shared library libuno_sal (soname 3, path libuno_sal.so.3, dependency field Depends)
dpkg-shlibdeps: warning: could not find any packages for libuno_cppu.so.3
dpkg-shlibdeps: warning: unable to find dependency information for shared library libuno_cppu (soname 3, path libuno_cppu.so.3, dependency field Depends)
dpkg-shlibdeps: warning: could not find any packages for libuno_cppuhelpergcc3.so.3
dpkg-shlibdeps: warning: unable to find dependency information for shared library libuno_cppuhelpergcc3 (soname 3, path libuno_cppuhelpergcc3.so.3, dependency field Depends)
dpkg-shlibdeps: warning: could not find any packages for libuno_cppuhelpergcc3.so.3
dpkg-shlibdeps: warning: unable to find dependency information for shared library libuno_cppuhelpergcc3 (soname 3, path libuno_cppuhelpergcc3.so.3, dependency field Depends)
dpkg-shlibdeps: warning: could not find any packages for libuno_cppu.so.3
dpkg-shlibdeps: warning: unable to find dependency information for shared library libuno_cppu (soname 3, path libuno_cppu.so.3, dependency field Depends)
dpkg-shlibdeps: warning: could not find any packages for libuno_sal.so.3
dpkg-shlibdeps: warning: unable to find dependency information for shared library libuno_sal (soname 3, path libuno_sal.so.3, dependency field Depends)
dpkg-shlibdeps: warning: could not find any packages for libuno_cppuhelpergcc3.so.3
dpkg-shlibdeps: warning: unable to find dependency information for shared library libuno_cppuhelpergcc3 (soname 3, path libuno_cppuhelpergcc3.so.3, dependency field Depends)
dpkg-shlibdeps: warning: could not find any packages for libuno_cppu.so.3
dpkg-shlibdeps: warning: unable to find dependency information for shared library libuno_cppu (soname 3, path libuno_cppu.so.3, dependency field Depends)
dpkg-shlibdeps: warning: could not find any packages for libuno_sal.so.3
dpkg-shlibdeps: warning: unable to find dependency information for shared library libuno_sal (soname 3, path libuno_sal.so.3, dependency field Depends)
dh_gencontrol
dh_md5sums
dh_builddeb
dpkg-deb: el directorio de control tiene permisos erróneos 700
(debe ser >=0755 y <=0775)
dpkg-deb: construyendo el paquete `openoffice.org-base' en `../openoffice.org-base_2.1.0-7_i386.deb'.
dh_builddeb: command returned error code 512
make: *** [binary-arch] Error 1
find: openoffice.org-base-2.1.0: No existe el fichero ó directorio

Creo entender que existe un problema de dependencias, pero ¿cuáles son estas?

Llegado a este punto no tengo más remedio que acudir a alguien que me guie o me de una pista hacia la solución.

Gracia de antemano y perdón por la extensión de este post.

Imagen de TASADAR-F
+1
0
-1

El openoffice es una de las cosas menos transportables a no ser que intentes usar el codigo fuente. Los rpms dan muchisimos problemas

+1
0
-1
Imagen de RagonichaFulva
+1
0
-1

Hola linxgalaico,

Yo instalé OO 2.1 e intenté asistir a la persona que uso el tema que comentas.

¿Seguiste los pasos del enlace que puse?

http://69.60.114.106/www.kubuntu-es.org/public_html/?q=node/1828

Yo ya he hecho esa instalación dos veces y JAMÁS me ha dado ningún problema instalar a partir de los RPMs.

Acuérdate sobre todo de hacer:

sudo aptitude install fakeroot alien

y tras descomprimir el .tar.gz descargado de la web que referencio:

fakeroot alien -d *.rpm

Dependiendo de donde sea, a lo mejor has de usar el comando sudo. Parece que se queja de falta de permisos.

Un saludo.

"La perseverancia es un árbol de raíces amargas, pero de frutos muy dulces."

+1
0
-1

"La perseverancia es un árbol de raíces amargas, pero de frutos muy dulces."