Imposible configurar tarjeta wireless broadcom 4310

Imagen de Nolox
0 puntos

Buenas a tod@s, llevaba mucho tiempo queriendo instalar Linux y cuando por fin me decido me es imposible echar a andar la conexión wifi. Mi portatil es un HP Pavillion dv2141eu, según me reconoce ubuntu la tarjeta inalámbrica es una broadcom 4310 UART (rev 1).

Después de haberme leido un montón de tutoriales, he probado con ndiswraper y con fwcutter y nada de nada, la luz de mi tarjeta wifi sigue en rojo.

Alguien podría echarme una mano?

Gracias de antemano

Imagen de pipepool
+1
0
-1

He mirado el bcm43xx que trae compilado Feisty y aún no trae soporte para la 4310 :/. No sé si has visto la lista de los desarrolladores del bcm43xx (para encontrarla busca en google bcm43xx-dev). Allí siempre hablan de las últimas novedades del driver. A lo mejor tienes algo interesante. En todo caso te exigiría parchear y compilar, lo cual, si estás empezando es duro.

Supongo que lo más lógico es intentar tirar de ndiswrapper. ¿Qué error/problema tienes cuando intentas con ndiswrapper? ¿Cúal es su versión y como la instalaste?

Un saludo.

+1
0
-1
Imagen de Nolox
+1
0
-1

En primer lugar gracias por contestar tan rápido ;) (No te imaginas el agobio que tengo jejejeje).
He estado mirando por la web lo que me dices de la lista de desarrolladores del bcm43xx-dev y no he encontrado nada que me ayude.

Respecto ndiswrapper he probado con varias versiones porque lei en varios manuales que las del repositorio de ubuntu por algún motivo no funcionaba bien con el driver. Al final como he estado probando con tantos drivers (casi me he vuelto loco jejejeje) me he instalado el ndisgtk (por comodidad) con el ndiswrapper 1.27...La cosa es que no me tira ningún error instalo el driver bcmwl5.inf y me dice hardware present:yes pero la tarjeta siempre está inactiva en eth1 y aunque la active si vuelvo a entrar en red está desactivada..

Otra cosa curiosa, lo más parecido a que funcionará lo conseguí con el fwcutter intentando instalar el firmware a traves del famosos wl_apsta.o, una vez instalado al reiniciar por fin se encendia azul la luz de la tarjeta pero...me peta el ubuntu y no arranca :S

Si se os ocurre algo..porque ya es cuestión de cabeconería.. en mi portatil se queda el ubuntu funcionando por mis...jejeje. al maldito windows no vuelvo ya

+1
0
-1
Imagen de pipepool
+1
0
-1

El caso que comentas al final me parece extraño, ¿qué salida da un: lspci -n |grep 43 ?
¿Y un: modinfo bcm43xx |grep alias ?

Hablabas de "eth1" pero, en mi caso al menos, ndiswrapper asigna un wlan0 a la tarjeta, mientras que el driver bcm43xx le asigna eth1. Por tanto me da la impresión de que estás mezclando uno con otro.

Haz:
sudo modprobe -r bcm43xx
sudo modprobe ndiswrapper
for x in $(ifconfig -a |grep 'Link encap' |awk '{print $1}'); do sudo ifconfig $x up; done

Prueba a intentar configurar ahora, por ejemplo con kwifimanager.

Si usas ndiswrapper 1.27 tienes una versión más actualizada aquí:

http://sourceforge.net/project/showfiles.php?group_id=93482&package_id=9...

Un saludo.

+1
0
-1
Imagen de Nolox
+1
0
-1

Bueno te comento, la salida que me pedias da este resultado ;)

gato@gato-laptop:~$ lspci -n |grep 43
0000:01:00.0 0280: 14e4:4312 (rev 01)
0000:03:09.2 0880: 1180:0843 (rev 01)

Respecto al resto de ordenes que me diste al realizarlas en Administración > Red me ha desaparecido la red inalámbrica como si no existiera, es mas el network manager ya no me da ni la opción de inalámbrico....

¿Alguna idea?

PD: Gracias a todos por la ayuda ;)

+1
0
-1
Imagen de pipepool
+1
0
-1

Vale, sí está soportada tu tarjeta en el bcm43xx, ya me parecía raro lo del final. Es que por lo que comentaras pensé que era un 4310 pero como puedes ver es una 4312, la cual si tiene soporte. Te recomiendo que bajes del link que te puse antes las fuentes del ndiswrapper. Mírate un tutorial para compilarlo, hay muchos. Una vez hecho deberías hacer:
sudo modprobe -r bcm43xx
sudo modprobe ndiswrapper

Y al hacer "iwconfig" debería aparecerte un wlan0

De no encontrar forma habría q meter el bcm43xx otra vez:
sudo modprobe -r ndiswrapper
sudo modprobe bcm43xx

Ahora ya tendrías que tener interfaz de nuevo. Ya que comentas un cuasi-exito con el tal vez debieras probar con otro firmware por ahí, a ver si con ese no se bloquea.

De todos modos si puedes hacerlo funcionar con ndiswrapper mejor.

Un saludo.

+1
0
-1
Imagen de Nolox
+1
0
-1

Bueno eso de soportada no sabes cómo de bien me suena jejejejejeje. Lo único que no te he entendido el resto jejejeje.

Si sabes cómo hacerlo te importaría explicarme cómo es que soy novatillo jejejeje, además prefiero hacerlo por el ndisgtk me es más cómodo ;) Porque supongo que lo que me dices es que tengo que instalar un driver diferente, no? pero cúal?

Un saludo y muchísimas gracias de nuevo

+1
0
-1
Imagen de Nolox
+1
0
-1

Bueno he hecho lo que me dijiste y algo mejora porque mira lo que me aparece al hacer un ndiswrapper -l:

gato@gato-laptop:~$ ndiswrapper -l
bcmwl5 : driver installed
device (14E4:4312) present (alternate driver: bcm43xx)

Sin embargo, he usado el iwconfig y esto es lo que me aparece:

gato@gato-laptop:~$ iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

sit0 no wireless extensions.

Es como si no encontrara la tarjeta pero dice que el hardware está presente. Ya me dices, porque creo que siguiendo tus instrucciones puede solucionarse el tema.

PD: Con esta nueva version de ndiswrapper no puedo instalar el ndisgtk?, al intentar hacerlo me intenta instalar el ndiswrapper del repositorio

+1
0
-1
Imagen de pipepool
+1
0
-1

Te explico: lo que te instala el ndisgtk es, si no me equivoco, las ndiswrapper-utils. Ndiswrapper no está en ellas. Digamos que ndiswrapper es el cascarón vacío de un driver, y tu lo rellenas con un driver de windows utilizando las ndiswrapper-utils. Y así se obtiene un driver que Linux acepta. Lo que te comento que sería conveniente recompilar es el cascarón, o sea ndiswrapper propiamente.

Para hacerlo descarga el .tar.gz de ndiswrapper aquí:
http://sourceforge.net/project/showfiles.php?group_id=93482&package_id=9...

Abres un terminal y haces:
sudo aptitude install linux-source linux-headers build-essential linux-headers-$(uname -r)
;Creo que esas son todas las dependencias
sudo modprobe -r ndiswrapper
sudo modprobe -r bcm43xx
cd Desktop
tar xvzf ndiswrapper-1.38.tar.gz
cd ndiswrapper-1.38
sudo make uninstall
sudo make uninstall
make
;Si aquí no obtenemos algún error ejecutamos el siguiente paso:
sudo make install
sudo modprobe ndiswrapper
;mira a ver que sale en el ndiswrapper -l y q sale con el iwconfig

Saludos.

+1
0
-1
Imagen de Nolox
+1
0
-1

Bueno aquí te dejo el error que me da:

gato@gato-laptop:~/Desktop/ndiswrapper-1.38$ sudo modprobe ndiswrapper
FATAL: Error inserting ndiswrapper (/lib/modules/2.6.15-26-amd64-generic/misc/ndiswrapper.ko): Unknown symbol in module, or unknown parameter (see dmesg)

el ndiswrapper -l sigue dandome el mismo mensaje:

gato@gato-laptop:~/Desktop/ndiswrapper-1.38$ ndiswrapper -l
bcmwl5 : driver installed
device (14E4:4312) present (alternate driver: bcm43xx)

Pero por primear vez el iwconfig me da el siguiente aspecto:

gato@gato-laptop:~/Desktop/ndiswrapper-1.38$ iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

sit0 no wireless extensions.

eth1 IEEE 802.11b/g ESSID:off/any Nickname:"Broadcom 4311"
Mode:Managed Access Point: Invalid Bit Rate=1 Mb/s
RTS thr:off Fragment thr:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

¿Alguna idea?

+1
0
-1
Imagen de pipepool
+1
0
-1

Parece que ha habido algún problema al compilar ndiswrapper, tal vez no coincide la versión que usaste para compilar con la del kernel... También puede ser por ser el kernel de 64 bits, lo cierto es que no sé si da problemas con ndiswrapper. Lo más cercano a funcionar parece el bcm43xx, aunque al hacer lo que yo te comenté antes no debería aparecer O.o. Supongo que la cuestión es que encuentres el firmware adecuado que extraer.

Tal vez una buena idea sería que bajaras la última Herd de Feisty, creo que es la 5, y la probaras en Live-CD. Yo cuando actualicé (Herd 2) me preguntó si quería instalar el firmware de mi tarjeta (4311), así que supongo que ya tendrán seleccionado un firmware adecuado los desarrolladores y de ese modo no tienes que buscarlo tu. No pierdes nada, por descargarla y ver si va, y te puedes ahorrar unos dolores de cabeza.

Saludos.

+1
0
-1
Imagen de Nolox
+1
0
-1

Al final he optado por instalar el ndiswrapper del repositorio de ubuntu que es el único que me funciona y no me da ese maldito error. Pero navegando por ahí con la idea que me diste de buscar algún otro firmware ecnontré y seguí los pasos de esta página

http://benux.wordpress.com/2006/10/08/configuracion-de-tarjeta-inalambri...

Y adivina?...Por fin la luz azul de mi wireless se enciende sin que me pete el ubuntu y me oblige a re-instalarlo, pero sigo sin tener acceso a las redes inalámbricas.

¿Alguna idea?

+1
0
-1
Imagen de pipepool
+1
0
-1

¿Y te escanea redes? Es decir, ¿te salen redes con: iwlist scan ?

Ánimo.

+1
0
-1
Imagen de Nolox
+1
0
-1

Eso es lo extraño, ahora la tarjeta está activa pero no detecta redes...El problema creo que esta en el ndiswrapper, que no consigo instalarlo del todo, me sigue dando el dichoso problema

gato@gato-laptop:~/Desktop/ndiswrapper-1.38$ sudo modprobe ndiswrapper
FATAL: Error inserting ndiswrapper (/lib/modules/2.6.15-26-amd64-generic/misc/ndiswrapper.ko): Unknown symbol in module, or unknown parameter (see dmesg)

No sé si es que de tanto probar, distintas versiones de ndiswrapper y distintos manuales hay algún conflicto que no me deja instalarlo. Pero visto lo visto estoy seguro de que hay alguna manera de hacer funcionar la tarjeta. No sé si formatear de nuevo el portatil y empezar de 0 para ver si así consigo instalar bien el ndiswrapper, pero me gustaría conseguir antes que la tarjeta de red funcionara para formatear despues (y dejar el laptop perfecto que he trasteado tanto que debe estar todo mezclado un poco jejejejeje).

¿Se te ocurre alguna idea?...siento que estoy cerca cerca de hacer funcionar la dichosa tarjeta. Si lo consigo prometo hacer un HOWTO para todo aquel que tenga mi modelo de broadcom ;)

+1
0
-1
Imagen de pipepool
+1
0
-1

Ahora mismo ndiswrapper no está actuando en absoluto. El driver que estás usando es el bcm43xx, o sea que tampoco tiene mayor importancia el ndiswrapper. Por cierto, antes de hacer el "iwlist scan" haz un "sudo ifconfig eth1 up", no vaya a ser que tengas el interfaz tirado y por eso no vaya.

Como ya te dije antes, yo si fuera tú me bajaba la Herd 5 de Feisty (la nueva versión de Ubuntu) y probaba el Live-CD porque ya trae el firmware, al menos de la bcm4311, y así, si ves que funciona, ya te lo instalas.

Saludos.

P.D.-Si quieres volver a dejar el kernel limpio sin reinstalar todo, puedes simplemente reinstalar el kernel.

+1
0
-1
Imagen de Nolox
+1
0
-1

Bueno he seguido tu consejo y me he bajado el live CD de Herd 5 para probar, en principio tiene muy buena pinta y aparece el network manager aunque sin detectar ninguna red, y la luz de la tarjeta inalámbrica en rojo. Es decir sin estar activa. Te copio los extractos de un lspci completo:

00:00.0 RAM memory: nVidia Corporation C51 Host Bridge (rev a2)
00:00.1 RAM memory: nVidia Corporation C51 Memory Controller 0 (rev a2)
00:00.2 RAM memory: nVidia Corporation C51 Memory Controller 1 (rev a2)
00:00.3 RAM memory: nVidia Corporation C51 Memory Controller 5 (rev a2)
00:00.4 RAM memory: nVidia Corporation C51 Memory Controller 4 (rev a2)
00:00.5 RAM memory: nVidia Corporation C51 Host Bridge (rev a2)
00:00.6 RAM memory: nVidia Corporation C51 Memory Controller 3 (rev a2)
00:00.7 RAM memory: nVidia Corporation C51 Memory Controller 2 (rev a2)
00:02.0 PCI bridge: nVidia Corporation C51 PCI Express Bridge (rev a1)
00:03.0 PCI bridge: nVidia Corporation C51 PCI Express Bridge (rev a1)
00:05.0 VGA compatible controller: nVidia Corporation C51 PCI Express Bridge (rev a2)
00:09.0 RAM memory: nVidia Corporation MCP51 Host Bridge (rev a2)
00:0a.0 ISA bridge: nVidia Corporation MCP51 LPC Bridge (rev a3)
00:0a.1 SMBus: nVidia Corporation MCP51 SMBus (rev a3)
00:0a.3 Co-processor: nVidia Corporation MCP51 PMU (rev a3)
00:0b.0 USB Controller: nVidia Corporation MCP51 USB Controller (rev a3)
00:0b.1 USB Controller: nVidia Corporation MCP51 USB Controller (rev a3)
00:0d.0 IDE interface: nVidia Corporation MCP51 IDE (rev f1)
00:0e.0 IDE interface: nVidia Corporation MCP51 Serial ATA Controller (rev f1)
00:10.0 PCI bridge: nVidia Corporation MCP51 PCI Bridge (rev a2)
00:10.1 Audio device: nVidia Corporation MCP51 High Definition Audio (rev a2)
00:14.0 Bridge: nVidia Corporation MCP51 Ethernet Controller (rev a3)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:00.0 Network controller: Broadcom Corporation BCM4310 UART (rev 01)
03:09.0 FireWire (IEEE 1394): Ricoh Co Ltd Unknown device 0832
03:09.1 Generic system peripheral [0805]: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 19)
03:09.2 System peripheral: Ricoh Co Ltd Unknown device 0843 (rev 01)
03:09.3 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 0a)
03:09.4 System peripheral: Ricoh Co Ltd xD-Picture Card Controller (rev 05)

Y de un iwconfig :

ubuntu@ubuntu:~$ iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

eth1 IEEE 802.11b/g ESSID:"" Nickname:"Broadcom 4311"
Mode:Managed Access Point: Invalid
RTS thr:off Fragment thr:off
Link Quality=0/100 Signal level=-256 dBm Noise level=-256 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

No sé si ves algo que pueda servirme de ayuda. A lo mejor si en esta versión compilo el ndiswrapper (lo cual parece harto complicado en el kernel de 64 bits de AMD) y le coloco el driver adecuado funciona pero eso no lo sabré si no instalo el sistema completo...

Respecto a lo que me decías de que no hace falta formatear sino reinstalar simplemente el kernel si me indicas la orden por terminal te lo agradecería, así como la manera de eliminar cualquier instalación de ndiswrapper que haya en el sistema. La idea es dejar el sistema como si estuviera recien instalado para probar a instalar la última versión de ndiswrapper desde 0 a ver si así compila (no vaya a ser que el problema en lugar del kernel de 64 sea que hay residuos de otras instalaciones)...vete tu a saber...ando desesperado jejejejeje

Un abrazo y mil gracias

+1
0
-1
Imagen de neoshadybeat
+1
0
-1

mirate este, es un pakete ya compilado, yo tambien estaba desesperado, metí este pakete y funciona a la perfección espero k te sirva

http://debian.cafuego.net/pool/feisty-cafuego/bcm43xx/bcm43xx-firmware_1...

 

esta probao en festy Saludos

+1
0
-1
Imagen de pipepool
+1
0
-1

En mi caso, al actualizarme desde Edgy me preguntó explicitamente si quería instalar el firmware de mi Broadcom, tal vez tengas que instalar para que te lo pregunte a ti también. No pongo la mano en el fuego sobre ello, pues como te digo, a mi me lo preguntó al actualizar.

La situación que observo en tu salida es: bcm43xx sin firmware, vamos, lo mismo de antes.

Hoy he ayudado a un nuevo ubuntero a compilar ndiswrapper con éxito sobre amd64, con un kernel generic, así que hay 2 opciones:

a) Las instalaciones previas de ndiswrapper dan problemas, NO debería ser el caso si al compilar has ejecutado "sudo make uninstall" antes.

b) La versión concreta y precisa de kernel que tienes tiene un bug que impide compilarlo. No sería la primera vez que pasa algo así.

Por otro lado, ya que estás utilizando un kernel de 64 bits los drivers que utilices de windows deben ser de 64 bits también! De este hecho me he dado cuenta hoy y no era consciente porque siempre he trabajado con Intel. Pero al ayudar "in vivo" al ubuntero que te he comentado me di cuenta.

Por tanto veo 3 opciones:

a) Optas por la senda del riesgo y te instalas la Herd 5 sin garantías más allá de mi sola experiencia personal.

b) Encuentras un driver de Windows de 64 bits (si existe) para tu tarjeta y se vuelve a intentar lo que se intentó antes con el de 32 bits.

c) Instalas un kernel de 32 bits que te dará un menor rendimiento pero sabes con certeza que los drivers existen y puedes descargas los correctos desde la wiki de ndiswrapper.

Bueno, son bastantes cosas, asimílalas, pregunta si no entiendes algo, opina, y decidas lo que decidas aquí estoy para ayudarte.

Un saludo.

+1
0
-1
Imagen de Nolox
+1
0
-1

Pues eso, me he bajado según me decias el HERD 5 y con el ndiswrapper y el controlador bcmwl5 y las indicaciones de esta web:

http://agarzon.php.com.ve/2006/09/15/wireless-broadcom-43xx-en-ubuntu/

He conseguido ver las redes y optar a conectarme pero no me deja acceder a la mia que tengo protegida por WPA (y eso que pongo la clave) no para de pedirmela una y otra vez sin conseguir acceder.

Esto es lo que me da un iwconfig:

lo no wireless extensions.

eth0 no wireless extensions.

eth1 IEEE 802.11b/g ESSID:off/any Nickname:"Broadcom 4311"
Mode:Managed Frequency=2.484 GHz Access Point: Invalid
Bit Rate=1 Mb/s Tx-Power=18 dBm
RTS thr:off Fragment thr:off
Link Quality=0/100 Signal level=-256 dBm Noise level=-256 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

Ya no debe quedarme mucho camino hacia la conexión, no?.....o sí???? jejejeje Se te ocurre que puedo hacer?

Un abrazo y mil gracias por la ayuda

+1
0
-1
Imagen de pipepool
+1
0
-1

¿Con qué intentas conectarte a una WPA? Va bien network-manager-gnome.

Voy a aclarar una cosa sobre ndiswrapper y tal:

ndiswrapper es un driver, bcm43xx es otro driver diferente. Los dos sirven para hacer funcionar tu wifi, pero no pueden estar a la vez, claro. El ndiswrapper da a tu wifi el nombre de wlan0. bcm43xx le da el nombre de eth1.

Como ves en el iwconfig, lo que tiene encendida tu tarjeta es el bcm43xx. Ahí no hay rastro de ndiswrapper. Y si te fijas pone "access point: invalid" así que creo que el tema del firmware no se solucionó.

Puedes probar a instalar un kernel de 32 a ver si en el te va o ndiswrapper o el bcm43xx. Yo personalmente confío más en ndiswrapper, porque el bcm43xx está algo verde.

Saludos.

+1
0
-1
Imagen de akebar
+1
0
-1

Hola Nolox

He leído tu petición de ayuda sobre el driver bcm 4310 de broadcom y, como no tengo mucho tiempo para escrbir, te voy a pedir que te dejes de probaturas y especulaciones y apliques la solución propuesta en este link

http://ubuntu1501.blogspot.com/2007/01/fixing-wifi-on-dell-1501.html

Esta solución está lo suficientemente probada para que yo te pueda asegurar que FUNCIONA de verdad, además personalmente yo la he probado en tres instalaciones.

Sólo me queda darte otro dato, pues si te fijas en el texto del link que te he dado, en el se dice que necesitas bajarte e instalar previamente los siguientes paquetes:

.- build-essential
.- linux-headers correspondientes a tu version de kernel

Como lo más seguro es que no dispongas de conexión a internet en ese equipo, desde otro equipo te bajas esos paquetes con todas sus dependencias y a su vez las dependencias de estas últimas desde el sitio wen siguiente

http://packages.ubuntu.com/edgy/devel/

Procede a instalar todos esos paquetes bien selecionándolos todos e instl,andolos de forma automática o bien desde la consola.

Ya diras algo

Salu2

+1
0
-1
Imagen de Nolox
+1
0
-1

Hola akebar, acabo de probar la solución que me diste (por cierto cojonudo el tutorial, muy bien explicado) pero no me funciona....

Para empezar la luz de mi wireless (como ya estaba encendida de cuanto use el bcmxx-fwcutter) no se ha apagado en ningún momento (sigue encendida de hecho)pero ahora me ha desaparecido de las conexiones la tarjeta inalámbrica.

Fijate que curioso, he seguido las instrucciones del tutorial paso a paso y ningún problema. Cuando hago iwlist scanning me da:

lo Interface doesn't support scanning.

eth0 Interface doesn't support scanning.

Sin embargo al hacer ndiswrapper -l:

bcmwl5 : driver installed
device (14E4:4312) present (alternate driver: bcm43xx)

También hay que decir que en mi /etc/network/interfaces me aparece esto:

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet dhcp

auto eth1
iface eth1 inet dhcp

Y que si hago ifconfig wlan0 up me da esto:

wlan0: ERROR while getting interface flags: No such device

Parece que detecta el driver y el hardware pero luego no lo detecta...no sé..Es posible que no me haya salido la receta que me has enviado porque he trasteado un montón en el pc y haya quedado algo del bcmxx-fwcutter

No sé ya me direis ;)

Un abrazo a ambos

+1
0
-1
Imagen de Nolox
+1
0
-1

Borrad mi comentario anterior, he apagado el ordenador (no sé porque al reiniciarlo seguía sin funcionar...pero al apagar jejeje) y al volverlo a encender....magia!!!! Estoy conectado.....

Os escribo desd mi wifi!!!!!!!!!!!!!!

Un abrazo/besazo/..(y demas mariconadas) a ambos

Mil millones de gracias por la ayuda a los dos ;)

+1
0
-1
Imagen de akebar
+1
0
-1

Enhorabuena Nolox.

Te iba a aconsejar que modificases el archivo /etc/network/interfaces pero ya no hace falta. No obstante comprueba que ese mismo archivo ha cambiado desde que tu posteaste su contenido.

E algunas ocasiones se consiguen mejores resultados configurando las conexiones como estáticas (manualmente), es decir, asignando una IP fija a tu idspositivo de RED (por ejemplo 192.168.1.66)

Saludos

+1
0
-1
Imagen de Nolox
+1
0
-1

Ok, miraré el network interfaces a ver si aparece wlan0 (creo que así debe aparecer al usar ndiswrapper, no?). Otra dudilla más. ¿Sabes si esta receta funciona en la versión dapper de ubuntu?.

Por lo demás mi wirelles funciona perfectamente, auqnue algunas veces no debe de cargar bien el ndiswraper y no me lo reconoce (mi luz vuelve a roja), lo cual deja de pasar si vuelvo a reiniciar. Hay alguna manera de que cuando me pase esto no tenga que reiniciar, puedo usar algún comando o algo?

Ya me direis ;)

Un abrazo

+1
0
-1
Imagen de Nolox
+1
0
-1

Bueno algo extraño pasa porque ahora todo funciona pero no puedo conectarme a la red con wpa :S, a ver si podeis echarme una mano para ver que ocurre y dejar esto listo ;)

dmesg | grep ndiswrapper

[ 36.774639] ndiswrapper version 1.32 loaded (preempt=yes,smp=yes)
[ 36.946990] ndiswrapper (link_pe_images:577): fixing KI_USER_SHARED_DATA address in the driver
[ 36.949581] ndiswrapper: driver bcmwl5 (Broadcom,10/12/2006, 4.100.15.5) loaded
[ 36.977359] ndiswrapper: using IRQ 233
[ 37.627632] usbcore: registered new driver ndiswrapper
[ 37.638222] ndiswrapper: changing interface name from 'wlan0' to 'eth1'

ndiswrapper -l:
bcmwl5 : driver installed
device (14E4:4312) present (alternate driver: bcm43xx)

iwlist scan:
lo Interface doesn't support scanning.

eth0 Interface doesn't support scanning.

eth1 Scan completed :
Cell 01 - Address: 00:03:6F:75:23:A4
ESSID:"TELE2"
Protocol:IEEE 802.11g
Mode:Managed
Frequency:2.462 GHz (Channel 11)
Quality:10/100 Signal level:-89 dBm Noise level:-96 dBm
Encryption key:on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9 Mb/s
12 Mb/s; 48 Mb/s
Extra:bcn_int=100
Extra:atim=0
IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (1) : TKIP
Authentication Suites (1) : PSK
Cell 02 - Address: 00:14:7F:36:86:9F
ESSID:"SpeedTouch"
Protocol:IEEE 802.11g
Mode:Managed
Frequency:2.412 GHz (Channel 1)
Quality:48/100 Signal level:-65 dBm Noise level:-96 dBm
Encryption key:on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9 Mb/s
12 Mb/s; 48 Mb/s
Extra:bcn_int=100
Extra:atim=0
IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (1) : TKIP
Authentication Suites (1) : PSK
Cell 03 - Address: 00:14:F8:8B:62:75
ESSID:"p159646640002"
Protocol:IEEE 802.11g
Mode:Managed
Frequency:2.437 GHz (Channel 6)
Quality:23/100 Signal level:-81 dBm Noise level:-96 dBm
Encryption key:on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
11 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Extra:bcn_int=80
Extra:atim=0
Cell 04 - Address: 00:01:36:0C:30:60
ESSID:"miau"
Protocol:IEEE 802.11g
Mode:Managed
Frequency:2.432 GHz (Channel 5)
Quality:87/100 Signal level:-40 dBm Noise level:-96 dBm
Encryption key:on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Extra:bcn_int=100
Extra:atim=0
IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (1) : TKIP
Authentication Suites (1) : PSK

sit0 Interface doesn't support scanning.

Contenido del archivo /etc/network/interfaces:

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet dhcp

auto eth1
iface eth1 inet dhcp

Contenido del archivo /etc/modprobe.d/ndiswrapper:
install pci:v000014E4d00004311sv00000007sd00001028bc*sc*i* /sbin/modprobe ndiswrapper
install pci:v000014E4d00004311sv00000008sd00001028bc*sc*i* /sbin/modprobe ndiswrapper
install pci:v000014E4d00004311sv*sd*bc*sc*i* /sbin/modprobe ndiswrapper
install pci:v000014E4d00004312sv00000007sd00001028bc*sc*i* /sbin/modprobe ndiswrapper
install pci:v000014E4d00004312sv00000008sd00001028bc*sc*i* /sbin/modprobe ndiswrapper
install pci:v000014E4d00004312sv*sd*bc*sc*i* /sbin/modprobe ndiswrapper
install pci:v000014E4d00004318sv00000005sd00001028bc*sc*i* /sbin/modprobe ndiswrapper
install pci:v000014E4d00004318sv00000006sd00001028bc*sc*i* /sbin/modprobe ndiswrapper
install pci:v000014E4d00004318sv*sd*bc*sc*i* /sbin/modprobe ndiswrapper
install pci:v000014E4d00004319sv00000005sd00001028bc*sc*i* /sbin/modprobe ndiswrapper
install pci:v000014E4d00004319sv00000006sd00001028bc*sc*i* /sbin/modprobe ndiswrapper
install pci:v000014E4d00004319sv*sd*bc*sc*i* /sbin/modprobe ndiswrapper
install pci:v000014E4d00004320sv00000001sd00001028bc*sc*i* /sbin/modprobe ndiswrapper
install pci:v000014E4d00004320sv00000002sd00001028bc*sc*i* /sbin/modprobe ndiswrapper
install pci:v000014E4d00004320sv00000003sd00001028bc*sc*i* /sbin/modprobe ndiswrapper
install pci:v000014E4d00004320sv00000004sd00001028bc*sc*i* /sbin/modprobe ndiswrapper
install pci:v000014E4d00004320sv*sd*bc*sc*i* /sbin/modprobe ndiswrapper
install pci:v000014E4d00004324sv00000001sd00001028bc*sc*i* /sbin/modprobe ndiswrapper
install pci:v000014E4d00004324sv00000002sd00001028bc*sc*i* /sbin/modprobe ndiswrapper
install pci:v000014E4d00004324sv00000003sd00001028bc*sc*i* /sbin/modprobe ndiswrapper
install pci:v000014E4d00004324sv00000004sd00001028bc*sc*i* /sbin/modprobe ndiswrapper
install pci:v000014E4d00004324sv*sd*bc*sc*i* /sbin/modprobe ndiswrapper
install pci:v000014E4d00004328sv00000009sd00001028bc*sc*i* /sbin/modprobe ndiswrapper
install pci:v000014E4d00004328sv*sd*bc*sc*i* /sbin/modprobe ndiswrapper
alias wlan0 ndiswrapper

iwconfig (aquí hay algo raro porque me aparece Not-Associated en Access Point):
lo no wireless extensions.

eth0 no wireless extensions.

eth1 IEEE 802.11g ESSID:off/any Nickname:"miau"
Mode:Managed Frequency:2.462 GHz Access Point: Not-Associated
Bit Rate=54 Mb/s Tx-Power:32 dBm
RTS thr:off Fragment thr:off
Power Management:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

sit0 no wireless extensions.

Supongo que debe ser alguna tonteria ya que si antes podía conectar, ahora se queda conectando, me pide la clave wpa de red, se la pongo pero parece como si no lograra conectar con el router.

Sabeis que se me está escapando??

Gracias de antemano de nuevo ;)

+1
0
-1
Imagen de doc-cymaho
+1
0
-1

yo segui esta guia para lap top dv9053ea y fue perfecto

http://www.ubuntu.cymaho.com/2007/04/01/wireless-wifi-chip-broadcom-en-u...

funciona en edgy tambien 

+1
0
-1

HP dv9053ea y tx1023ea GNU/Linux, Beryl Nvidia driver 100.14.03 ..Blog - http://ubuntu.cymaho.com

Imagen de linubi
+1
0
-1

sudo apt-get update
sudo apt-get --reinstall install bcmwl-kernel-source

según este manualito de broadcom
http://www.broadcom.com/docs/linux_sta/README.txt

+1
0
-1