Fallo al reiniciar NVidia

Imagen de angel_87
0 puntos

Hola a todos. Os cuento mi problema a ver si alguien puede ayudarme.

Tengo una tarjeta gráfica Nvidia MX440. Me descargué los drivers de la página oficial de NVidia, los instalé y todo fue sin problemas. Instalé Beryl, algunos juegos, etc. y todo funcionaba perfectamete.

El problema está en que al reiniciar me da fallo en el entorno gráfico. Parece que mi sistema no encuentra el módulo instalado o algo así porque tengo que reinstalar el driver si quiero usar aceleración o configurarlo con el driver 'nv' en vez de 'nvidia'. De esta forma, cada vez que quiero usar Beryl o cualquier juego tengo que reinstalar el driver.

Una vez que reinstalo y entro en el sistema con 'startx' todo funciona perfectamente. También si reinicio el entorno gráfico con "Ctrl+Alt+Backspace" se reinicia sin problemas. Sólo falla si reinicio la máquina completa.

Gracias de antemano.

Imagen de marcus1984
+1
0
-1

Hola,

yo tengo el mismo problema. He probado con mil parches tales como deshabilitar el modulo "nv", agregar el modulo "nvidia", instalar diferentes versiones de drivers, modificar el archivo xconf.org........y nada me consigue resolver el problema.

Lo que no llego a entender, es como despues de instalar los drivers y arrancar el entorno grafico todo funciona correctamente, y al reiniciar el PC todo se va al garito.

 Agradeceria que alguien me pudiera ayudar.  Muchas gracias.

+1
0
-1
Imagen de xoye
+1
0
-1

Lo saque de algun sitio que no me acuerdo, pido disculpas al autor 

1- Presionaremos las teclas Ctrl+Alt+F1

2- Accedemos con muestro nombre de usuario y contraseña.

3- Y ejecutamos el siguiente comando:

"sudo nano /etc/default/linux-restricted-modules-common"

en la línea:

DISABLED_MODULES=""

escribimos nv de tal forma que quede así:

DISABLED_MODULES="nv"

Pulsamos Ctrl+O para guardar, y Enter para sobreescribir el archivo.

Cerraremos el editor con Ctrl+X.

Para finalizar solo queda reiniciar el servidor X con:

"sudo /etc/init.d/gdm restart"

Si tenéis alguna duda, exponerla en la sección de comentarios (en este mismo artículo); intentaré solventarla lo mas pronto posible.

1- Presionaremos las teclas Ctrl+Alt+F1

2- Accedemos con muestro nombre de usuario y contraseña.

3- Y ejecutamos el siguiente comando:

"sudo nano /etc/default/linux-restricted-modules-common"

en la línea:

DISABLED_MODULES=""

escribimos nv de tal forma que quede así:

DISABLED_MODULES="nv"

Pulsamos Ctrl+O para guardar, y Enter para sobreescribir el archivo.

Cerraremos el editor con Ctrl+X.

Para finalizar solo queda reiniciar el servidor X con:

"sudo /etc/init.d/gdm restart"

+1
0
-1
Imagen de angel_87
+1
0
-1

Pues eso tio, muchas gracias Riendo.

La verdad es que creí que ya no respondería nadie a esta pregunta, pues hace tiempo ya que la escribí.

Ha funcionado a la primera, ya no tengo que liar una buena para jugar al stepmania Riendo.

+1
0
-1