problemas con savage

Imagen de Johan0xff
0 puntos

que tal amigos, bueno aun no me doy porvencido, ayer instale enemy territory y el unico problema que tengo es que me da un error y se me desconecta, creo que es un problema de servers.

pero aveces entra y esta de pelos.

Ahora he instalado el savage siguiendo el tutorial de la guia ubuntu :

http://www.guia-ubuntu.org/index.php/Savage

cuando ejecuto savage desde el terminal me aparece una ventana con el siguiente mensaje

"Your version of Savage is up to date"

y me da la opcion de aceptar y luego se cierra.

entonces veo la consola terminal y salen los siguientes mensajes:

~$ savage

Gdk-WARNING **: locale not supported by Xlib, locale set to C

Gdk-WARNING **: can not set locale modifiers
./silverback.bin: /usr/lib/libGL.so.1: no version information available (required by ./silverback.bin)
System_Init()
Game error during initialization:

Couldn't open scripts.log

alguna idea? he buscado en synaptic libGL pero no doy con la solucion

Imagen de Johan0xff
+1
0
-1

me falto algo:

si ejecuto:

$ sudo savage
Gdk-WARNING **: locale not supported by Xlib, locale set to C

Gdk-WARNING **: can not set locale modifiers
./silverback.bin: /usr/lib/libGL.so.1: no version information available (required by ./silverback.bin)
System_Init()
PNG header and library versions do not match

eso

+1
0
-1
Imagen de Diegstroyer
+1
0
-1

Creo que tu problema reside en que no tienes instalada la librería libGL.so.1, prueba de instalarla si la encuentras con:

$ sudo apt-get install libGL.so.1

Si no la encuentra:

$ sudo apt-get install libGl*

Instala todos los paquetes que así te salgan y solucionarás el problema (o eso creo), jejejeje.

un saludo!

Live as if you were to die tomorrow, learn as if you were to live forever...
Ghandi.

+1
0
-1
Imagen de Johan0xff
+1
0
-1

hice lo de $ sudo apt-get install libGl*

pero es una lista interminable de librerias que entran en conflicto con otras, esta demas que postee la enorme lista ya que no cabria en la pantalla, muchas gracias por responder tan pronto, aun sigo en busca de soluciones.

Alguien más desea cooperar con este novatillo (ese soy yo xD...)?

+1
0
-1
Imagen de Johan0xff
+1
0
-1

el archivo esta en la carpeta /usr/lib, pero tiene una flechita muy parecida a los accesos directos que se usan en windows (disculpen mi ignorancia.

+1
0
-1
Imagen de Diegstroyer
+1
0
-1

Creo que esto ya lo probaste, pero busca en los paquetes Synaptic libGL.so.1, tanto en nombre como en descripción, si no voy errado, te saldrá libgl1-mesa-swx11, márcalo para reinstalar, lo reinstalas y a ver que pasa.

A mi me daba el mismo problema, era la dichosa ATI y sus "tan faciles" de configurar drivers.

Si no es esto,me temo que ya no te puedo aconsejar nada más.

Un saludo y suerte!

PD: ya me dirás si te funciona.

Live as if you were to die tomorrow, learn as if you were to live forever...
Ghandi.

+1
0
-1
Imagen de Johan0xff
+1
0
-1

todabia no puedo y he probado todo

+1
0
-1
Imagen de kukalax
+1
0
-1

Tengo el mismo problema con el gdk. He intentado seguir tus consejos, pero lo que me dice el synaptic no me ha gustado nada y me ha entrado el canguelo, ya que para instalar esa libreria me pide que elimine el libgl1-mesa-dri; libgl1-mesa-glx, y por ultimo el xorg!!!!!Sorprendido Asi que me he rajado!!!

Mas datos, tengo una ati 9200 y el juego que me da problemas es el racer.

 

Salut

 

 

 

+1
0
-1
Imagen de Johan0xff
+1
0
-1

pues en mi caso yo arriesgue todo con poder jugar el maldito juego SAVAGE, tal asi que acepte al solucion que me dava aptitude y....

 ME QUEDO LA MEDIA CAGADABurla

se me desitalo todo, perdi todos los programas (aceleracion 3d, reproductores, nautilus scripts, wine, juegos, programas torrents, reproduccion de mp3 y mpg, TODO!!!!!!!!!!!!)

 y al final mientras me eliminaba todo me mando un error y quede sin nada y el maldito juego no FUNCIONO!!!!!!!!!!!!!!!

pueden creerlo? no funciono y tuve que instalar todo pero todo de nuevo, con suerte y no se me peto el UBUNTU.

 

 

+1
0
-1
Imagen de kukalax
+1
0
-1

Pues ya esta claro!!! No voy a tocar nada, que le vamos ha hacer?Enfadado

 

Salut!! 

+1
0
-1
Imagen de Diegstroyer
+1
0
-1

Prueba de reinstalar libgl1-mesa-dri; libgl1-mesa-glx, y por ultimo el xorg a ver que sucede, seguramente tines los drivers libres y por eso te dice que los eliminará, al reinstalarlos no cambia la configuración.

Live as if you were to die tomorrow, learn as if you were to live forever... Ghandi.

+1
0
-1
Imagen de kukalax
+1
0
-1

Ya lo he probado, he reinstalado las librerias y el xorg y sigo teniendo el mismo problema. Temgo los drivers fglrx, no se si servira de algo...

Gracias por todo!!!

 

 

+1
0
-1
Imagen de Johan0xff
+1
0
-1

hola amigos, pues no me pude aguantar, quiero jugar a toda costa l maldito juego SAVAGE!!!.

asi que respalde mi informacion de la carpeta personal y me di el gustazo de reinstalar todo desde 0.

 instale ubuntu edgy sin problemas, luego procedi a actualizarlo (245mb mas o menos), luego me descargue la ULTIMA version de los drivers para ATI 8.35.5 que viene con el famoso ATI CATALYST CONTROL CENTER (muy bueno) .

siguiendo un par de guias consegui la aceleración tan deseada y sin problemas de mi ATI 9550 GIGABYTE 128mb. 

ningun problema hasta ahora, instale el savage nuevamente con el metodo de la guia:

http://www.guia-ubuntu.org/index.php?title=Savage

pero vuelvo a tener conflictos con la famosa librería  libGL.so.1, que no puedo instalar porque pierdo el XORG.

grrrrrrrrrrrrRRRR!!!!!! tengo rabia!!!! todo para nada!!!!

porfabor se los ruego ayudenmeeeee!!!!!!!! miren todo mi esfuerzo, todo lo que hice, he gogleado hasta decir basta y no encuentro la solucion 

+1
0
-1
Imagen de Diegstroyer
+1
0
-1

Wenas, revisando mi instalación me he dado cuenta de que yo instalé algunas actualizaciones del juego y el problema se solucionó.

Descargate el parche de actualización SEP3T y a ver si te va bien,creo definitivamente que es eso.

El enlace de la página de descarga: 

http://www.s2games.com/savage/downloads.php 

Saludos! 

Live as if you were to die tomorrow, learn as if you were to live forever... Ghandi.

+1
0
-1
Imagen de Johan0xff
+1
0
-1

bueno, no habia posteado pero solucione el problema descargando un script del juego en el cual venia la actualización, el problema que tengo ahora es que no tengo sonido en el juego, pero aun asi lo he probado poco y tiene muy buena pinda jejeje, gracias de todos modos.

+1
0
-1