Kernel 2.6.20 con config 2.6.17... no funciona

Imagen de VicBlack
0 puntos

Hola a todos.
El problema (bueno, no es tanto, es curiosidad) es que compilo el kernel y todo bien, creo paquetes y bien. Instalo el image y el headers sin problema, pero arranco con él y el puñetero no me carga modulos necesarios, entre ellos el de la tarjeta de red y sin embargo otros como sonido, wifi, etc, sí.
El kernel está configurado con el mismo config del 2.6.17 que tengo ahora mismo rulando y que va perfecto. No es que necesite el nuevo, pero necesito saber porqué no carga igual que el actual.
Alguna idea?
Salu2

Imagen de santi...
+1
0
-1

A mi me paso algo parecido,,, igual que tu lo hice para experimentar y a ver si lograba mejorar algo,.. en la configuracion quite todo lo que sabia que no usaba.. y como a ti hay cosas que no van bien..
El caso es que para algunas cosas necesita paquetes actualizados y los repositorios no tienen esos paquetes, ya que estan pensados ra kernel 2.6.17.... yo prové copiando paquetes del feysti... que usa kernel 2.6.20 pero la lista de dependencias es larga y al final me hice un lio y desistí.
Una posiblidad que se me ocurre (seguramente es descabellada) es añadir los sources del feysti.. así quiza sea todo mas facil... esto te lo digo solo para experimentar ... y si no te importa cargarte el sistema... yo cree una particion para instalar ubuntu y hacer experimentos .. ahí los hago y cuando peta... a instlar de nuevo. Lo malo es el tema de las UUID de particiones cuando instalas en otra particion que tengas montada en otro sistema. si reinstalas en una particion para experimentos y luego no te arranca tu sistema bueno... acuerdate de las uuid.

+1
0
-1

.....................
...Pero no me hagas mucho caso... no soy ningun experto.

Imagen de VicBlack
+1
0
-1

Hola santi y gracias por responder.
Estoy seguro que el problema es tal y como tú comentas, ahora bien, ¿porqué a la hora de instalar los paquetes no indica nada sobre las dependencias? tipo "se espera libtalypascual > 1.0 y se encuentra libtalypascual 0.9
Supongo que sera problema del dpkg (bueno, problema no sería la palabra) ya que unicamente le indicas que haga un deb con el resultado de una compilacion. Pero leche, es que no da ningun tipo de error por ningun lado. Hay modulos que no se cargan... y punto. Ni una pista. Nada.
En fin, supongo que es menos complicado esperar. Pero chico, cuando todo va perfecto tienes que toquetear algo para poder entusiasmarte de nuevo, no? :)
Un Saludo y gracias otra vez.

+1
0
-1
Imagen de javier1965
+1
0
-1

Hola Gente, actualize de 2.6.17 a 2.6.20.6,  con copia del .config, hice make oldconfig menuconfig, conteste todas las opciones compile y Kernel panic, espero que algun experto lo halla podido hacer y lo comente, pues hay mejoras interesantes.

Hasta pronto

Javier Alvaredo 

 

+1
0
-1