Desactivar el servidor X

Imagen de jplinux
0 puntos

Siguiendo las instrucciones que algunos me habéis proporcionado, he conseguido restaurar el xorg.conf eligiendo un driver VESA, pero cuando intento instalar el driver original de la tarjeta (NVIDIA GeForce 6600 GT) me sale el siguiente mensaje : " You appear to be running an X server; please exit X before installing. " ¿Cómo lo desactivo? ¿Hay alguna otra forma de hacerlo?

Gracias

Imagen de munyeko
+1
0
-1

Hola,
una de las maneras que yo hago es:
Abrir una tty (P.e. CTRL+ALT+F1) y despues teclear:
/etc/init.d/gdm stop
Despues de esto el entorno grafico GDM quedara parado.
Y aqui ya puedes instalar los drivers tecleando
(donde tengas el fichero run de tus drivers Nvidia):
sh Nvidia ...... 1.976..run

Una cosa importante es darle los permisos de ejecucion
al archivo run (p.e. chmod +x Nvidia ... .run)

Una vez instalados hay 2 opciones:
Reiniciar el PC.
Reanudar el servidor X (/etc/init.d/gdm start)

PD: Antes te recomendaria hacer un backup de xorg.conf
(cp /etc/X11/xorg.conf /etc/X11/xorg.conf_backup)

Espero haberme explicado bien y que te sirva de ayuda.
"Saludos de uno que salio del lado "azulo" (oscuro) de la fuerza".

+1
0
-1

Espero haberme explicado bien y que te sirva de ayuda.

"Saludos de uno que salio del lado "azulo" (oscuro) de la fuerza".

(Los windowseros resuelven problemas, los linuxeros los evitan.)

Imagen de jplinux
+1
0
-1

Efectivamente, he conseguido desactivar el servidor X siguiendo tus instrucciones. Lamentablemente, al iniciar la instalación de los drivers, me aparece ahora el siguiente mensaje: "You do not appear to have libc files installed on your system. Please install your distributions libc development package." He buscado en los repositorios pero me aparecen muchos libc y no sé si se trata de alguno de estos. ¿Alguna idea?

+1
0
-1
Imagen de munyeko
+1
0
-1

Hola jplinux,
veo que lo que puse te fue bien (ya es un paso).
Recuerdo hace tiempo que me ocurrio algo parecido y la solucion
que encontre para poder instalarlos fue instalar los headers de linux.
Pero antes tendras que mirar cual es la version del nucleo o kernel
en el que estes trabajando, eso lo puedes saber con:

uname -r

con esto obtendras el kernel que estan utilizando, despues
tendras que instalar los headers:

sudo apt-get linux-headers-(y aqui el valor de uname -r)

Creo que con esto despues lance la instalacion de los drivers
de Nvidia y todo funciono a las mil maravillas.

Espero haberme explicado bien y que te sirva de ayuda.
"Saludos de uno que salio del lado "azulo" (oscuro) de la fuerza".

+1
0
-1

Espero haberme explicado bien y que te sirva de ayuda.

"Saludos de uno que salio del lado "azulo" (oscuro) de la fuerza".

(Los windowseros resuelven problemas, los linuxeros los evitan.)

Imagen de sansatan
+1
0
-1

En edgy yo tengo instaladas libc6 y libc6 y libc6-i686 (esta última sólo si tienes un procesador adecuado)

Seguro que te funciona

+1
0
-1

--------------------------------------

Un error muy frecuente: Confundir valor y precio.

Imagen de munyeko
+1
0
-1

Hola,
mis especificaciones son:
Distribucion -> Ubuntu Dapper Drake 6.06.1 LTS
Version kernel -> 2.6.15-28-386
Sobre las libc6, tengo instaladas:
libc6 y libc6-dev

Ya se que me podeis llamar un poco "cagon" al no
actualizarme a Edgy pero como la Dapper es LTS
(Long Time Support 3 años tengo entendido) y probe una
Live CD de Edgy y no fue como yo esperaba me quede con
mi Dapper.

Como dice un refran:
"Si las cosas van bien para que cambiarlas."
(Aunque algunas veces hay que cambiarlas, no queda otra.)

Espero haberme explicado bien y que te sirva de ayuda.
"Saludos de uno que salio del lado "azulo" (oscuro) de la fuerza".

+1
0
-1

Espero haberme explicado bien y que te sirva de ayuda.

"Saludos de uno que salio del lado "azulo" (oscuro) de la fuerza".

(Los windowseros resuelven problemas, los linuxeros los evitan.)

Imagen de jplinux
+1
0
-1

Ya he conseguido instalar los drivers.

Muchas gracias a todos por vuestra ayuda

+1
0
-1