Problemas con la instalción de Java Runtime

Imagen de mobutu
0 puntos

Hola, amigos

He entrado a una página y necesitaba al parecer tener el java runtime instalado. El instalador de plugins de mozilla lo mostraba con el cuadradillo aceptado, así que le he dado a seguir y finalmente me decia que lo tenía que instalar a mano. Me lo he descargado y, siguiendo las instrucciones, he tecleado en la terminal
./jre-versión

dentro del directorio donde estaba, concretamente en /usr/java. Me ha dado error de instalación. Lo he buscado en Synaptic y lo que me decía que era lo he instalado. He ido a la página y al intentar al cargarsela imagen en cuestión ha salido la siguiente información

http://recursos.cnice.mec.es/biosfera/alumno/1ESO/Astro/a_inicial2.htm wants to load an applet.
GNU Classpath's security implementation is not complete.
HOSTILE APPLETS WILL STEAL AND/OR DESTROY YOUR DATA!

Click "Cancel" if you do not trust the source of this applet.
Click "Trust Applet" to load and run this applet now.
Click "Trust Applet and Add To Whitelist" to always load and run this applet from now on, without asking.
The whitelist is a list of the URLs from which you trust applets.
Your whitelist file is " /home/mobesse/.gcjwebplugin/whitelist.txt ".

He hecho click en "Trust Applet and Add To Whitelist" Se ha visto la imagen, pero al intentar pasar adelante donde había otra imagen ya no se ha podido ver y me ha salido una ventana de bugs para enviar. No sé cómo se envía.

Entonces lo he intentado desde Aplicaciones-Añadir. Ha vuelto a pasar y lo mismo y además se ha cerrado bruscamente Firefox

He venido aquí. Siguiendo las normas he buscado primero información. Y siguiendo las instrucciones he tecleado el terminal

sh jre-versión Se ha instalado con éxito.

Pero el problema sigue. No se ven las imágenes y Firefox se cierra bruscamente.

No sé que puede pasar ni qué puedo hacer.

Os agradecería que me ayudarais.

AMD AM2 ATHLON 64
Edgy Eft 32 bits
Firefox 2.0.0.2

Un cordial saludo

Imagen de soygecko
+1
0
-1

Joven mobutu:

Tené en cuenta lo siguiente firefox está usando GNU Java y no Java de Sun... Esto es debido a que por lo general en el directorio /usr/bin el paquete de GCIJ, o algo asi, ya no me acuerdo tiene Symlinks con nombre de los equivalentes de Sun para que funcione como si fuese este.

Por otro lado vos instalaste el JRE en un directorio distinto y si lo fueses a instalar en bin te romperia los paquetes que instalas con synaptic. yo te recomiendo que busques el symlink que dice java y (si podés) editalo para que apunte al que vos instalaste de Sun por pedido de firefox. Esto no quiebra los paquetes pero pueden surgir problemas con los programas de GNU que dependen de su interprete.Pero son pocos y reemplazables.

Espero que mi ayuda te sirva y si me equivoco...¡CORRIJANME!

Soy de Salta y hago Falta, soy 6e(k0

+1
0
-1

Soy de Salta y hago Falta, soy 6e(k0

Imagen de mobutu
+1
0
-1

Recuerdo que sí instale en bin.
No entiendo que symlik me dice java

No sé como se edita y menos que apunte a algún sitio.

Demasiado complicado para un servidor tuyo.

Gracias de todos modos. Quizá lo entenderé m? adelante

Mobutu
Linux User #338331#

+1
0
-1

Mobutu Linux User #338331#

Imagen de mobutu
+1
0
-1

He tenido que instalar de nuevo Ubuntu por las razones que explicaré en la bitácora.
Después he instalado todo el java recomendado en vuestros posts.
He visitado la paginita y
Vualá

Yo mismo había fastidiado la cosa por pinchar donde no debía e instalar archivos bin sin saber qué es lo que hacía ni a qué me exponía. Ligero de gatillo, que dicen

Gracias a todos

Mobutu
Linux User #338331#

+1
0
-1

Mobutu Linux User #338331#

Imagen de yosebilla
+1
0
-1

Abrimos el synaptic ( o gestor de paquetes grafico que estemos usando), verificamos que tenemos puesto multiverse en fuentes pulsamos sobre "BUSCAR" y ponemos "firefox java"

Y vuala, el plugin de sun java esta entre las opciones, que ademas instala el jre java, pues ala.

+1
0
-1
Imagen de mobutu
+1
0
-1

Pues no encuentro lo de fuentes y menos lo de multiverse

Saludos

Mobutu
Linux User #338331#

+1
0
-1

Mobutu Linux User #338331#

Imagen de yosebilla
+1
0
-1

Sere mas especifico:

Dentro del sistema de repositorios ubuntu, existen varios tipos de repositorio, el base (main) universe, multiverse etc. Algunas utilidades que no tienen soporte oficial ubuntu pero que son usualmente utiles o usadas estan en esos repositorios. Estos repositorios estan usualmente soportados por la comunidad. Te explico por partes:

paso 1
Instalar synaptic , gestor de paquetes grafico:
Abrir un terminal y teclear:

sudo apt-get update
sudo apt-get install synaptic

paso dos
abrir synaptic, en el menu gnome no se donde suele estar pero sera en "administracion de sistema" o similares.

paso tres
en synaptic pestaña "configuracion" opcion "repositorios" abre una ventana nueva en esa ventana pulsamos "nuevo" y añadimos
en la seccion uri
http://es.archive.ubuntu.com/ubuntu/
en la seccion distribucion
dapper
en la seccion seccion(es)
universe multiverse

pulsar aceptar

Paso cuatro
en synaptic pulsar "recargar" esperar a que recarge pulsar "buscar" y poner sun-java entre las opciones aparecera "sun-java5-plugin" pulsar para instalar, pulsar aplicar, esperar a que baje e instale, cerrar synaptic, cerrar firefox, y volver a iniciar firefox. poner en firefox en la barra de direcciones "about:plugins" y comprobar que java esta instalado. fin.

Paso quinto (opcional)
leer la documentacion basica de ubuntu, seccion "instalar y desinstalar paquetes"

+1
0
-1
Imagen de mobutu
+1
0
-1

Lo primero, gracias por la molestia. Y paso a decirte.

Paso 1
Innecesario. Synaptic ya está instalado (¿O es que si me lo instalo como tú dices me va a salir un Synaptic güay con su uri, distribución y todo?)

Paso dos
Correcto, coincide y hecho

Paso tres
Hasta repositorios, correcto. Después no coincide con lo que describes.

Paso cuatro
Todo conforme. en about:plugins aparece un listón de javas plugins todos activos.

Voy a la página que escribí en mi primer post. Veo una breve animación del universo. Paso a la primera actividad y solo se ve la "huella" el espacio gris plano donde debería aparecer la animación o el juguete multimedia oportuno.

Así que debe ser un problema de la página o de algo que yo elegí romper y ahora es difícil arreglar.

Lo he vuelto a intentar con esta página y lo mismo; vuelve a salir el aviso de

http://newton.cnice.mec.es/1eso/materia/propiedades2.html wants to load an applet.
GNU Classpath's security implementation is not complete.
HOSTILE APPLETS WILL STEAL AND/OR DESTROY YOUR DATA!

Y todo lo demás

Mobutu
Linux User #338331#

+1
0
-1

Mobutu Linux User #338331#

Imagen de yosebilla
+1
0
-1

Lo primero efectivamente, yo no uso la version ubuntu gnome de synaptic y efectivamente existen algunas pequeñas diferencias, de todas formas es posible revertir a la version "a la debian" que yo suelo usar, esta entre las opciones.

En segundo lugar si tienes demasiados plugins java instalados es posible que escoja uno que no sea el que quieres, por ejemplo el blackdown java u otros. Eliminalos todos menos el que deseas.

En tercer lugar la pagina tiene alguna clase de error que no he identificado, no se si intenta acceder a los controles activex. lamentablemente no tengo tiempo para identificar el error. lo siento.

+1
0
-1