Comando dos2unix

Imagen de bnhraes
0 puntos

Buena! Un novatillo por aquí os pide ayuda para instalar una tarjeta usb wifi D-Link 122 C1. EN el manual que he encontardo por internet me pedia el "make" y el "dos2unix". He conseguido que el "make" me funcione gracias a build-esentials (lo he insatalado desde cd porque no puedo conectarme a internet), mi problema ahora es que no consigo encontrar el "dos2unix". ¿Alguna idea? Por cierto, si alguien sabe una forma de instalar los drivers de mi tarjeta-usb de forma sencilla (para novatos) le agradeceria que avisase!!Gracias!!

Imagen de kavra
+1
0
-1

Creo que tu driver es el rt2570 de todas formas documentate, en la siguiente página aparece como instalarlo http://hwagm.elhacker.net/drivers-ng/driver-ng.htm hago un copy&paste prueba...

ifconfig rausb0 down

rmmod rt2570

wget http://rt2x00.serialmonkey.com/rt2570-cvs-daily.tar.gz

tar -xvzf rt2570-cvs-daily.tar.gz

cd rt2570-cvs-[*]/Module

make && make install

modprobe rt2570

Nota:

[*] = Varia según el día de la descarga, pero lo veremos en cuanto descomprimimos el fichero mediante el comando anterior tar.

Pero este driver aun es mejor:

ifconfig rausb0 down

rmmod rt2570

wget http://homepages.tu-darmstadt.de/~p_larbig/wlan/rt2570-k2wrlz-1.5.1.tar.bz2

tar -xvjf rt2570-k2wrlz-1.5.1.tar.bz2

cd rt2570-k2wrlz-1.5.1/Module

make && make install

modprobe rt2570

"El pueblo que está dispuesto a cambiar su libertad por seguridad no merece ninguna de las dos" Benjamín Franklin
http://www.karnekruda.blogspot.com

+1
0
-1

____________________
Anarquía != Desorden

Imagen de bnhraes
+1
0
-1

Antes de nada, gracias por la ayuda. He seguido las indicaciones de la página que me pusiste, aunque para un chip diferente puesto que mi usb lleva el Rt73 (rt2571) que también te venía para instalar. Pero me da un error a la hora de instalarlo. A ver si sabes que puede ser...

alemarting@alemarting:~/Desktop/d.link linux/rt73-cvs-2007031110/Module$ make & make install

make[1]: se ingresa al directorio `/usr/src/linux-headers-2.6.15-26-386'
make[1]: *** No hay ninguna regla para construir el objetivo `linux/rt73-cvs-2007031110/Module'. Alto.

make[1]: se sale del directorio `/usr/src/linux-headers-2.6.15-26-386

rt73.ko failed to build!
make: *** [module] Error 1

alemarting@alemarting:~/Desktop/d.link linux/rt73-cvs-2007031110/Module$

Gracias!!

+1
0
-1
Imagen de kavra
+1
0
-1

Comprueba que las linux-headers están instaladas y pertenecen al núcleo que estás utilizando. Puedes ver el núcleo y versión que
utilizas con el comando uname -a

Las normas
La Documentación

+1
0
-1

____________________
Anarquía != Desorden

Imagen de bnhraes
+1
0
-1

Muchas gracias por la ayuda kavra. Al final he instalado la nueva versión porque lei que con ella funcionaban mejor los drivers. Los instalé ya sin ningún problema y ya te estoy contestando desde linux!

+1
0
-1
Imagen de kavra
+1
0
-1

Cierro el hilo, pues. :)
Saludos y a disfrutarlo
______________________
Las normas
La Documentación

+1
0
-1

____________________
Anarquía != Desorden