¿Porqué tarda Ubuntu tanto en cargar, 4 minutos con 5 segundos?

Imagen de carloscv-207
0 puntos

El inicio de Ubuntu desde que prendo o reinicio mi PC hasta que termina de cargar el escritorio está muy lento, acabo de cronometrar 4 minutos con 5 minutos y 49 segundos. Hasta el Grub duró 10 segundos, pero el resto (dando enter de una vez y sin equivocarse en la contraseña) son casi 4 minutos.

Me parece mucho.

Yo no utilizo Beryl, ni nada parecido. La aceleración gráfica me está funcionando. Eliminé el icono de inicio de Nvidia porque me pareció que hace más lento el arranque.

Utilizo como tema el predeterminado de Ubuntu, aunque combinado con unos iconos llamados "Gion" que bajé del sitio de Gnome. También instalé dos desklets en el escritorio pero para que carguen debo activar siempre el programa respectivo (gDesklets Shell). Uso 5 lanzadores en el escritorio, 3 de programas y 2 de carpetas.

Mis preguntas son:

1) Si Ubuntu está instalado en un disco duro esclavo que tiene además una partición FAT32 para compartir información con Windows (todavía no he tenido tiempo de montarlo, aunque Gparted si lee la partición) ¿puede ser más lento el inicio que si estuviera en el disco principal?

2) El cambio del splash pedeterminado ¿puede afectar el inicio? Porque incluso me cambió, y no recuerdo haber modificado eso, la ventana donde uno digita el nombre de usuario y la contraseña después.

Aquí encontré un hilo de discusión que recomienda desactivar el update-notifier, pero se refiere a una persona que no tiene conectado todo el tiempo su cable de red y no es mi caso. http://www.ubuntu-es.org/index.php?q=node/38760
Además no me gustaría desactivar el notificador de actualizaciones, me parece inseguro.

Imagen de dracool
+1
0
-1

Ayudaría mucho si nos proporcionaras los datos de tu equipo, y la versión de tu Distribucion para poder ayudarte.
Te recomiendo que leas las Normas del Foro para que puedas postear de manera correcta y tengas una ayuda adecuada a los problemas que se te puedan sucitar.

*********************************
Equipo de moderadores del Foro ubuntu
Normas del Foro
*********************************

+1
0
-1
Imagen de carloscv-207
+1
0
-1

Gracias, ya leí las normas y busqué con Google.
Mi equipo es una PC con procesador Pentium IV de 2,26 Ghz, memoria RAM de 512, monitor Samsung syncmaster CRT, memoria de video 128, dos discos duros de 80 Gigas con suficiente espacio libre. La versión de Ubuntu es edgy 6.10.

No he medido el tiempo exacto de carga en Windows, pero me parece que no pasa de un minuto. Hace 6 semanas se hizo una reinstalación en limpio del Windows y quedó rápido.

Voy a probar volviendo al splash y los iconos del tema predeterminado. Es probable que me tarde en contestar unas 14 horas porque en mi país son las 22 horas del domingo y me debo acostar dentro de una hora después de leer mi suscripción de blogs.

+1
0
-1
Imagen de santi...
+1
0
-1

Quiza si arrancas en recovery mode.... te sale en formato texto todo el proceso de arranque ... puedas averiguar donde se demora... fijate bien en la pantalla: mensajes de error.. se para mucho tiempo en una tarea.. etc.
pueden pasar varias cosas, pero ese tiempo de arrranque no es normal, yo pienso que en tu equipo desde el grub hasta la pantalla de login no debe tardar mas de 30 seg.
Bueno... esa es otra cosa... donde se demora... antes o despues del login??

+1
0
-1

.....................
...Pero no me hagas mucho caso... no soy ningun experto.

Imagen de RagonichaFulva
+1
0
-1

Puede que parte del problema esté en el montaje de los discos. Es lo que me pasaba a mí. Ahora me carga Ubuntu hasta escritorio en unos 35 segundos (llámame friki por cronometrar el arranque de mis sistema, jeje :D)

Ponnos tu FSTAB (gedit /etc/fstab).

Iremos depurando.

"La perseverancia es un árbol de raíces amargas, pero de frutos muy dulces."

+1
0
-1

"La perseverancia es un árbol de raíces amargas, pero de frutos muy dulces."

Imagen de carloscv-207
+1
0
-1

Hoy resolví en buena medida el problema.
Restauré la ventana original de inicio de Ubuntu, pues la había cambiado.
Además dejé el tema preterminado de Ubuntu Human con sus respectivos iconos.

Estaba durando tanto en el inicio cuando se despliega la barra de progreso y el logo de Ubuntu, como después. Parece que no encontraba algunas cosas.

Además se vuelve más lento si quito del todo el Splash.

A propósito de Splash, me hice una carpeta en home para guardar Splash que bajo de Gnome y estarlos cambiando. Sin embargo ahora no logro encontrar el Splash original.

También hice un intento de poner una foto al inicio y no funcionó, supongo que eso originó problemas.

Restaurando lo que pude en modo gráfico me duró después de un reinicio 1 minuto con 30 segundos.

En Windows XP dura 1:40 incluyendo cargar la suite de seguridad Kaspersky.

Si no intentaré restaurar como se me indicó en otro comentario. Pero de momento lo arreglé, aunque perdí el Splash original.

Me parece que en mi máquina no se debe personalizar mucho el entorno de trabajo porque el procesador no es muy potente para los parámetros actuales. A veces cuando abro varias aplicaciones (writer, firefox, synaptic o el instalador de Gnome) es probable que writer de OpenOffice comience a no responder.

Espero comprar pronto otra PC y tener más potencia para trabajar, porque también en Windows para el M.S. Office en documentos con mucho gráfico me da pegonazos y cuelgues de programas.

+1
0
-1
Imagen de carloscv-207
+1
0
-1

Le dí gedit /etc/fstab en la terminal y me sale (antes tuve que instalar una librería adicional de Gnome) Ver abajo enlace a captura de pantalla del disco.
¿A partir de esto qué debo hacer? Todavía tengo que montar la partición FAT32 porque con NFTS no me atrevo.

Me da
# /etc/fstab: static file system information.
#
#
proc /proc proc defaults 0 0
# /dev/hdb2
UUID=4db5af73-4d51-4d34-b9cc-6f8293f86dd2 / ext3 defaults,errors=remount-ro 0 1
# /dev/hdb5
UUID=36d80e73-eab2-41d5-b0dd-8895c74f9f9f none swap sw 0 0
/dev/hdc /media/cdrom0 udf,iso9660 user,noauto 0 0
/dev/hdd /media/cdrom1 udf,iso9660 user,noauto 0 0
/dev/ /media/floppy0 auto rw,user,noauto 0 0

http://www.flickr.com/photo_zoom.gne?id=419023946&size=o

+1
0
-1