ATI Aceleración 3D y Beryl

Imagen de Aram
0 puntos

Hola Amigos,

He comprado recientemente un portatil nuevo un SAMSUNG R40 ya que leí en uno de los foros que alguien lo tenia y no le daba ningún problema. ¡¡¡¡Pues sí, lo da!!!!, la tabarra es la aceleración 3D de la tarjeta ATI Radeon Xpress 200M que lleva. Al final consegui activar la aceleración 3D:

marc@marc-portatil:~$ sudo glxinfo |grep rend
Password:
direct rendering: Yes
GLX_ATI_pixel_format_float, GLX_ATI_render_texture
OpenGL renderer string: RADEON XPRESS Series Generic

pero ahora al ejecutar beryl desde la línea de comandos me devuelve este error:

marc@marc-portatil:~$ beryl
**************************************************************
* Beryl system compatibility check *
**************************************************************

Detected xserver : AIGLX

Checking Display :0.0 ...

Checking for XComposite extension : failed

No composite extension
beryl: No composite extension

el Beryl-manager se carga, pero no hay representación de ventanas en formato beryl..... ¡¡¡¡BBBBBUUUUUAAAAAA!!!!!!!!!

¿Alguien sabe como arreglarlo?, me gustaría poder tener el Beryl en este portátil, me he acostumbrado a usarlo y ahora me parece pobre la presentación del Ubuntu (6.10)

Bueno si alguien ha pasado por aquí y me puede echar una manita, pues muchas gracias por adelantado.

Aram.

Imagen de hugolino
+1
0
-1

seguramente, durante la configuración de la placa de video, para conseguir la aceleración 3D, tuviste que agregar en el archivo xorg.conf algo así

Section "Extensions"
Option "Composite" "Disable"
EndSection

bueno, si lo agregaste, borralo, o ponele "Enable" para habilitar el Composite

+1
0
-1
Imagen de Aram
+1
0
-1

Hola hugolino,

Gracias, despues de cambiar el xorg.conf ahora me devuelve esto y las ventanas quedan sin la barra de titulo su arranco el beryl

Detected xserver : AIGLX

Checking Display :0.0 ...

Checking for XComposite extension : passed (v0.3)
Checking for XDamage extension : passed
Checking for RandR extension : passed
Checking for XSync extension : passed

Checking Screen 0 ...

Checking for GLX_SGIX_fbconfig : passed
Checking for GLX_EXT_texture_from_pixmap : passed
Xlib: extension "XFree86-DRI" missing on display ":0.0".
Checking for non power of two texture support : failed

Support for non power of two textures missing
Xlib: extension "XFree86-DRI" missing on display ":0.0".
beryl: glXBindTexImageEXT is missing
beryl: Failed to manage screen: 0
beryl: No manageable screens found on display :0.0

¿Alguna idea de que puede ser?

Muchas gracias.

Aram

+1
0
-1

Si lloras porqué se ha puesto el Sol, las lágrimas en los ojos no te dejarán ver la luz de las estrellas (R. Tagore)

Imagen de Javier M.
+1
0
-1

Ya te funciona beryl y no te salen las barras o no te funciona y ademas no te salen las barras?
A mi me paso lo de las barras y lo arregle con pulsar recargar el gestor de ventanas en las opciones de beryl.
Por si te sirve de algo, te dejo mi xorg.conf para que lo compares, que aunque no es la misma tarjeta, si es una ati. Yo instale beryl sin mayor problema desde una instalacion limpia. Ten en cuenta si estuviste tocando mucho, el driver que tengas puesto, o si ya has mezclado muchas cosas.

Section "Device"
Identifier "ATI Technologies, Inc. RV350 NP [Mobility Radeon 9600/9700 M10/M11]"
Driver "radeon"
Option "AGPMode" "4"
Option "UseFBDev" "true"
Option "EnablePageFlip"
Option "ColorTiling"
BusID "PCI:1:0:0"
EndSection

A mi desde una instalacion limpia, solo con poner esto ya me funcionaba.

+1
0
-1
Imagen de Aram
+1
0
-1

Pues no, no me funciona, en cuanto le doy a recargar el gestor de ventanas lo que sale es otra vez seleccionado el tipo de ventanas del metacity. Que es el que está para casos de emergencia, así que amigo con esto estoy, lo carga pero no tengo nada nada BBBUUUUAAAAA!!!!! Vaya putada, estos tios de ATI se pasan un huevo, en el otro portatil, un HP con targeta grafica i915 no tengo ningún problema, ni con la aceleración ni con el beryl que esta funcionando 100% de P.M.

Gracias

+1
0
-1

Si lloras porqué se ha puesto el Sol, las lágrimas en los ojos no te dejarán ver la luz de las estrellas (R. Tagore)

Imagen de vnmx
+1
0
-1

Mira yo tengo esa misma tarjeta y por el error que muestras veo que no instalaste XGL, que es lo que necesitas para correr beryl, intentarlo con AIGLX no te llevará a nada, al menos con esa tarjeta. Yo seguí este link para instalar XGL.

Para tener el 3d con XGL y con esta tarjeta, necesitas tener deshabilitado el composite en /etc/X11/xorg.conf


Section "Extensions"
Option "Composite" "Disable"
EndSection

Y yo tuve que instalar Beryl desde los repositorios de treviño para hacerlo funcionar, que son repositorios svn.

Saludos... vnmx

Amplificación del conocimiento. Lo que él aprende, todos lo aprendemos. Lo que él sabe, nos beneficia a todos.

Su nombre... LINUX

+1
0
-1

Amplificación del conocimiento. Lo que él aprende, todos lo aprendemos. Lo que él sabe, nos beneficia a todos.

Su nombre... LINUX

Imagen de Aram
+1
0
-1

Hola vnmx

Ahora tengo la sesión XGL pero las ventanas van muy, muy lentas, el refresco de la pantalla se ha vuelto muy lento y al comprobar si tengo aceleración 3D, pues.....:

marc@marc-portatil:~$ sudo glxinfo |grep rend
Password:
Xlib: extension "XFree86-DRI" missing on display ":1.0".
direct rendering: No
GLX_ATI_pixel_format_float, GLX_ATI_render_texture
OpenGL renderer string: Mesa GLX Indirect

Maldita ATI de los co......

Saludos.

Aram

+1
0
-1

Si lloras porqué se ha puesto el Sol, las lágrimas en los ojos no te dejarán ver la luz de las estrellas (R. Tagore)

Imagen de vnmx
+1
0
-1

Sí, si hiciste la prueba de sudo glxinfo |grep rend dentro de la sesión XGL te dió direct rendering: No, es normal, a mí también nos da ese resultado, no te preocupes, está bien.

Y lo de las ventanas lentas es porque en tu /etc/X11/xorg.conf tienes esto


Section "Extensions"
Option "Composite" "Enable"
EndSection

si tienes eso, cámbialo por esto

Section "Extensions"
Option "Composite" "Disable"
EndSection

Saludos... vnmx

Amplificación del conocimiento. Lo que él aprende, todos lo aprendemos. Lo que él sabe, nos beneficia a todos.

Su nombre... LINUX

+1
0
-1

Amplificación del conocimiento. Lo que él aprende, todos lo aprendemos. Lo que él sabe, nos beneficia a todos.

Su nombre... LINUX

Imagen de Aram
+1
0
-1

Efectivamente, había cambiado el composite a Disable, pero no se porqué no iba bien, al hacer un reset del portátil ya no van lentas en la sesión XGL, pero al cargar el Beryl y poner las ventanas tipo beryl, desaparecen las barras 'cuadros' del Gnome, la de arriba y la de abajo y no hay nada que hacer, el ratón funciona pero no hay mas tutía que resetear el GDM. (Ctrl+ Alt + Retroceso) para poder trabajar de nuevo, ya que sino al no tener ningún menú......

¿Alguna idea de que puede estar ocurriendo ahora.?

Gracias

Aram

+1
0
-1

Si lloras porqué se ha puesto el Sol, las lágrimas en los ojos no te dejarán ver la luz de las estrellas (R. Tagore)

Imagen de vnmx
+1
0
-1

Saludos Aram:

utiliza los paquetes de beryl que estàn en el repositorio de treviño. Es el beryl del svn, dicen que son inestables pero yo los he encontrado mas estables, son los que mejor me han funcionado para esta tarjeta.

sudo gedit /etc/apt/sources.list
Agrega
# Treviño’s Beryl-SVN Ubuntu Edgy Repository
# GPG key: 81836EBF
deb http://download.tuxfamily.org/3v1deb edgy beryl-svn
deb-src http://download.tuxfamily.org/3v1deb edgy beryl-svn

agregamos la clave pùblica, unos updates...
$ wget http://download.tuxfamily.org/3v1deb/DD800CD9.gpg -O- | sudo apt-key add -
$ sudo apt-get update
$ sudo apt-get upgrade

...Reinicia la màquina y listo!

Fuente de los pasos anteriores.

Saludos... vnmx

Amplificación del conocimiento. Lo que él aprende, todos lo aprendemos. Lo que él sabe, nos beneficia a todos.

Su nombre... LINUX

+1
0
-1

Amplificación del conocimiento. Lo que él aprende, todos lo aprendemos. Lo que él sabe, nos beneficia a todos.

Su nombre... LINUX

Imagen de Aram
+1
0
-1

Bueno, al fin después de muchas peleas y de encontrar este programita : Envy (http://www.albertomilone.com/nvidia_scripts1.html) que instala bien la maldita ATI el beryl se ha puesto en marcha, pero no me deja cambiar los themes. Es decir por mucho que cargue otros al clicarlos en el gestor de temas este no cambia y queda el que viene por defecto.

¿Alguna idea de como puedo hacer para ver mi theme favorito?

Mil gracias a todos los que me haveis dado sugerencias, esto es lo que hace Grande a Linux.

Aram

+1
0
-1

Si lloras porqué se ha puesto el Sol, las lágrimas en los ojos no te dejarán ver la luz de las estrellas (R. Tagore)

Imagen de Aram
+1
0
-1

Bueno, he buscado un poco y lo he encontrado en la guía ubuntu, pero lo escribo aquí por si puede servirle a alguien

Basta con añadir esto en la sesión (sistema- preferencias- sesiones - programas de inicio)

gnome-settings-daemon

añadiendo esta linea ya van los themes

Una vez más MUCHÍSIMAS GRACIAS a todos los que habéis seguido y colaborado en este hilo, por fin tengo mi portatil con ubuntu beryl

Aram

+1
0
-1

Si lloras porqué se ha puesto el Sol, las lágrimas en los ojos no te dejarán ver la luz de las estrellas (R. Tagore)

Imagen de Mikerm
+1
0
-1

Oie me aparece lo mismo que a Abram, y en el xorg.config tengo desabilitado el "composite" y nada...
sigue saliendo lo mismo, lo de beryl pues tengo Ubuntu Ultimate 1.3 y ya viene instalado, aunque no e podido disfrutar de sus efectos y herramientas, los temas poes stoy usando de los temas de GNOME,
alguieeeen ayudemeeeeeeeeeee stoe al borde de la locura jajajajaja
mi tarjeta de video es la: ATI Radeon Xpress 200
heeelp wanted.
saludos a todos.

-----------------------------Edito --------------------------------------------------
Me tope con este manual
http://wiki.cchtml.com/index.php/Ubuntu_Edgy_Installation_Guide#Method_2...
segui el metodo 2, que es para la ati xpress 200 con amd
me funciono perfecto, peero el beryl sigue sin correr :(:(:(...
ya venia instalado... puedo meterme a las ventanas de configuraciones y abrir el smerald theme manager pero no puedo aplikar el entorno beryl, tengo aplicado el Gnome (N)... ayuda please

"La creencia en un enlace universal de compartir que conecta a toda la humanidad."

+1
0
-1

"La creencia en un enlace universal de compartir que conecta a toda la humanidad."

Imagen de alvbarrett
+1
0
-1

tengo el mismo problema que Aram...y de hecho cuando reinicio el motor gráfico, y trato de usar el xgl...como instale é beryl...y me aparece la pantalla totalmente en blanco...y ahí si puedo usar el cubo...pero esté en blanco y no puedo hacer nada...la descripción que dio Aram es la misma q daría yo...sólo que mi tarjeta gráfica es una ATI x300

sería buenísimo si me ayudaran

hasta luego !!

+1
0
-1
Imagen de Gordot
+1
0
-1

Yo también estoy teniendo problemas de dirvers con mi máquina, pero mi tarjeta es una nvidia y aun sigo buscando posibles soluciones.

Me acabo de bajar la versión alpha de Uberyl (ubuntu + beryl), que es un live-cd y también puedes instalarlo. La probé en una portátil de mi trabajo (Sony Vaio VGN-S30F) con una tarjeta de video Ati Mobility Radeon 9200, y corrió bastante decente, aunque un poco lento claro, pues lo estaba corriendo desde el cd.

Puedes probarla si quiereres, y si deseas saber más la web es http://pollolinux.blogia.com/ donde puesdes además ver los enlaces de descarga.

=====================================================================================================
Ominis enim res, quae dando non deficit, dum habetur et non datur, nondum habtur, quomodo habenda est.

+1
0
-1

=================================================================================

Ominis enim res, quae dando non deficit, dum habetur et non datur, nondum habetur, quomodo habenda est.

Imagen de Aram
+1
0
-1

Hola Gordot,

Ostras, la tarjeta no es la misma, pero tiene buena pinta, aunque dudo que vaya con este portátil mio, seguro que me sirve para 'vender' Ubuntu a mas de uno.

+1
0
-1

Si lloras porqué se ha puesto el Sol, las lágrimas en los ojos no te dejarán ver la luz de las estrellas (R. Tagore)

Imagen de evilshadow
+1
0
-1

Wnas!

Yo tengo este mismo portatil y he de decir que tengo aceleracion grafica siempre y cuando entre en una sesion que no este con Beryl. Lo curioso es que aunque entre en la sesion en la que tengo Beryl funciona todo correctamente. Tambien decir que cuando arranco gnome tal cual y hago la prueba de la aceleracion grafica obtengo 1300 fps y pico. El manual que yo segui para tener aceleracion grafica fue el siguiente:

1. Abres una consola y escribes
sudo apt-get install linux-headers-version-de-su-kernel
2. sudo apt-get install linux-restricted-modules-version-de-su-kernel
3. sudo apt-get install fglrx-control xorg-driver-fglrx
o tambien puedes localizarlos desde el gestor de paquetes synaptic
4. modprobe agpgart
5. modprobe -r fglrx
6. sudo gedit /etc/X11/xorg.conf y modificas el apartado de la tarjeta gráfica, reemplazándolo por:
Section “Device”
Identifier “ATI Technologies, Inc. Radeon 9200 SE (RV280)” (aqui indicará el modelo que tengas)
Driver “fglrx”
BusID “PCI:1:0:0”
Option “VideoOverlay” “on”
Option “OpenGLOverlay” “off”
Option “UseInternalAGPGART” “no”
EndSection
7.- sudo gedit /etc/modules y añades en el archivo las siguientes líneas:
agpgart
fglrx
8.- Reinicias y a probar que hay aceleración ejecutando en un terminal:
glxgears (tiene que dar entre 700 y 1000 frames/seg).
glxinfo (tiene que poner “Direct Rendering yes”).

Segui estos pasos al pie de la letra y me funciono a la primera, nada de segundos intentos. Despues hice la instalacion de Beryl, creo recordar que con el apt-get, despues de haber descargado las pgkey y despues de haber añadido unas entradas a los repositorios (o tal vez no, no me acuerdo).

Para el tema de la instalacion de Beryl, segui este tutorial: http://plinux.wordpress.com/2007/02/04/instalar-xgl-y-beryl-en-ubuntu/

Saludos!

+1
0
-1

____________________________________________________

Mi blog: http://www.krispytech.com/

Imagen de Aram
+1
0
-1

He probado lo que me dices, todo lo que hay que instalar ya lo he instalado, pero al cambiar la configuración del xorg...... CATACRACK, no reinicia GDM he tenido que entrar en una sesión de consola y poner la configuración de las Xorg que tenia antes.

Bueno, que nada de nada... que no le da la p.... gana de funcionar....-. :-(

¿Alguna sugerencia más?

Gracias

Aram

+1
0
-1

Si lloras porqué se ha puesto el Sol, las lágrimas en los ojos no te dejarán ver la luz de las estrellas (R. Tagore)

Imagen de Aram
+1
0
-1

Yo tengo otro ordenador con una nvidia y antes no conseguía aceleración 3D hasta que me instale los drivers propios de nvidia, hace mucho tiempo de esto y no recuerdo los pasos exactos que seguí, solo recuerdo que fue muy fácil. Busca en la propia web de nvidia los drivers, creo que allí indicaba como instalarlos ....

Suerte.

PD si no lo consigues dímelo e intento encontrar lo que hice, el beryl va de P.M. en esa maquina con la nvidia.

Saludos

Aram

+1
0
-1

Si lloras porqué se ha puesto el Sol, las lágrimas en los ojos no te dejarán ver la luz de las estrellas (R. Tagore)

Imagen de dracool
+1
0
-1

***********************************
Te muevo al Foro Correspondiente
***********************************

*********************************
Equipo de moderadores del Foro ubuntu
Normas del Foro
********************************

+1
0
-1