Duda sobre los kernels precompilados

Imagen de Silveste
0 puntos

Tengo ubuntu funcionando en dos maquinas, un pentium III y un amd 64 bits. Hasta ahora instalaba los kernel optimizados para estos procesadores es decir: linux-image-version-i686 y linux-image-version-amd64, sin embargo ahora tengo instalada en ambos el linux-image-2.6.17-11-generic porque no hay las versiones especificas de estos microprocesadores
¿Porque ocurre esto?
¿A partir de ahora existirá un kernel compilado para todos los procesadores o es algo temporal?

un saludo

Imagen de gabiel
+1
0
-1

A partir de Edgy no se crean imágenes precompiladas para cada arquitectura. Según las pruebas que se realizaron, apenas había una mejora apreciable del rendimiento en la mayoría de los casos; así que decidieron que no merecía la pena el esfuerzo de mantener las distintas imágenes.

En principio no parece que vayan a cambiar esta política; así que por ahora si quieres un kernenl específico para tu arquitectura, tendrás que compilarlo a mano ;)

Saludos.

PD: Ahora no tengo el enlace correspondiente; pero en el wiki de Ubuntu aparecía explicado con más detalle.

♠ ♣ ♥ ♦
Este comentario puede contener trazas de cacahuetes, almendras y germen de trigo.
[Documentación oficial][Normas del foro]

+1
0
-1
Imagen de Silveste
+1
0
-1

Supongo que las mejoras son mínimas entre un generico y un procesador con arquitectura x86, pero ¿no te parece un poco extraño que no hay mejoras entre una arquitectura de 32 bits y una de 64?
o es que son las aplicaciones las que presentan estas mejoras.

Tengo mucha curiosidad respecto al tema y me gustaria que me recomendases algun sitio para leermelo aunque tampoco te agobies porque como he dicho antes es curiosidad no se trata de un problema

Muchas gracias y un saludo

+1
0
-1
Imagen de pipo
+1
0
-1

Hola, para el amd64 no tuviste que bajar una iso distinta? quiero decir, la diferencia no estará ya ahi incluida?

____________________________________________
http://coladevelo.blogspot.com por si os sirve. y eso.

+1
0
-1

______________________________________________________
http://coladevelo.blogspot.com por si os sirve. y eso.

Imagen de TASADAR-F
+1
0
-1

Es que el kernel de las versiones de 64bits esta compilado y optimizado para una version de 64bits por eso tienes que bajarte una iso diferente y los repositorios son diferentes

+1
0
-1
Imagen de pipo
+1
0
-1

Ezo mismoXD
__________________________________________
http://coladevelo.blogspot.com por si os sirve. y eso.

+1
0
-1

______________________________________________________
http://coladevelo.blogspot.com por si os sirve. y eso.

Imagen de Silveste
+1
0
-1

Teneis razon no me habia fijado en ese pequeño detalle

muchas gracias otra vez

+1
0
-1
Imagen de voyager1
+1
0
-1

Hola

Yo tengo un PIII, según lo que he leido, sería mejor un kernel el que sea, pero para -686 sin embargo yo he evolucionado desde breezy con kernel -386 a edgy y he intentado cambiar a el kernel para 686 y me aparece un mensaje de dice kernel panic

Visto vuestros mesajes me quedo con el kernel para 386, proque hay diferencias mínimas.

Muchas gracias

+1
0
-1

usuario de gnu con kernel linux número 481.784

Antes de preguntar suelo hacer ...RTFM y STFW, es decir, intento leer la correcta pagina del manual, y buscar la solución por la red. Evidentemente siempre me quedan manuales y paginas por leer, e intento

Imagen de TASADAR-F
+1
0
-1

En edgy hay 2 kernels el 386 y el generic. Yo uso uso el generic aunque en tu caso supongo que dara lo mismo. EL generic te detecta si tienes varios procesadores o nucleos

+1
0
-1