Feisty Fawn y Nvidia rompe servidor x

Hola. He instalado Feisty Fawn herd 5 y cuando instalo los drivers Nvidia, al reiniciar se rompe el servidor x y solo puedo actuar con líneas de comando con lo cual tengo que desinstalar y reinstalar el backup de xorg.conf para solucionarlo. Es que la instalación por defecto no lo configura o es que hay que hacerlo manualmente? mi gráfica es una fx 5200 128 mb. Alguien tiene alguna solución? Gracias

Imagen de teri
+1
0
-1

Eso se sebe a que aún la distribución de Feisty Fawn es inestable aún hasta que no cumpla el plazo de los 6 meses para ser estable. Yo cuando actualicé mi sistema también se me rompió el servidor X y la solución era arrancar con el kernel que tenía antes de actualizarlo. Es bastante recomendable que te instales la última versión estable.

+1
0
-1
Imagen de ator_18
+1
0
-1

Hoy mismo he instalado feisty fawn en un nuevo equipo que he comprado, casualmente con una Nvidia. En una de las actualizaciones (y tras instalar vmware) rompio el entorno grafico que tenia configurado con el driver de nvidia.

Lo solucione del siguiente modo:

1) Restaura el xorg.conf original
sudo cp /etc/X11/xorg.conf.backup /etc/X11/xorg.conf
Si te sale algun error, es que tu xorg.xonf original tiene otro nombre (en mi caso era xorg.conf.backup), haz un ls -l /etc/X11/xorg.conf y elige el que tenga la fecha mas antigua.

2) Reinicia:
sudo reboot

3) Abre una terminal y escribe:
sudo rm /etc/init.d/nvidia-*
sudo apt-get --purge remove nvidia-glx nvidia-settings nvidia-kernel-common
sudo dpkg-reconfigure -phigh xserver-xorg
Te pedira ahora que selecciones el controlador, elige nvidia (a mi me lo cambio por vesa)

4) Aunque no es necesario, para evitar futuros errores, deshabilita el modulo nv:
sudo gedit /etc/default/linux-restricted-modules-common
Ahora edita esta linea:
DISABLED_MODULES=""
para que quede asi:
DISABLED_MODULES="nv"

5) Ahora reinicia.

6) Si todo ha ido bien, vuelve a hacer una copia de tu xorg.conf:
sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.backup

Linux: La puerta mejor cerrada es aquella que puede dejarse abierta.

+1
0
-1
Imagen de guajiro
+1
0
-1

Gracias por el tutorial pero no entiendo porqué instalandolo con synaptic no funciona, despues investigando lo configuré y ya funciona. Pero con Edgy me pasó lo mismo al activar los drivers y Beryl. Deberian poner más enfasis en estos detalles que todo el mundo no sabe recuperar el sistema. Por cierto creo que Feisty necesita Vmware beta o algo así he leido por ahi.

+1
0
-1
Imagen de moroncin
+1
0
-1

He intentado hacer lo que dice pero he tenido un problema:

Cuando intento la primera linea para poner el backup me dice que el fichero no existe tal y como tu indicas hago ls -l ....... y me responde algo que no logro entender: -rw-r--r= 1root root 3549 2007-03-08 22:49 /etc/X11/xorg.conf lo único que he conseguido avanzar por un lado es que mi carpeta se llama X11(x mayúscula) y creo que mirando la carpeta que indicas(X11) he visto tras archivos que supongo serian los backup y ninguno tenia fecha anterior al 8 de marzo que es cuando tuve el problema

+1
0
-1
Imagen de ator_18
+1
0
-1

Si no has guardado manualmente una copia de seguridad del xorg.conf no tendras el xorg.conf.backup. Ahora bien, si escribes:
ls /etc/X11/xorg.conf*
deberan salirte varios archivos parecidos a este:
/etc/X11/xorg.conf.20070316180943
Eso es porque el sistema crea una copia de seguridad del xorg.conf cuando lo modificamos. Los numeros indican una fecha y una hora, en mi caso 16/03/2007 a las 18:09 (el 43 son los segundos). Asi que prueba restaurando alguno de ellos.

Linux: La puerta mejor cerrada es aquella que puede dejarse abierta.

+1
0
-1
Imagen de guajiro
+1
0
-1

He activado los driver propietarios en sistema -administración-restricted manager drivers, despues reinicio y se cuelga y esto dos veces. Que es lo hago mal, hace faklta algun comando extra para configurarlo via terminal? sabes el proceso para su instalacion en feisty porque este "automatico" me rompe el servidor x.

+1
0
-1
Imagen de ator_18
+1
0
-1

Si instalas los drivers propietarios, no puedes instalar los que aparecen en los repositorios. Trata de restaurar el xorg.conf

Linux: La puerta mejor cerrada es aquella que puede dejarse abierta.

+1
0
-1