Dual Ubuntu-XP: Disk I/O Error en hda1

Imagen de Tuttle
0 puntos

Saludos,

migré a Ubuntu feisty hace unos diez días, y aunque estoy encantado con la comunidad lo cierto es que me está haciendo sudar la camiseta entre configuraciones y aprendizaje de bash a base de collejas... Lo último me está dejando ya sin recursos, así que me permito pediros ayuda.

Trabajo con un laptop Acer Aspire 1621LM. Antes de instalar Feisty desde el Alternate CD (y por tanto de meter el GRUB), ejecuté una instalación a mínimos de Win XP pro para poder correr un par de aplicaciones y juegos que no tenían garantizado funcionar bajo WINE. Una vez funcional el XP, instalo Ubuntu. Todo correcto. Me quedo con tres particiones...

hda1 - FAT32 de 12 GB, win xp pro
hda5 - swap de 256 MB
hda6 - ext3 de 26 GB para ubuntu

durante unos días el GRUB funciona perfecto. Ningún problema para alternar el arranque entre OS's. Pero a partir de un cuelgue del linux intentando configurar la gráfica, tras el arranque de Ubuntu se llena la pantalla de números (por lo que averigüé, la comparación entre el boot sector y su backup) terminando con el aviso "Not automatically fixing this." A los pocos segundos, Ubuntu retoma el hilo y carga. Tras unos googles, leo a alguien aconsejando desactivar el chequeo de FAT en el fstab para que no salga el error, y de paso acelerar el arranque de Ubuntu.

El tema funciona, pero parece que ha sido pan para hoy y hambre para mañana porque a la siguiente vez que intento arrancar el XP desde GRUB no tarda ni dos segundos en devolverme al menú de arranque, sin ni siquiera haber asomado la nariz el NTLDR de windows. Ubuntu va sin problemas, pero el XP nada. El último intento ha sido arrancar con el CD-ROM de Super Grub Disk y probar "Arreglar arranque de Windows" (o sea, hacer un Fix MBR) y luego incluso probar una herramienta en fase beta de la misma aplicación para Arreglar específicamente la partición donde arranca Windows. Nada. La cosa no rula, tengo que restaurar el GRUB y además ahora sale al intentar arrancar XP

Disk I/O error
Replace disk and press any key...

el asunto es que desde Ubuntu el contenido de hda1 se ve absolutamente normal, incluyendo los archivos de la raíz de windows. Y yo ya no sé qué probar. Me resisto a hacer un backup de toda la partición de linux para formatear y reinstalar todo (más que nada para evitar el coñazo de volver a instalar y configurar bien Ubuntu, que me ha costado lo mío). Os dejo el final de mi menu.lst resumido, aunque todo parece normal...

## ## End Default Options ##

title Ubuntu, kernel 2.6.20-12-generic
root (hd0,5)
kernel /boot/vmlinuz-2.6.20-12-generic root=UUID=e1bdb5e4-0138-4dd5-8327-c767dc48e6bf ro quiet splash
initrd /boot/initrd.img-2.6.20-12-generic
quiet
savedefault

title Ubuntu, kernel 2.6.20-12-generic (recovery mode)
root (hd0,5)
kernel /boot/vmlinuz-2.6.20-12-generic root=UUID=e1bdb5e4-0138-4dd5-8327-c767dc48e6bf ro single
initrd /boot/initrd.img-2.6.20-12-generic

### (aquí van las generic y generic recovery mode de tres versiones antiguas de kernel)

title Ubuntu, memtest86+
root (hd0,5)
kernel /boot/memtest86+.bin
quiet

### END DEBIAN AUTOMAGIC KERNELS LIST

# This is a divider, added to separate the menu items below from the Debian
# ones.
title Other operating systems:
root

# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/hda1
title Microsoft Windows XP Professional
rootnoverify (hd0,0)
savedefault
makeactive
chainloader +1

Espero que el rollo sea clarificador y sirva de algo. Gracias por vuestro tiempo y un saludo.

Imagen de Jorolo
+1
0
-1

Hola tuttle.

Para las consultas relacionadas con windows tenemos un foro específico, allá nos vamos.


Equipo de moderadores del Foro ubuntu
Normas del Foro
+1
0
-1
Imagen de Tuttle
+1
0
-1

Ok, gracias y disculpas. Cuando lo he visto ya había colgado el topic.

+1
0
-1