Problema con Driver ATI radeon xpress 200series

Imagen de steel1
0 puntos

Descripcion:
Ati Radeon Xpress 200 series
AMD Atlhon 64

He tratado de instalar el driver ati 4 veces en mi Ubuntu 6.06
pero no he podido instalarlo me dice que hay un error que puedo hacer
para arreglarlo por que generalmente como no se la formateo
les agradeceria si me ayudan me quiero pasar a ubuntu ya windows
me esta dando muchos problemas.

Por cierto para instalar los driver ati uso este tutorial
http://www.elblogdemaverick.com/?p=13

Imagen de netsilence
+1
0
-1

Si me equivoco en algo en el comentario por favor que alguien me corrija, porque lo que digo lo digo de lo poco que he trasteado con mi ati xpress 200 series.

Puedes optar por instalar los driver fglrx o el driver libre radeon.

La diferencia es que se supone que los drivers fglrx dan mayor rendimiento, pero sobre algunas tarjetas dan problemas. El driver libre radeon no aporta tanta potencia.

El driver fglrx lo puedes instalar desde synaptic (Lo buscas y lo marcas), y desmarcas el xserver-xorg-video-ati. Compruebas luego en el archivo /etc/X11/xorg.conf en la seccion device (section "device") donde ponga driver un poco mas abajo ponga driver "fglrx", si no lo pone lo modificas tú, añadiendo al final del fichero las lineas que deshabilitan el composite (lo tienes en la direccion que has pegado tú mismo).

Puedes ver como instalar el driver libre radeon en esta pagina http://sigt.net/archivo/instalar-beryl-con-aiglx-en-ubuntu-610-edgy-con-...
Yo tengo la misma tarjeta y puedo activar la aceleración pero no puedo instalar beryl, me consta que no soy el unico y tambien me consta que esto dicen se soluciona en la nueva version de ubuntu que sale el mes que viene, no obstante si consigues que te funcione beryl te agradecería que comentases como lo has hecho ;).

Si tienes alguna duda específica o alguna duda sobre lo que te he comentado sigue posteando y te ayudo en lo que pueda.

Saludos!

+1
0
-1
Imagen de santi...
+1
0
-1

Yo tengo la misma tarjeta y funcionan todos los drivers de ati, lo mejor es instalar el fglrx desde los repositorios como dice netsilence, pero se le han olvidado algunos pasos, para que no te ocurra esto usa este script:

http://www.ubuntu-es.org/index.php?q=node/39476

si has instalado otros drivers antes es posible que haya alguna incompatiblidad, si todo va bien despues de reiciar deberias tener algo como esto al escribir "fglrxinfo" en terminal:

display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON XPRESS Series Generic
OpenGL version string: 2.0.6011 (8.28.8)

si te sale "mesa" entonces escribe en terminal:

depmod -a

y vuelve a reiniciar... si sigue sin ir bien es posible que tengas que hacer alguna otra cosa debido al AMD... busaca informacion por ese camino.

El driver raedon NO proporciona aceleracion gracica en la x200, aunque se puede hacer funcionar beryl sin xgl... pero no podras usar googleearth y los juegos 3D no te iran o iran muy despacio.

Respecto al beryl a mi solo me ha funcionado con XGL.. No instalando la ultima version, sino una anterior... despues de instalar pide actualizar.... NO hay que actualizar , porque sino te instala la ultima version que no funciona... entonces hay que quitar beryl de los repositorios y dejarlo sin actualizar... aver si en proximas versiones se soluciona

EDITO:
si has seguido la guia de maverick y no has cometido ningun fallo, todo deberia ir bien, de todas formas lo mejor es instalar el fglrx de los repositorios, da menos problemas y funciona igual de bien que el de la pagina ati, de echo son los mismos, lo unico que el de la guia de maverick es una version ligeramente posterior que solo arregla algunos problemas en ciertas tarjetas, si no necesitas esa version lo mejor es instalar desde repositorios.
si no te funciona el sistema de maverick (y lo has hecho bien) posiblemente el problema venga del AMD...
Si ya instalaste el 8.33.6 de la guia de maverick y usas el script... despues de reiniciar tendras que hacer "depmod -a" y volver a reiniciar.
Si

+1
0
-1

.....................
...Pero no me hagas mucho caso... no soy ningun experto.

Imagen de steel1
+1
0
-1

Por cierto el Driver que le trato de instalar es el https://a248.e.akamai.net/f/674/9206/0/www2.ati.com/drivers/linux/ati-dr... y que puedo hacer cuando inicio me dice que hay un error en la configuracion grafica como puedo solucionar eso por que generalmente la formateo cuando me daba ese error. Ubuntu 6.06 64bit

+1
0
-1
Imagen de hugolino
+1
0
-1

la idea sería que digas qué error te da para poder ayudarte...

supongo que el error es el clásico "servidor X dañado blablal", te pide que pongas "si" o "no", poné "no" y te manda a línea de comandos, ahí tenés varias opciones:

-hacé "dpkg-reconfigure xserver-xorg" y seguí el asistente eligiendo al principio el driver "vesa"

-hacé "sudo nano /etc/X11/xorg.conf" (no me acuerdo si Xorg va con mayúscula o minúscula) y buscá la sección que dice "Device" y donde dice "driver" cambiá lo que diga al lado (fglrx o radeon) por vesa y guardalo

ahora hacé "startx" y debería andar

+1
0
-1
Imagen de steel1
+1
0
-1

Y que hago ahora reintalar los driver y verificar que si hice algo mal

+1
0
-1
Imagen de santi...
+1
0
-1

si realmente quieres instalar el 8.34... a mi me ha dado algunos problemas... utiliza este script:

http://www.ubuntu-es.org/index.php?q=node/40119

Si quieres instalar el 8.28 utiliza el que te indique antes
Los dos te lo instalan automaticamente, solo copias el script y lo lanzas (sigue las instrucciones)

+1
0
-1

.....................
...Pero no me hagas mucho caso... no soy ningun experto.

Imagen de steel1
+1
0
-1

Bueno por fin pude instalar los driver ati y tengo aceleracion 3D pero lo que me hace falta es beryl si me dieran un tutorial de como instalarlo se los agradeceria beryl para Ubuntu Dapper 6.06 de 64Bit

 Gracias

+1
0
-1