Modem huawei en version actualizada de UBUNTU

Imagen de elotroangel
0 puntos

Bueno despues de muchos problemas pude hacer andar el modem HUAWEI de telecom Argentina en Ubuntu siguiendo esta guia: http://69.60.114.106/www.kubuntu-es.org/public_html/?q=node/1470

al actualizar el equipo en el arranque ahora me da las opciones de la version instalada o la version actualizada ... cuando quiero entrar a la version actualizada el modem no me funciona ... o sea queda una sola luz prendida (la de power) ... trato de reinstalarlo siguiendo la misma guia pero no me deja... ya en el primer paso de instalar los linux headers me tira este error :

 
matanga@matanga-desktop:~$ uname -r 
2.6.15-28-386
matanga@matanga-desktop:~$ sudo apt-get install build-essential linux-headers-2.6.15-28-386
Password:
Reading package lists... Done
Building dependency tree... Done
build-essential is already the newest version.
The following extra packages will be installed:
  linux-headers-2.6.15-28
The following NEW packages will be installed:
  linux-headers-2.6.15-28 linux-headers-2.6.15-28-386
0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
Need to get 7762kB of archives.
After unpacking 79.6MB of additional disk space will be used.
Do you want to continue [Y/n]? y
Err http://security.ubuntu.com dapper-security/main linux-headers-2.6.15-28 2.6.15-28.51
  Temporary failure resolving 'security.ubuntu.com'
Err http://archive.ubuntu.com dapper-security/main linux-headers-2.6.15-28 2.6.15-28.51
  Temporary failure resolving 'archive.ubuntu.com'
Err http://security.ubuntu.com dapper-security/main linux-headers-2.6.15-28-386 2.6.15-28.51
  Temporary failure resolving 'security.ubuntu.com'
Err http://archive.ubuntu.com dapper-security/main linux-headers-2.6.15-28-386 2.6.15-28.51
  Temporary failure resolving 'archive.ubuntu.com'
Failed to fetch http://archive.ubuntu.com/ubuntu/pool/main/l/linux-source-2.6.15/linux-headers-2.6.15-28_2.6.15-28.51_i386.deb  Temporary failure resolving 'archive.ubuntu.com'
Failed to fetch http://archive.ubuntu.com/ubuntu/pool/main/l/linux-source-2.6.15/linux-headers-2.6.15-28-386_2.6.15-28.51_i386.deb  Temporary failure resolving 'archive.ubuntu.com'
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
matanga@matanga-desktop:~$

Alguien que me de una mano!!

Imagen de lauchacba
+1
0
-1

http://www.ubuntu-es.org/index.php?q=node/36369

solo repti la remoción de modulos, el drivers y el firmware.
en mi caso, borre la carpeta inicial donde estaba el driver ( primera ves)
te cito mi blog, por que en ese seria el paso cuarto, quinto y sexto, nada más.

========================================
http://ar.geocities.com/novatocba/doc/files/ubuntu-linux.pdf
http://www.gnu.org/philosophy/free-sw.es.html
el exito de windows fue y es pensar en la familia,,,
linux sigue creciendo,,,

+1
0
-1

ubuntu sin internet-offline

http://novatocba.netii.net/

http://www.ubuntu-es.org/index.php?q=Preguntas_Frecuentes

de nuevo en linea... y con ubuntu..

Imagen de elotroangel
+1
0
-1

Intente desinstalar la carpeta del driver pero no me deja ... como se haria eso desde consola ... la carpeta esta en el home

 

trate de hacer lo que me dijiste pero mira lo que me aparece


matanga@matanga-desktop:~$ tar -xvzf ueagle-atm-1.3.tar.gz

ueagle-atm-1.3/

ueagle-atm-1.3/COPYING

ueagle-atm-1.3/Makefile

ueagle-atm-1.3/ueagle-atm.c

ueagle-atm-1.3/usbatm.c

ueagle-atm-1.3/usbatm.h

ueagle-atm-1.3/README

matanga@matanga-desktop:~$ cd ueagle-atm-1.3

matanga@matanga-desktop:~/ueagle-atm-1.3$ sudo make

make -C /lib/modules/2.6.15-28-386/build M=/home/matanga/ueagle-atm-1.3

make: *** /lib/modules/2.6.15-28-386/build: No such file or directory. Stop.

make: *** [all] Error 2

matanga@matanga-desktop:~/ueagle-atm-1.3$ sudo make install make -C /lib/modules/2.6.15-28-386/build M=/home/matanga/ueagle-atm-1.3 modules_install

make: *** /lib/modules/2.6.15-28-386/build: No such file or directory. Stop.

make: *** [install] Error 2

matanga@matanga-desktop:~/ueagle-atm-1.3$

 

+1
0
-1
Imagen de lauchacba
+1
0
-1

te cuento, al actualizar el sistema te actualiza el kernel. por ende no funciona el modem por que ni idea.en edgy o ubuntu 6.10 yo lo que hice fue remover los modulos,reinstalar el driver y el firmware, este ultimo al repetir los pasos, parece que sesobre escriben los archivos, no hay drama,. tu kernel nuevo es el

tu kernel actualizado 2.6.15-28-386 puede ser?

para borrar el la carpeta del driver creo que seria asi:

$ sudo rm /home/ueagle-atm-1.3 

la otra, que no se pero creo que tenes que tener, es de modo gráfico :

$ sudo nautilus 

te pide el password, escribis, se abre una ventana como la del usuario pero es de root, ojito con lo que tocas, buscas la carpeta del driver  (uagle-atm-1.3) que esta en "sistema de archivos, home, ueagle-atm-1.3"  y la borras, después repetis lo de los modulos, el driver y el firmware. reinicias la maquina por las dudas si no parpadea la luz.

que viendo el post en el que te basaste seria: 

$ sudo lsmod | grep eagle

$ sudo modprobe -r eagle-usb

$ sudo rm /lib/modules/”uname -r”/kernel/drivers/usb/atm/usbatm.ko
$ sudo rm /lib/modules/”uname-r”/kernel/drivers/usb/net/eagle/eagle-usb.ko

reinstalación del driver

 

3-INSTALACION DEL DRIVER repetis lo que ya habias echo para el nuevo kernel:

Bien, ahora es el turno de instalar el driver, tipeamos:

$ tar -xvzf ueagle-atm-1.3.tar.gz
$ cd ueagle-atm-1.3
$ sudo make
$ sudo make install
$ cd

 y firmware:

$ tar xzf ueagle-data-1.1.tar.gz
$ cd ueagle-data-1.1

Lo que resta hacer es crear un directorio “ueagle-atm” dentro del directorio donde se almacenan los firmwares en el sistema, se hace de la siguiente manera: 

$ sudo mkdir /lib/firmware/ueagle-atm

Y se copia todos los archivos del directorio “ueagle-data-1.1” al directorio que recién hemos creado:

$ sudo cp -a *.* /lib/firmware/ueagle-atm

 eso tal cual, si bien tu ubuntu  parece ser  otra versión, por el kernel seria lo mismo.

después te dice algo de:

$ sudo modprobe ueagle-atm

$ dmesg | grep ueagle

si la luz no parpadea, no hay drama, si en el segundo comando te da error y no te muestra la firma, tampoco, reinicia el equipo y la teoria indica que cuando inicies seción, la luz parpadeara.

para conectarte haces : 

$ sudo modprobe br2684
$ sudo br2684ctl -c 0 -b -a 0.33
$ sudo ifconfig nas0 up

 

si queres probar el siguiente comando ( que reemplaza al  $ sudo pppd call adsl):

sudo pppoe-start para conectarte

sudo pppoe-stop  para desconectarte

espero te halla servido. 

+1
0
-1

ubuntu sin internet-offline

http://novatocba.netii.net/

http://www.ubuntu-es.org/index.php?q=Preguntas_Frecuentes

de nuevo en linea... y con ubuntu..