apache2 vs xampp

Imagen de josevbellver
0 puntos

Hola, a todos, me instalé el pack xampp para linux en el portàtil (apache, proftp, mysql,...), pero decidí quitarlo para ponerme apache2, mysql, php5, etc.... (Algo más normal y que se instala como siempre en /var/www, etc...)

 El problema que tengo ahora es que después de instalarme todos los paquetes necesarios (el el pc de sobremesa lo hice sin ningún problema pq inicialmente no tenia instalado xampp) ahora no me funciona el servidor. no tengo servidor web, y no se si es que xampp ha desviado el puerto 80 a otro sitio, y si tengo que volverlo a configurar.

 

Si alguien sabe como solucionarme el problema le estaría agradecido, sino siempre me queda volver a xampp ;-( 

 

Gracias.- 

Imagen de newcomplexlife
+1
0
-1

Revisa los logs (/var/log/apache/...) para determinar exactamente que pasa, si puedes publicarlo, hazlo. Saludos 

 

 

Venezuela al Software libre!!!! Newcomplexlife

+1
0
-1

Venezuela al Software libre!!!!

Imagen de Espetito
+1
0
-1

Es difícil responder con tan pocos datos pero suele ocurrir que cuando se instalan más de un servidor web en una misma máquina y ambos se ejecutan a la vez ninguno funcione porque ambos apuntan al puerto 80. Esto se soluciona desactivando (parando) un servidor y dejar sólo uno activo, el que interese o cambiando el puerto a uno de ellos (así funcionan los dos con distintos puertos). Es posible que tengas el servidor del XAMPP y el otro APACHE funcionando a la vez con el puerto 80, así ninguno funciona. Un consejo, desinstala XAMPP y quédate con el LAMP puro y duro. El XAMPP es para pruebas, no para un entorno de producción, es vulnerable. 

Espetito. Yo, Linux. Linux es libertad.

+1
0
-1

Espetito.
Yo, Linux. Linux es libertad.

Imagen de ragnarokmaiden
+1
0
-1

Como dijo Espetito tiene mucha razon , no es posible que los dos web server se ejecuten a la vez. Te comento que yo instale LAMP, y despues he decidido instalar XAMPP. Al principio no me funcionaba la configuracion de XAMPP, lo que hice fue parar el servidor de apache2

sudo /etc/init.d/apache2 stop

Enseguida levante con este comando el servicio de XAMPP

sudo /opt/lampp/lampp start

Con esto puede ir al navegador y teclear http://localhost y es cuando pude ver que el servicio de xampp ya estaba corriendo.

espero te sirva saludos!

+1
0
-1