Modem USB Huawei E220 de Vodafone

Imagen de pipols
0 puntos

Hola a todos!

No consigo hacer funcionar el p... modem este en Ubuntu! Busqué en todos lados y ninguna de las soluciones que encontré me sirven. Hay alguien al que le funcione? Me encantaría saber cómo. GRACIAS! 

Imagen de treses3
+1
0
-1

hola buenas

estoy en la misma situacion pero ademas añadimos win vista a la lista. Vodafone no da soporte mas que a los que pagan? -yvistacolgao-  canonicals estaria bien contactar con vodafone, eee... ;P

si sabeis algun driver ubuntu hacerlo saber!!!

tambien me molesta muucho

HELPME PLEASE

gracias

+1
0
-1
Imagen de treydo
+1
0
-1

Yo utilizo el modem usb de vodafone y al principio si que me dio un poco de quebradero de cabeza, pero ahora todo va fino, os explico de forma muy resumida lo que teneis que hacer.

 

1.- crear un alias para mod probe, por ejemplo huawei220, es decir, crea el siguiente archivo en /etc/modprobe.d/huawei220 con el contenido

#Huawei E220
alias huawei usbserial
options huawei vendor=0x12d1 product=0x1003

2.- ahora demontamos el modem (lo tectara como un CDROM) y le decimos que es un modem Huawei220, ejecuta estos comandos en la consola:

sudo umount /media/cdrom-1
sudo rmmod usb_storage
sudo modprobe huawei220

3.- ahora si hacemos un ls /dev/ttyUSB* y nos aparecen varios dispositivos quiere decir que nuestro linux ya puede utilizar el modem, pero antes hay que configurar la conexion (es un modem no... pues a por wvdial)

4.- edita el fichero /etc/wvdial.conf y copia el contenido de mi fichero:

[Dialer Defaults]
## Con este numero me funciona a mi:
Phone = *99***1#

## Este numero es el que se marca desde hassefroch XP
## si no os funciona con el anterior, probad este.
#Phone = *99#

Username = vodafone
Password = vodafone
Stupid Mode = 1
Dial Command = ATDT

[Dialer reset]
Modem = /dev/ttyUSB0
Init1 = AT

[Dialer pin]
Modem = /dev/ttyUSB0
Init1 = AT+CPIN=XXXX <<<<----- AQUI PONER VUESTRO PIN

[Dialer vodafone]
Phone = *99***1#
Modem = /dev/ttyUSB0
Baud = 460800
Init2 = ATZ
Init3 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ISDN = 0
Modem Type = Analog Modem
Init5 =AT+CGDCONT=1,"IP","ac.vodafone.es";

5.- Ahora a conectar, primero conectamos para meterle el pin al modem

sudo wvdial pin

6.- Ahora conectamos

sudo wvdial vodafone

tachaaaan!!!!, ya esta conectado nuestro maravilloso huawei 220 de vodafone. Para que nuestro sistema busque internet en el modem hay que cambiarle la ruta simplemente con :

sudo ip route del default ; sudo ip route add default dev ppp0

Espero os sirva, un saludo.

 

En la caja ponia: "Requiere Windows o superior..." por eso instale Linux

+1
0
-1

En la caja ponia: "Requiere Windows o superior..." por eso instale Linux

Imagen de kironte
+1
0
-1

Tengo un problema con tu explicación.

 

Cuando escribo wvdial pin me da el siguiente error: "Modem not responding" también he probado de escribir el siguiente comando wvdial vodafone y da el mismo error, que el modem no responde.

También decir que he probado las variables que habían con el número de teléfono que dices que puede variar, y sigue dando el mismo error, que el modem no responde.

 

También otra cosilla el cdrom-1 yo no lo tenía pero haciendo un ls /media/cdrom* me daba dos cosas "cdrom" y "cdrom0", probé con el cdrom0.

 

No se me ocurren más cosas que comentarte, si sabes como ayudarme te lo agradeceré.

 

Igualmente gracias por leerme. 

Escrito por Kironte

+1
0
-1

Escrito por Kironte

Imagen de treydo
+1
0
-1

desconecta el modem, en la consola ejecuta  dmesg -c para limbiar la cache, conecta el modem, espera unos 2 o 3 minutos y  ejecuta el comando dmesg copialo y pegalo en un post para que pueda ayudarte.

 

En la caja ponia: "Requiere Windows o superior..." por eso instale Linux

+1
0
-1

En la caja ponia: "Requiere Windows o superior..." por eso instale Linux

Imagen de kironte
+1
0
-1

tengo problemas con el paso 2.

 

Cuando le hago modprobe huawei220
Me da el siguiente error: FATAL: Module huawei220 not found.
 

 También tengo que decir que he hecho el ls  /dev/ttyUSB* y tampoco no me encuentra nada.

Escrito por Kironte

+1
0
-1

Escrito por Kironte

Imagen de treydo
+1
0
-1

He pasado la receta a mi blog y en ella te soluciono el problema del reconocer los dispositivos. 

http://www.ubuntu-es.org/index.php?q=node/45842 

 

En la caja ponia: "Requiere Windows o superior..." por eso instale Linux

+1
0
-1

En la caja ponia: "Requiere Windows o superior..." por eso instale Linux

Imagen de daka
+1
0
-1

Hola

 

Lo instalé con exito varias veces en Dapper, Edgy, y ahora en Feisty..."Todos los camino llegarán a Roma", no.... Lo hizo de una manera diferente.....pero soy principiante en Linux....Si alguien quiere intentarlo, muy bien..... disculpe mi Español:

Utilizo Kubuntu tambien... Dapper, Edgy y ahora Feisty.y funciona, a menudo, sin problema. Pero de vez n cuando como ya he dicho, tengo que "eject" o quittar el "cdrom" dos o trés veces y no entiendo porque. Una cosa que he notado ultimamente es que si dejo un cd en blanco en el cdrom del portatil no tengo que "eject" o quittar nada porque el Huawei no está mal-identificado como cdrom. Entonces voy a poner aqui las intrucciónes para Kubuntu, hoy en dia, que funcionan bien para mi. Intentalo otra vez. Creo que con paciencia y esfuerzo lo vas a configurar.

 

Hay que editar wvdial.conf (mis instrucciónes abajo)

* Mejor desactivar el pin y el wifi y el ethernet (especialmente al iniciar!!!!!!!!!!! es decir no se puede auto-iniciar el ethernet ni Wifi!!!)

mejor quitar todos los "Pendrives" tambien

1- pon cd en blanco en el cdrom
2- enciende el ordenador con Huawei enchufado
Como root
modprobe usbserial vendor=0x12d1 product=0x1003
(hay que quittar/sacar el Huawei E220 un ratito (2-4 segundos)
, y enchufalo otra vez... Espera hasta que la luz azul está parpeandose....

Antes de conectar puedes poner, si quieres:

(pero no hace falta)

ls -la /dev/ttyU*
probablamente dará ...
USB0 USB1 and USB2 .. )

* Si no llegan dos o trés puertas, USB 0,1 2, no conectará y tienes que empezar otra vez

Luego
wvdial hsdpa

[Dialer hsdpa]
Phone = *99***1#
Username = vodafone
Password = vodafone
Stupid Mode = 1
Dial Command = ATDT
Modem = /dev/ttyUSB0
Baud = 460800
Init2 = ATZ
Init3 = ATE0V1&D2&C1S0=0+IFC=2,2
ISDN = 0
Modem Type = Analog Modem
Init5 =AT+CGDCONT=1,"IP","ac.vodafone.es";

*****estás conectado

No soy experto en Linux (ni español) pero parece que tengo mucho experiencia con ese aparatito.

La verdad es que es posible y mas o menos sencillo

Que tienes suerte

Daka

 

+1
0
-1
Imagen de RGthundRclap
+1
0
-1

Agradezco tu ayuda. funciona;). pero permiteme hacerle unos arreglos para que no surjan dudas de los mas nuevos como me pasó a mi.

1. Abrir Terminal (en Aplicaciones/Accesorios)  y escribir esto:

sudo gedit  /etc/modprobe.d/huawei220

Esto creará un archivo en modprobe y abrirá un procesador de tecto para que lo edites (antes te pedirá la contraseña de administrador)  en el archivo escribes:

#Huawei E220
alias huawei usbserial
options huawei vendor=0x12d1 product=0x1003

guardas y cierras.

2. El 7.04 no me lo detectó como cdrom-1. no hay que intentar con el cdrom-0. ese es el cdrom d verdad.  para saber si lo detecta como cdrom yo hice:

ls /media/cdrom*

antes de conectar el modem (te musetra los cdroms)  lo mismo despues. si hay algumo + es que lo detecta como tal. Facil no?;)

solo si lo detecta como CD entonces tecleas en el terminal la primera linea  del paso2 explicado por Treydo:

sudo umount /media/cdrom-1

Sino esto sobra.

3.

sudo rmmod usb_storage
sudo modprobe huawei220

y si quieres haces el paso3 de Treydo.

4.Editas wvdia.conf igual que lo hiciste con huawei220 en el paso 1:

sudo getid /etc/wvdial.conf

y a partir de aquí haces exactamente lo que dice Treydo, pero con el comentario del segundo nº de phone no me funcionó y yo lo quité. es decir, en el archivo escribes:

[Dialer Defaults]
## Con este numero me funciona a mi:
Phone = *99***1#

Username = vodafone
Password = vodafone
Stupid Mode = 1
Dial Command = ATDT

[Dialer reset]
Modem = /dev/ttyUSB0
Init1 = AT

[Dialer pin]
Modem = /dev/ttyUSB0
Init1 = AT+CPIN=XXXX
<<<<----- AQUI PONER VUESTRO PIN

[Dialer vodafone]
Phone = *99***1#
Modem = /dev/ttyUSB0
Baud = 460800
Init2 = ATZ
Init3 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ISDN = 0
Modem Type = Analog Modem
Init5 =AT+CGDCONT=1,"IP","ac.vodafone.es";

guardas y cierras 

5.en el terminal:

sudo wvdial pin

y ya lo tienes;)

6. para conectarte es:

sudo wvdial vodafone

y.. ¿no se vuelve azul la lucecita verde?:) 

7. 

sudo ip route del default ; sudo ip route add default dev ppp0

 Ahora.. siempre que quieras conectar usas el paso 6.

 Es lo mismo que decia Treydo pero sin tener que quitar el cdrom-1 (q al no haberlo tampoco pasa nada si lo quitas :D)

Lo unico es que si cierro el terminal se me desconecta :(

 

 

 

+1
0
-1
Imagen de Euridice
+1
0
-1

hola!

 

Estoy intentnado instalarlo siguiendo tus indicaciones, pero me quedo estancada en el tercer paso.

 No me detecta el modem de ninguna manera...

dice: FATAL: Module huawei220 not found

 

¿Cómo puedo hacerlo?

 

gracias!!

 

+1
0
-1
Imagen de RGthundRclap
+1
0
-1

me pasó la 2ª vez q lo editaba.

reinicia con el modem enchufado (ojo con q la bios no kiera iniciar desde la unidad extraible) y prueba de nuevo desde ese paso. si sigue asi, pasalo por alto (eso hice yo y funciona, parece que feisty se da cuenta de que no es una memoria usb sino lo que es)

si sigue sin detectarlo prueba con poner otra ID de USB en el archivo q creaste. 

+1
0
-1
Imagen de jasp255
+1
0
-1

He logrado, siguiendo los pasos indicados que el modem se conecte (sale una luz azul permanente), pero no puedo conectar con ninguna página.

He ejecutado: 

sudo ip route del default ; sudo ip route add default dev ppp0

 Pero, aunque aparentemente no da error, no me puedo conectar ni hacer ping a ninguna máquina de internet.

Imagino que es algo relacionado con la sentencia "route", que habrá que poner algo mas. Me podeis ayudar?

+1
0
-1
Imagen de Euridice
+1
0
-1

Estoy intentando conectarlo de distintos modos, pero ya en el pirmer paso que porpones me dice:

 

"Permission denied"

 

¿Qué hago?

 

 

Gracias...

+1
0
-1
Imagen de mithdesigns
+1
0
-1

Hola, soy muy nuevo en esto y estaba intentando hacer lo que decíais para poder utilizar el modem usb E220 de Huawei (Vodafone) y en algo me he equivocado y ahora ni siquiera lo reconoce (cuando hago sudo rmmod usb_storage indica que no hay ningún dispositivo de almacenamiento usb).¿De qué manera puedo hacer que lo detecte, y entonces poder terminar de configuarlo (siguiendo estas intrucciones), o la he cagado definitivamente?? es que el modem ni siquiera es mío (glups!). Gracias, espero ansioso vuestras respuestas!

Mith

+1
0
-1
Imagen de RGthundRclap
+1
0
-1

Acabo de instalar el ubuntu,  había utilizado Mandrake 9.2 y allí accedía como usuario ROOT y podía morificar archivos.

Aki lo de root solo me sale en la consola.. cómo modifico o creo archivos en modprobe?? cómo es lo del alias... Solo conozco lo que mandrake hacía solo.. hechadme una mano xq sino no podré prescindir del windows.

+1
0
-1
Imagen de kironte
+1
0
-1

 

Tengo varios problemas el primero es que no me detecta ningún usb pues me dice esto. (pero si enchufo un pendrive me lo detecta como tal. 

guru:/etc/modprobe.d# ls -la /dev/ttyU*
ls: /dev/ttyU*: No existe el fichero o el directorio
 

 También cuando le tengo que decir umount /media/, le doy al tabulador para saber cuantos tengo y me da este resultado:

cdrom/          cdrom0/         MOBILE_CONNECT/

 

Osea tengo que hacer umount /media/MOBILE_CONNECT, pero ya lo hago y tampoco obtengo resultado ninguno, le doy otra vez y le hago un ls-la y me sigue saliendo el MOBILE_CONNECT.

 

No se me ocurre nada, por cierto, claro está, si hago wvdial pin o wvdial vodafone me dice:

 

guru:/# wvdial pin
--> WvDial: Internet dialer version 1.56
--> Cannot open /dev/ttyUSB0: No such file or directory
--> Cannot open /dev/ttyUSB0: No such file or directory
--> Cannot open /dev/ttyUSB0: No such file or directory

 

guru:/# wvdial vodafone

--> WvDial: Internet dialer version 1.56
--> Cannot open /dev/ttyUSB0: No such file or directory
--> Cannot open /dev/ttyUSB0: No such file or directory
--> Cannot open /dev/ttyUSB0: No such file or directory

 

Algún manual para torpes de verdad, jajaja, a ver si hay más suerte en el próximo, gracias.. 

Escrito por Kironte

+1
0
-1

Escrito por Kironte

Imagen de RGthundRclap
+1
0
-1

Que yo sepa (q es + bien poco)  hay que poner:

sudo ls /dev/ttyUSB*

en vex de ttyU*

y si no editas wvdial.conf  tal como Treydo publicó y yo transcribí, no sabrá en qué USB le tienes enchufado.   antes de editar wvconf me pasaba lo mismo.  fuí probando con cambiar USB0 por los otros USB  (1 y 2)  en el codigo de wvdial.conf.  al final resultó el USB0, pero hasta que no reinicié el equipo no aparecía el hardware.  luego puse:

sudo wvdial pin 

sudo wvdial vodafone  (ahora es cuando al parecer linux empezó a tener consciencia sobre el huawei. asi que repetí el paso del pin y el de conectar;)

cada vez que me meto a windows o apago sin desconectar, me toca folver a meterle el pin  pero funciona.

 Otra cosa.. si MOBILE_CONNECT no aparece como CDrom  no lo demontes.  sospecho que todo lo que está en /media no tiene xq ser CDrom  (y tengo entendido que en otras distros los dispositivos de red son carpetas en las q navegar, asiq tal vez sea eso lo que te aparece. Compruebalo con:

sudo ls /media/cdrom*

Soy novato y nose si mi mensaje ayuda o estorba, desdeluego el modem me funciona y es lo que hice;).

Suerte!  y cuidado d no sobrepasar el consume:D que aki no lo ves ni te avisa:P

+1
0
-1
Imagen de kironte
+1
0
-1

 

Tengo varios problemas el primero es que no me detecta ningún usb pues me dice esto. (pero si enchufo un pendrive me lo detecta como tal. 

guru:/etc/modprobe.d# ls -la /dev/ttyU*
ls: /dev/ttyU*: No existe el fichero o el directorio
 

 También cuando le tengo que decir umount /media/, le doy al tabulador para saber cuantos tengo y me da este resultado:

cdrom/          cdrom0/         MOBILE_CONNECT/

 

Osea tengo que hacer umount /media/MOBILE_CONNECT, pero ya lo hago y tampoco obtengo resultado ninguno, le doy otra vez y le hago un ls-la y me sigue saliendo el MOBILE_CONNECT.

 

No se me ocurre nada, por cierto, claro está, si hago wvdial pin o wvdial vodafone me dice:

 

guru:/# wvdial pin
--> WvDial: Internet dialer version 1.56
--> Cannot open /dev/ttyUSB0: No such file or directory
--> Cannot open /dev/ttyUSB0: No such file or directory
--> Cannot open /dev/ttyUSB0: No such file or directory

 

guru:/# wvdial vodafone

--> WvDial: Internet dialer version 1.56
--> Cannot open /dev/ttyUSB0: No such file or directory
--> Cannot open /dev/ttyUSB0: No such file or directory
--> Cannot open /dev/ttyUSB0: No such file or directory

 

Algún manual para torpes de verdad, jajaja, a ver si hay más suerte en el próximo, gracias.. 

Escrito por Kironte

+1
0
-1

Escrito por Kironte

Imagen de adrianhtorres
+1
0
-1

pudistes resolver el problema del modem , tengo el mismo problema q tu.

+1
0
-1
Imagen de RGthundRclap
+1
0
-1

no es sudo ls /dev/ttyU*

es sudo ls /dev/ttyUSB*

+1
0
-1
Imagen de adrianhtorres
+1
0
-1

no puedo hacerlo funcionar al p... modem de vodafone , siguiendo este post , al realizar el paso 2 : sudo modprobe huawei220 da error con el siguiente mensaje : FATAL: Module huawei220 not found.

tampoco reconoce el modem com CDROM , pero he leido q eso no era incoveniente y que se podia saltar el paso de desmontarlo.

Utilizo ubuntu feisty 7.04 

 

 

si alguien puede orientarme , soy nuevo en linux y no se como resolverlo.

+1
0
-1
Imagen de RGthundRclap
+1
0
-1

He tenido que reinstalar linux y la 2ª vez q configuraba el modem he observado que es + facil aun.  nose si sera x haber instalado actualizaciones previamente o no pero así fué:

segui los pasos que posteé en el anterior mensaje y al parecer no lo detecta ni como cd-rom ni nada de eso.. sabe que es un modem. lo digo porque todo esto sobraba (x lo que da error):

sudo umount /media/cdrom-1
sudo rmmod usb_storage
sudo modprobe huawei220

 

pero ignorandolo y siguiendo los pasos me conecto sin problemas.

IMPORTANTE:  despues de editar huawei220 (el primer paso) conectamos el modem, pero no lo reconoce. hay que reiniciarlo. es +, aunq lo tengas configurado y lo conectes cn linux iniciado no lo tecta.

solo lo hace mientras se arranca.

 

llevo poco aki y he hallado la forma de que funcione sin tener el terminal abierto ni tener que marcar los comandos del pin y vodafone cada vez q conecto. es facil, mediante lanzadores, y seguramente la mayoria lo sepais hacer, pero para los + nuevos si surgen dudas preguntad;) 

+1
0
-1
Imagen de adrianhtorres
+1
0
-1

despues de dos semanas buscando alguna solucion , y habiendo leido innumerables post , acabo de encontrar la solucion en el siguiente enlace : http://amedias.org/archives/20070604/tarjeta-3g-funcionando-en-ubuntu-y-...

solamente hay q descargar el paquete de instalacion y todo funciona  de maravillas , ubuntu feisty , reconoce el modem inmediatamente y se abra la aplicacion de vodafone mobile connect - una maravilla 

+1
0
-1
Imagen de kironte
+1
0
-1

He ido a la página que dices tío, y está de p.m., me arranca el programa de vodafone, pero ni me da opción a conectarme ni me pide el pin.

 Tal vez haya que configurar el wvidal.conf? 

 

 

Escrito por Kironte

+1
0
-1

Escrito por Kironte

Imagen de adrianhtorres
+1
0
-1

Para q funcione tenes q conectar el modem antes de arrancar ubuntu , cuando la luz azul comienza a parpadear , abres el programa de Vodafone Connect y entonces te pedira el pin y te dara la opcion de conectar . por lo menos asi me funciona a mi y hasta ahora nunca me ha fallado. espero tengas suerte

+1
0
-1
Imagen de kironte
+1
0
-1

He hecho lo que dices, he conectado el modem usb de vodafone antes de arrancar el portátil y nada.

 He escrito esto y me da una serie de errores imprseionantes, yo diría que tiene algo que ver el twistd y el python, alguien sabe resolver esta ecuación? jejeje.

/usr/bin/vodafone-mobile-connect-card-driver-for-linux-debug

2007/06/20 22:52 CEST [-] Log opened.
2007/06/20 22:52 CEST [-] twistd 2.4.0 (/usr/bin/python 2.4.4) starting up
2007/06/20 22:52 CEST [-] reactor class: <class 'twisted.internet.gtk2reactor.Gtk2Reactor'>
2007/06/20 22:52 CEST [-] Loading /usr/share/vodafone-mobile-connect-card-driver-for-linux/tap.py...
2007/06/20 22:52 CEST [-] Traceback (most recent call last):
2007/06/20 22:52 CEST [-]   File "/usr/lib/python2.4/site-packages/twisted/application/app.py", line 159, in getApplication
2007/06/20 22:52 CEST [-]     application = service.loadApplication(filename, style, passphrase)
2007/06/20 22:52 CEST [-]   File "/usr/lib/python2.4/site-packages/twisted/application/service.py", line 301, in loadApplication
2007/06/20 22:52 CEST [-]     application = sob.loadValueFromFile(filename, 'application', passphrase)
2007/06/20 22:52 CEST [-]   File "/usr/lib/python2.4/site-packages/twisted/persisted/sob.py", line 206, in loadValueFromFile
2007/06/20 22:52 CEST [-]     exec fileObj in d, d
2007/06/20 22:52 CEST [-]   File "/usr/share/vodafone-mobile-connect-card-driver-for-linux/tap.py", line 90, in ?
2007/06/20 22:52 CEST [-]     device = get_device()
2007/06/20 22:52 CEST [-]   File "/usr/share/vodafone-mobile-connect-card-driver-for-linux/tap.py", line 84, in get_device
2007/06/20 22:52 CEST [-]     device = hw_reg.get_3g_device()
2007/06/20 22:52 CEST [-]   File "/usr/lib/python2.4/site-packages/Vodafone_Mobile_Connect_Card_driver_for_Linux-0.9.5-py2.4.egg/vmc/common/hardware.py", line 230, in get_3g_device
2007/06/20 22:52 CEST [-]     device.setup(device_properties)
2007/06/20 22:52 CEST [-]   File "/usr/lib/python2.4/site-packages/Vodafone_Mobile_Connect_Card_driver_for_Linux-0.9.5-py2.4.egg/vmc/common/hardware.py", line 136, in setup
2007/06/20 22:52 CEST [-]     self.extract_info(children)
2007/06/20 22:52 CEST [-]   File "/usr/lib/python2.4/site-packages/Vodafone_Mobile_Connect_Card_driver_for_Linux-0.9.5-py2.4.egg/vmc/common/hardware.py", line 166, in extract_info
2007/06/20 22:52 CEST [-]     raise ex.DeviceLacksExtractInfo
2007/06/20 22:52 CEST [-] DeviceLacksExtractInfo
2007/06/20 22:52 CEST [-] Failed to load application:
2007/06/20 22:52 CEST [-] Traceback (most recent call last):
          File "/usr/bin/twistd", line 25, in ?
            run()
          File "/usr/lib/python2.4/site-packages/twisted/scripts/twistd.py", line 205, in run
            app.run(runApp, ServerOptions)
          File "/usr/lib/python2.4/site-packages/twisted/application/app.py", line 278, in run
            runApp(config)
          File "/usr/lib/python2.4/site-packages/twisted/scripts/twistd.py", line 195, in runApp
            application = app.getApplication(config, passphrase)
        --- <exception caught here> ---
          File "/usr/lib/python2.4/site-packages/twisted/application/app.py", line 159, in getApplication
            application = service.loadApplication(filename, style, passphrase)
          File "/usr/lib/python2.4/site-packages/twisted/application/service.py", line 301, in loadApplication
            application = sob.loadValueFromFile(filename, 'application', passphrase)
          File "/usr/lib/python2.4/site-packages/twisted/persisted/sob.py", line 206, in loadValueFromFile
            exec fileObj in d, d
          File "/usr/share/vodafone-mobile-connect-card-driver-for-linux/tap.py", line 90, in ?
            device = get_device()
          File "/usr/share/vodafone-mobile-connect-card-driver-for-linux/tap.py", line 84, in get_device
            device = hw_reg.get_3g_device()
          File "/usr/lib/python2.4/site-packages/Vodafone_Mobile_Connect_Card_driver_for_Linux-0.9.5-py2.4.egg/vmc/common/hardware.py", line 230, in get_3g_device
            device.setup(device_properties)
          File "/usr/lib/python2.4/site-packages/Vodafone_Mobile_Connect_Card_driver_for_Linux-0.9.5-py2.4.egg/vmc/common/hardware.py", line 136, in setup
            self.extract_info(children)
          File "/usr/lib/python2.4/site-packages/Vodafone_Mobile_Connect_Card_driver_for_Linux-0.9.5-py2.4.egg/vmc/common/hardware.py", line 166, in extract_info
            raise ex.DeviceLacksExtractInfo
        vmc.common.exceptions.DeviceLacksExtractInfo:

Failed to load application:
2007/06/20 22:52 CEST [-]
 

Escrito por Kironte

+1
0
-1

Escrito por Kironte

Imagen de Ebeldur
+1
0
-1

He instalado el paquete "Vodafone conect card for Linux", pero aunque se me instala bien, al ejecutarlo no pasa nada, hace como que se carga, pero después no consigo conectar, no me pide pin ni se abre ventana de programa ni nada, ¿alquien puede ayudarme? Muchas gracias.

Visita mi página:

http://franyv.wordpress.com/

+1
0
-1

Mi página personal:

http://franyv.wordpress.com/

Imagen de folken20x
+1
0
-1

atencion ubunteros con un E220
yo he conseguido una guia que de verdad funciona en ubuntu 8.04 y que casualidad, no utiliza wvdial.
yo no lo consegui hacer funcionar con wvdial "me parece un pastel".
para que funcione os voy a resumir lo que me ha funcionado a mi extraido es esta

Guia:

IMPORTANTE con el E220 desenchufado.

1. Abrir una terminal e instalar los paquetes que nos harán falta antes de conectar el módem:

sudo apt-get install libusb-dev wget build-essential

2. Obtener el código fuente del pequeño programa huaweiAtkBbo:

wget http://www.kanoistika.sk/bobovsky/archiv/umts/huaweiAktBbo.c

3. Compilarlo

cc huaweiAktBbo.c -lusb -o huaweiAktBbo

4. Copiar ese binario en uno de los directorios con ejecutables de nuestro PATH, por ejemplo, /sbin:

sudo cp huaweiAktBbo /sbin/

5. Crear una regla udev para hacer que una vez conectado el módem, se ejecute el programa recién compilado e instalado. Para ello crear un nuevo fichero de texto:

sudo gedit /etc/udev/rules.d/50-huawei-e220.rules

Y luego copiar en él la siguiente sentencia

SUBSYSTEM=="usb", SYSFS{idProduct}=="1003", SYSFS{idVendor}=="12d1", RUN+="/sbin/huaweiAktBbo"

6. Ahora conectar el módem USB de Huawei, y en unos segundos comprobar que lo ha detectado con el siguiente comando:

ls /dev/ttyUSB*

que teóricamente mostrará un número variable de ttyUSBs. A mí me han salido entre 4 y 6 según el caso, pero lo importante es que salgan tres, por ejemplo,

/dev/ttyUSB0 /dev/ttyUSB1 /dev/ttyUSB2

hasta aqui la guia no falla, luego hace una cosa extraña que no va, y luego sigue con una alternativa que si funciona, prosigo:

1. Instalar los paquetes de desarrollo de qt3 necesarios para umtsmon "esto lo edito yo porque esta mal"

sudo apt-get install libavahi-qt3-1 libavahi-qt3-dev libqt3-headers libqt3-mt libqt3-mt-dev libqwt5-qt3 libqwt-qt3-dev qt3-dev-tool

2. Descargar de SourceForge la última versión disponible (en el caso de mis pruebas, la 0.8)

3. Descomprimir el fichero en el directorio que queramos para luego poder trabajar a gusto

tar xzvf umtsmon-0.8.src.tar.gz

4. Llamar a qmake para realizar la pre-compilación

qmake

5. Compilar

make

6. Eso dejará un ejecutable llamado umtsmon que también es conveniente copiar a nuestro PATH, por ejemplo a /sbin

sudo cp ./umtsmon /sbin/

7. Ya podemos conectar el E220 y ejecutar el programita con el comando umtsmon en la terminal, por cierto que si os sale una ventana cuando lo ejecutais con texto y 3 botones de dais a ignore, lo que nos permitirá crear un perfil nuevo en Connection/Manage Profiles, editarlo, e introducir los datos necesarios, y en el caso de Simyo, el APN.No hay mucho más que hacer, aunque podéis cacharrear por alguna de sus opciones, que dejan ver claramente que este programita es un pequeño prodigio para controlar el tema del límite de las descargas.

EDIT:
En el caso de vodafone hay que poner como usuario vodafone y contraseña vodafone y la APN es ac.vodafone.es

y ya podeis enchufar el E220 y darle a conectar :3

+1
0
-1

http://ubuntucrew.blogspot.com/
Bienvenidos tripulantes
Imagen de julepeh
+1
0
-1

Hola, me he vajado del enlace recomendado por adrianhtorres los siguientes paquetes:

vodafone-movile-connect-card-driver-for-linux_1,99,16_i386.deb

vodafone-movile-connect-card-driver-for-linux_1,0_feisty_i386.deb

vodafone-movile-connect-card-driver-for-linux_0,9,7,3_feisty_all.deb

vodafone-movile-connect-card-driver-for-linux_0,9,7,2_feisty_all.deb

 y no puedo instalar ninguno, pues al abrirlos con el instalador de paquetes Gmdebi me da el siguiente error:

Dependency is not satisfiable: pyton-twisted

Podeis alguno decirme como coño puedo instalar este puto modem?, es la única razón por la que sigo usando windows.

Saludos.

+1
0
-1
Imagen de daka
+1
0
-1

Re: Vodafone Mobile Connect Issue Hardy


Hi

I too had problems. I now have it working but have to go through a few hoops:

1. modprobe usbserial vendor=0x12d1 product=0x1003
2. remove (disconnect modem) five seconds and re-connect
3. in a few moments .. sudo modprobe -r ehci_hcd
4. click on Vodafone Connect Card

It should connect as usual after those steps

daka __________________
NO SELF....NO PROBLEM

+1
0
-1
Imagen de folken20x
+1
0
-1

Read my post, easyly and clean, with out vwdial or some vodafone tool it really works, I have try it all the things I have read in this post and no one work, els the metode I have post here.

de verdad que si lo aceis como os he dicho funciona de perlas y ademas es muy facil, y con entorno grafico que mas quereis!!!??? xDDDDDD

serio que sino no tira, y le podeis dar mil vueltas el wvdial no tira en ubuntu 8.04 ni a pilas

+1
0
-1

http://ubuntucrew.blogspot.com/
Bienvenidos tripulantes
Imagen de Ledif
+1
0
-1

Hola compañeros, os puedo decir que wvdial funciona bien ya que lo he tenido hasta ahora en mi Ubuntu 8.04 con el modem Huawei 3G de Simyo, en estos momentos estoy usando el umtsmon en modo grafico que sirve para cualquier operador de internet, ojo hay dos variantes uno en targz que hay que compilarlo y otro el que uso yo un .deb. osea enpaquetado para Debian y derivados, lo podeis encontrar en mister Google, aqui os dejo el nombre del paquete umtsmon_0.8+dfsg-1_i386.deb ya vereis es mu facil de usar y te contabiliza el tiempo y la descarga..

Un Saludo a todos..

http://morganlinux.blogspot.com

Linux Registered User # 446512
Ubuntu User # 22996

+1
0
-1

Linux Registered User # 446512
Ubuntu User # 22996

Imagen de Ebeldur
+1
0
-1

Pues estoy intentando instalarlo y me dice el sistema que no puede instalar porque falta una dependencia.

Visita mi página:

http://franyv.wordpress.com/

+1
0
-1

Mi página personal:

http://franyv.wordpress.com/

Imagen de Neimad
+1
0
-1

Pues yo tb tengo un problema en la modificacion de las tablas de ruta.

La cuestion es que no se le asigna ninguna interfaz de red al modemn (ni ppp0, ni ethX, ni ninguna otra, estan las que estaban). El modem conecta perfectamente y funciona, y ya no se como hacer.
Es un fastidio estar conectado pero sin poder decirle al equipo que utilice esa conexion.

Utilizo un Acer Aspire One (de esos EEE-PC o mini-portatiles) con el OS por defecto: Un Fedora para i686 con escritorio XFCE4 modificado por Acer.
Me gustaria añadir que no puedo meter ciertos paquetes de Gnome por incompatibilidad con los paquetes de XFCE modificados por Acer pos si comentais alguna solucion que utilice eso.
Tb añadir que probe el programita ese ya hecho y no me funciona.

+1
0
-1
Imagen de folken20x
+1
0
-1

Bueno, yo soy informatico en una empresa y evidentemente para hacer funcionar estas cosas, necesito una forma estable y facil de acceder a los usuarios que tienen un nivel 0 en linux.

yo aporte un tutorial, con esto siempre funciona, nunca da errores, si quereis probar esta en mi blog que he creado hoy mismo.

http://ubuntucrew.blogspot.com/2008/11/solucion-segura-para-el-e220-voda...

parece mas largo, pero te proporciona una tool que funciona muy bien y ademas es muy bonita.

un saludo

http://ubuntucrew.blogspot.com/
Bienvenidos tripulantes

+1
0
-1

http://ubuntucrew.blogspot.com/
Bienvenidos tripulantes
Imagen de ese_juanaco
+1
0
-1

-hola muy wenas a to@s, lo primero me gustaria dar las gracias a RGthundRclap por su post pues señores si funciona, y funciona a las mil maravillas.Solo me gustaria puntualizar alguna cosilla....

-Para que no se cierre la conexion cuando cierras la consola directamente logueate como root y no como user, asi puedes cerrar la consola, y una cosita para ahorrarnos los comandos sudo wvdial pin y sudo wvdial vodafone pues directamente creamos un scrip cn estos dos comandos en un ducumento de texto guardamos y cerramos, despues solo queda ir a propiedades del documento y en la pestaña permisos marcamos la opcion ejecucion.cerramos y cuando ejecutemos el archivo de texto nos dara la opcion de ejecutarlo en terminal, lo hacemos y asi conseguimos con 2 clics conectarnos directamente.

Salu2 y gracias de un principiante en este mundillo del linux

+1
0
-1
Imagen de juanlo
+1
0
-1

Buenas, soy nuevo en ubuntu, lo prové hace tiempo en su versión 4 y ahora regreso con la 9.10 y veo que no me ha pedido el PIN ni siquiera la primera vez al conectar mi router-usb vodafone...

vaya tela no? a nadie le pasa lo mismo?

+1
0
-1