Como hago para cambiar la resolucion de pantalla de ubuntu?

Imagen de Genia
0 puntos

Explico mi situacion:

Tengo una pantalla de 19" panoramica, si voy a sistema/preferencias/resolucion de la pantalla, me encuentro solo con estas 3 posibilidades: 1024x768, 800x600 y 640x480. Estoy usando 1024x768, pero no se ve bien, todo enorme y eso, mi pregunta es, como puedo hacer para que se vea normal? con normal quiero decir que no se vean las imagenes achatadas ni todo tan grande, con win xp se ve bien, ahora mismo no recuerdo la resolucion que tengo con win xp, pero ya lo dije, se ve bien. Si me podeis ayudar os estaria muy agradecida, solo pido que me conteis lo que tengo que hacer como si fuera una niña de 3 años, ya que yo no tener ni idea de unix XD, en serio. Muchas gracias por adelantado.

Imagen de mstreet linux
+1
0
-1

Tenés que editar el archivo /etc/X11/xorg.conf en modo superusuario. Para hacerlo podés ejecutar el siguiente comando en una terminal:

$ sudo nano /etc/X11/xorg.conf

Podés usar nano o cualquier otro editor de textos (por ejemplo, gedit o kate).

Después vas a la sección Screen, y agregás, en las subsecciones Display, la resolución que quieras usar. Por ejemplo, si querés agregar 1280x1024:

SubSection "Display"
 Depth 24
 Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection

Por último, tenés que reiniciar el entorno gráfico con Ctrl+Alt+Retroceso.

Saludos

+1
0
-1

mstreet

Imagen de nembergantes
+1
0
-1

Para tener todas las opciones de resulución de pantalla, tienes que editar el archivo xorg.conf. Para ello , abres terminal y escribes:

$sudo gedit /etc/X11/xorg.conf

Una vez en el archivo xorg.conf, te vas a la sección "screen" y en todas las líneas donde aparecen las diferentes resoluciones que te reconece, añades, en primer lugar la de tu pantalla ("1280x1024" o la que sea, si no sabes cual tiene tu pantalla, mira en la información del fabricante).

TE pongo el mio como ejemplo:

Section "Screen"
Identifier "Default Screen"
Device "NVIDIA Corporation NV34 [GeForce FX 5500]"
Monitor "COMPAQ FP731"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection

 

 

Una vez hecho esto, guardas el archivo y cierras.

REinicia las X y ya tendrás solucionado el problema.

+1
0
-1
Imagen de hugolino
+1
0
-1

si lo que dijeron arriba no te sirve (a veces no funciona para resoluciones panorámicas) tenés que agregar Modelines al xorg.conf, te dejo un link que en el sexto post está explicado bien rápido y claro como generar el modeline y dónde agregarlo. ya posteé una vez ese link y la persona dijo que le funcionó perfecto

http://www.linuxquestions.org/questions/showthread.php?t=524319 

+1
0
-1
Imagen de Genia
+1
0
-1

Y no me funciona nada, no se hago algo mal, lo del 915resolution no me funciona porque tengo una targeta nvidia (eso es lo que me dice). He hecho lo de añadir la resolucion optima para mi pantalla segun el fabricante, i tampoco, no ha hecho ningun cambio....que hago mal? o que no hago? ayuda please!!

Por cierto, gracias por contestar! 

+1
0
-1
Imagen de hugolino
+1
0
-1

no me refería a lo del 915resolution, más abajo hay una configuración que no depende tanto de la placa de video, es lo que dije de los modeline, te lo copio acá:

El Xorg incluye un programa llamado "gtf" que te deja generar modeline para la resolución que quieras, por ejemplo:

>gtf 1280 768 60 -x      <--- te devuelve el modeline para 1280x768 con refresco de 60

# 1280x768 @ 60.00 Hz (GTF) hsync: 47.70 kHz; pclk: 80.14 MHz
Modeline "1280x768_60.00" 80.14 1280 1344 1480 1680 768 769 772 795 -HSync +Vsync

Dice que tuvo problemas con modelines que tengan el punto decimal, así que corta la parte de ".00"  y supongo que también donde dice ".14", fijate qué valores te devuelve a vos y probá con y sin los decimales.

y después pone dos métodos de editar el xorg.conf

primero, con la sección "modes":

Section "Monitor"
DisplaySize 332 207
HorizSync 32-48
Identifier "Monitor[0]"
ModelName "ZV5000"
Option "DPMS"
VendorName "HP"
VertRefresh 40-70
UseModes "Modes[0]"
EndSection

Section "Modes"
Identifier "Modes[0]"
# 1280x768 @ 60.00 Hz (GTF) hsync: 47.70 kHz; pclk: 80.14 MHz
Modeline "1280x768_60" 80.14 1280 1344 1480 1680 768 769 772 795 -HSync +Vsync
Modeline "1280x800" 80.58 1280 1344 1480 1680 800 801 804 827
Modeline "1280x800" 67.25 1280 1328 1360 1440 800 803 809 822 +HSync -Vsync
Modeline "1280x768" 80.14 1280 1344 1480 1680 768 769 772 795
...

segundo método, agragándolos directo en la sección "monitor":

Section "Monitor"
DisplaySize 332 207
HorizSync 32-48
Identifier "Monitor[0]"
ModelName "ZV5000"
Option "DPMS"
VendorName "HP"
VertRefresh 40-70
# 1280x768 @ 60.00 Hz (GTF) hsync: 47.70 kHz; pclk: 80.14 MHz
Modeline "1280x768_60" 80.14 1280 1344 1480 1680 768 769 772 795 -HSync +Vsync
EndSection 

+1
0
-1
Imagen de Genia
+1
0
-1

A ver si me sale...one momment please, y merci por responder! pruebo e informo a ver que tal...

+1
0
-1
Imagen de Genia
+1
0
-1

He probado con el segundo metodo, ya que con el primero no me aclaro, y no me sale!!! en teoria, haciendo esto tendria que salir en Sistema/preferencias/resolucion de la pantalla, la opcion para la resolucion que quiero, no? o no? es que estoy hecha un lio.... Que hago mal? o que no hago? ayuda please!!! merci por adelantado....

+1
0
-1
Imagen de hugolino
+1
0
-1

a ver... te explico más detallado el primer método a ver si ese sí te funciona

primero usás el comando para generar el modeline como hiciste antes, con la resolución que quieras agregar

ahora hay que editar el archivo xorg.conf, sudo gedit /etc/X11/xorg.conf

bajá hasta la sección "monitor" y agregále esto dentro de la sección:

UseModes "Modes[0]" ###o el nombre que quieras

 

ahora abajo de la sección "monitor" creá la sección "modes" donde vas a pegar los modeline. escribí esto:

 

Section "Modes" ### esto indica que empieza la sección
Identifier "Modes[0]" ### acá tiene que ir el mismo nombre que pusiste arriba

#ahora van los modeline, pegá acá lo que te salió del comando para generarlos

EndSection # con esto indicás que se terminó la sección "modes"

 

grabá el archivo y reiniciá las X con ctrl+alt+backspace o reiniciá la pc y fijate si aparecen las resoluciones nuevas

una pregunta, tenes instalada correctamente la placa de video? alguna vez la instalaste? porque quizas ese
sea el problema tambien, en una terminal hace "glxinfo | grep direct" y fijate, si te dice "Direct Rendeing: Yes" la tenes instalada bien, si dice "no" entonces no esta bien instalada y habria que ver eso tambien

+1
0
-1
Imagen de Genia
+1
0
-1

Me dice: direct rendering; No

              OpenGL renderer string: Mesa GLX Indirect

 

que hago con eso???? 

+1
0
-1
Imagen de hugolino
+1
0
-1

para instalar la placa de video te conviene probar bajar el programa "envy" o por medio de automatix, que son las formas más fáciles, también podés probar instalar el paquete "nvidia-glx" desde synaptic o el "nvidia-glx-legacy" si tu placa es viejita y hacer unos cambios en el archivo /etc/X11/xorg.conf, tenés que editar una línea donde dice "nv" por "nvidia" y agregar esto al final del archivo:

Section "Extensions"
Option "Composite" "Disable"
EndSection

si haciéndo algo de eso te da problemas cuando reiniciás, errores del servidor X, te va a mandar al modo consola y para arreglarlo escribí "sudo dpkg-reconfigure xserver-xorg" y al principio del asistente elegí el driver "vesa" y sale todo siguiente y reiniciar

es demasiado resumido lo que te dije, en realidad deberías dejar el nombre completo de tu placa de video, si tenés windows podés verlo ahí por ejemplo, o poné el comando "lspci" a ver si aparece el nombre de tu tarjeta (de eso depende si usás el diver legacy o el no legacy) y quizás debas hacer algnos cambios más. lo más recomendable es probar y probar hasta que ande, pero siempre recordando qué fue lo último que hiciste para deshacerlo si no anda eh!

si tenés más dudas antes de probarlo preguntá, suele traer algunos problemitas instalar la placa de video 

+1
0
-1
Imagen de dracool
+1
0
-1

***********************************
Te muevo al Foro Correspondiente
Movido por dracool.
***********************************

***********************************

Equipo de moderadores

Foro ubuntu-es

Normas del Foro

*******

+1
0
-1
Imagen de EVC
+1
0
-1

la maquina me dice que no tengo permiso de escrbir sobre ese archivo, y lo ocupaba hacer para modificar la resolucion de la pantalla, y ya me encuentro en modo de super usuario (sudo su)

alguna ayudita de alguien?? muchas gracias  

+1
0
-1