Desesperado por la aceleración 3d de ati en feisty fawn

Imagen de mijel84
0 puntos

No soy capaz de hacer correr la aceleración 3d, y por más que navego por internet no encuentro nada. He probado de todo ya.

Xlib:  extension "XFree86-DRI" missing on display ":0.0".

Eso me lo pone muchas veces al querer usar programas que requiren la tarjeta gráfica. He activado el supesto soporte 3d que viene de fábrica en feisty fawn pero ni asi. El cedega me detecta los drivers como los vesa, y en el xorg.conf como los ati, decir que mi feisty fawn esta actualizado sobre edgy donde te nia los drivers propietarios.

Por culpa de estas cosas no me funciona ni beryl ni compiz ni juegos ni nada, alguien puede ayudarme o dar aviso para que lo implanten en futuros arreglos de la versión del feisty? 

Imagen de ertato
+1
0
-1

Hola, no se si te ayudará mucho pero a mí me pasaba igual y opté por bajarme los drivers propietarios y conseguí la aceleración. Ahora "sólo" me queda configurar Beryl. Por cierto, antes de actualizar me iba perfecto y al actualizar se me fastidió .

+1
0
-1
Imagen de randu
+1
0
-1

yo tengo en el portatil una  ATI Technologies Inc Radeon Mobility 9200 IGP y no me da aceleración 3d, y no se la he podido poner,y también ya estoy desesperado jejeje 

 han encontrado alguna solución

 

 

------------------------------------ Ing. Randu2005, Powered by Linux http://del.icio.us/randu2005 http://www.flickr.com/photos/randu2005 http://lamentehueca.blogspot.com

+1
0
-1

 

 

------------------------------------

Ing. Randu2005, Powered by Linux

http://del.icio.us/randu2005

http://www.flickr.com/photos/randu2005

http://lamentehueca.blogspot.com

Imagen de mijel84
+1
0
-1

Actualizando a feisty fawn, se me ha solucionado el problema, sin los drivers propietarios funciona perfectamente todo, el 3d incluido.

+1
0
-1

Actualizate, vive al día, estate al día, busca, rebusca, depende de alguién lo menos posible.

Imagen de netsilence
+1
0
-1

Si nos das el modelo de tu tarjeta gráfica quizás podamos ayudarte... el proceso a seguir es en muchos casos distinto y depende del modelo de la tarejta en cuestión.

 Saludos!

+1
0
-1
Imagen de medu69
+1
0
-1

A ver yo tengo una Ati Radeon 9250, despues de esto diré:

1º Tanto con Dapper como con Edgy conseguí aceleración con los drivers propietarios.

2º Al actualizar a Feisty la conseguí eliminado los drivers propietarios y utilizando los genéricos de Feisty. Por lo tanto he conseguido siempre aceleración y si yo puedo vosotros tambien.

+1
0
-1

Visita: <a href="http://www.guia-ubuntu.org/index.php?title=Portada">Guía Ubuntu</a>

Imagen de MalcoM
+1
0
-1

How to install Beryl (ATI)

"All credit is due to the forum user in the reference link above. This is been added to this wiki so that other users will not (hopefully) have to search for a solution. This has been tested on the i386 version of Feisty Fawn. Someone, please modify this if the AMD64 version is also compatible."

 

  • Open a terminal:
Applications > Accessories > Terminal
  • Verify our system is up-to-date:
sudo apt-get update
sudo apt-get upgrade
  • Install Xgl (This is the main problem with ATI cards. The fglrx driver will not support the built-in Compiz feature in Ubuntu and we need Xgl to run our new version of Beryl with an ATI card.):
sudo apt-get install xserver-xgl
  • Write a script so Xgl can start on its own:
sudo gedit /usr/local/bin/startxgl.sh
  • Enter and save this script information:

#!/bin/sh
Xgl :1 -fullscreen -ac -accel xv:pbuffer -accel glx:pbuffer &
DISPLAY=:1
cookie="$(xauth -i nextract - :0 | cut -d ' ' -f 9)"
xauth -i add :1 . "$cookie"
exec dbus-launch --exit-with-session gnome-session
  • Make the script executable:
sudo chmod a+x /usr/local/bin/startxgl.sh
  • Now, we need to put in a Xgl option in our GDM login screen:
sudo gedit /usr/share/xsessions/xgl.desktop
  • Enter and save this script information:
[Desktop Entry]
Encoding=UTF-8
Name=GNOME with XGL
Comment=
Exec=/usr/local/bin/startxgl.sh
Icon=
Type=Application
  • Also make this script executable:
sudo chmod a+x /usr/share/xsessions/xgl.desktop
  • Disable the universe repositories (these provide Beryl software that is incompatible with the fglrx driver).
Go to System > Administration > Software Sources 
Uncheck Community-maintained Open Source software (universe)
Click Close

Back in our terminal:

  • Add the correct repository key:
sudo wget http://ubuntu.beryl-project.org/root@lupine.me.uk.gpg -O- | sudo apt-key add -
  • Add the correct repository to the top of your apt source list:
sudo gedit /etc/apt/sources.list
Enter: deb http://ubuntu.beryl-project.org/ feisty main
Save and close gedit
  • Update your apt sources:
sudo apt-get update
  • Install the correct Beryl applications:
sudo apt-get install beryl emerald-themes

Apt should retrieve all of the dependencies such as plug-ins and libraries

  • Install your ATI drivers (if needed):
Go to System > Administration > Restricted Drivers Manager
Check the Enable check box for your ATI graphics card

You will need to reboot to enable the card.

  • After a reboot and choosing Xgl from your sessions list at your login screen, test Beryl. In a terminal:
beryl-manager
emerald --replace

http://ubuntuguide.org/wiki/Ubuntu:Feisty#How_to_install_Beryl_.28ATI.29

 

 

Un Saludo. "La única iglesia que ilumina es la que arde"

+1
0
-1

Un Saludo.

"La única iglesia que ilumina es la que arde"