Problemas al instalar la tarjeta de red

Imagen de paxxel
0 puntos

Hola, pues me he decidido a migrar de windows a linux, y la verdad me estoy encontrando con algunos problemillas pero poco a poco a ver si los voy sacando.
El primero es que al hacer la instalación, no me ha detectado la tarjeta de red. Procedo a instalar los drivers pero me quedo atascado.
sigo los pasos del cd de drivers, descomprimo el fichero etc, pero me quedo en el paso 4:

Please enter the following commands at the UNIX prompt. Remember, UNIX is
case sensitive.

1) Create a temporary directory:
mkdir /temp

2) Change to the temporary directory:
cd /temp

2) Copy driver (rhinefet.tgz) from DOS disk, (mcopy below is one tool in
mtools, if you didn't install mtools, you can type
'mount -t msdos /dev/fd0 /mnt' and use 'cp /mnt/rhinefet.tgz /temp'
command to copy the driver to the temporary directory):
mcopy a:rhinefet.tgz .

3) untar the archive file:

tar xzvf rhinefet.tgz
cd rhinefet

4) Compile the driver source files and it will generate rhinefet.o, and
copy it to correct driver installation path (The installation directory
is different in different kernel versions. In 2.4.x kernel, the path is
/lib/modules/KERNEL_VERSION/kernel/drivers/net/, and in 2.2.x kernel,
the path is /lib/modules/KERNEL_VERSION/net/, the KERNEL_VERSION (see
above) means the kernel version of your Linux distribution. If you don't
know your kernel version , please run 'uname -r' command in command
line. The kernel version will look like '2.2.16', '2.4.2-2smp' etc.) :
make install

5) Check configuration file (/etc/modules.conf or /etc/conf.modules,it
depend on your Linux distribution) for loading kernel modules. Make sure
there is the following content in the configuration file, where # is
interface number (eg: alias eth0 rhinefet):
alias eth# rhinefet

--------------------------------------------------------------------------------------

Al intentar copiar los ficheros que salen al descomprimir a la siguiente ruta, me dice que no tengo permiso para hacerlo:

/lib/modules/KERNEL_VERSION/kernel/drivers/net/

---------------------------------------------------------------------------------------

Alguien me puede dar una idea?

Un saludo y gracias!

Imagen de paxxel
+1
0
-1

Ya está solucionado!! Ahora mismo estoy posteando desde ubuntu! al parecer hay problemas para reconocer la tarjeta de red de la placa, e colocado una en ranura pci, ejecutado pppoeconf y seguido los pasos y voila!!

Un saludo!

+1
0
-1
Imagen de tatadeluxe
+1
0
-1

tengo el disco con drivers y salen las indicaciones que tu das mira prueba
$sudo modprobe via-rhine
te aseguro que te reconocerá la tarjeta de inmediato.
para que esto sea permanente haz
$sudo gedit /etc/modules
luego agregas : via-rhine
y listo, recuerda antes hacer un backup de modules por si acaso.
claro ya te compraste un tarjeta nueva pero nunca esta de mas tener 2 para una red casera :P

+1
0
-1

Javier A. Rovegno Campos
https://launchpad.net/people/tatadeluxe
http://foros.ubuntu-cl.org/
Linux User #419384
PGP key 1024D/C14716CC 2006-09-02
Hydraulic Engineering Student - UdeChile - Chile // Ubuntero Ubuntu-cl