Adobe acrobat reader en Feisty no me funciona

Imagen de piponazo
0 puntos

Hola!

He probado a instalar la última versión disponible de Adobe Acobat Reader en esta versión de Ubuntu y no me deja arrancarlo cuando parece que se ha instalado perfectamente.

 Al ejecutar acroread en un terminal aparece repetidamente esto por pantalla:

expr: error de sintaxis
expr: error de sintaxis
expr: error de sintaxis
...

A un amigo le ha ocurrido lo mismo que a mi. ¿Alguien sabe a que se puede deber? 

Imagen de Caribdis
+1
0
-1

Al parecer es un problema en la detección de la versión de GTK, pero tiene solución. Para ello:

cd /tmp
wget http://remi.collet.free.fr/files/acroread.patch
cd /usr/local/Adobe/Acrobat7.0/bin
sudo patch -b </tmp/acroread.patch 

(la penúltima orden debes modificarla si has instalado el Adobe Reader en un directorio distinto al que viene por defecto)

Y ya está. Vuelve a lanzar el Adobe Reader y verás como ya funciona.

-----
Jorge Castelao

+1
0
-1

-----
Jorge

Imagen de piponazo
+1
0
-1

Muchas gracias, aplicando ese pequeño parche se ha solucionado el problema.

Como ya he comentado le ocurrió lo mismo a un amigo mio y posteriormente a varios más, quizás sea un leve bug que se hayan dejado por la beta del feisty, porque anteriormente en la versión 6.10 de Ubuntu nos iba a todos perfecto.

 Saludos!

+1
0
-1

Daría todo lo que se, por la mitad de lo que ignoro.

Imagen de Caribdis
+1
0
-1

El problema no está en Ubuntu, sino en el propio Adobe Reader. Tiene un bug que hace que no reconozca correctamente la versión de GTK de las distribuciones modernas que usan GTK 2.10. A mí me ocurría lo mismo en Edgy. Y ocurre lo mismo en otras distribuciones, como Fedora Core 6.

Me alegro de que te haya funcionado.

-----
Jorge Castelao

+1
0
-1

-----
Jorge

Imagen de oskar_sv
+1
0
-1

me ha funcionado bien..

Saludos 

+1
0
-1
Imagen de iacaca
+1
0
-1

Funciona perfectamente, muchas gracias :-)

Aunque pensaba que el Adobe iba a funcionar mejor. El kpdf le da 1000 vueltas xD 

+1
0
-1

Que é un porco vestido co traxe de supermán?
Resposta --> Porcomán!!!

Imagen de souf
+1
0
-1

A mi directamente no me deja instalarlo.

Lo busco en el synaptic, me aparece, y cuando lo selecciono para instalarlo, me da un error.

Al actualizar de 6.06 a 7.04 se desinstalaron algunos programas, pero conseguí volver a instalar casi todo, menos el acroread, ya se que el xpdf es muy bueno, de hecho es el que uso yo, pero necesito el acroread para otra persona que usa mi pc.

al intentar instalar el acroread, synaptic me manda un error:

acroread:

El paquete acroread no tiene una versión disponible, pero existe en la base de datos.
Esto generalmente significa que el paquete fue mencionado en una dependencia y nunca fue subido, ha sido declarado obsoleto o no está disponible en el contenido de sources.list

 

He estado buscando y no se que entrada me falta en el sources.list, ya que por mucho que busco, el único problema que encuentro documentado es el como arreglar esto del gtk... 

+1
0
-1
Imagen de Caribdis
+1
0
-1

Descárgalo desde la página de Adobe e instálalo, es lo que he hecho yo. 

-----
Jorge Castelao

+1
0
-1

-----
Jorge

Imagen de gogan
+1
0
-1

Bien tal y como comentan en http://linuzeros.org/foro/viewtopic.php?t=371

<quote>

Y al parecer el problema residía en un fallo de sintaxis, que se corrige así:
sudo gedit /usr/local/Adobe/Acrobat7.0/bin/acroread
Nos situamos en la línea 458
len_version=`expr length $version`
cambiar por:
len_version=`expr length "$version"`

y también en la linea 464
len_base_version=`expr length $base_version`
cambiar por:
len_base_version=`expr length "$base_version"`
</quote>

A lo que yo añado cambiar en la linea 460

<code>

len_base_version=`expr length $base_version`

</code>

por esto

<code>

len_base_version=`expr length "$base_version"`

</code>

Se ve que los desarrolladores de Adobe no llevan bien la evaluación de expresiones en bash

Aun así continuará advirtiendo de

<code>

(acroread:29705): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libqtengine.so: wrong ELF class: ELFCLASS64

(acroread:29705): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libqtengine.so: wrong ELF class: ELFCLASS64

</code>

Pero aun así funciona en Debian Lenny,

Si os da el error de carga el plugin PPKLite.api podeis desactivarlo así

<code>

chmod -x /usr/local/Adobe/Acrobat7.0/Reader/intellinux/plug_ins/PPKLite.api

</code>

Sirve para manejo de PKI, LDAP servidores seguros y no es fundamental

Saludos

 

http://gogan.homelinux.org

+1
0
-1