Instalar Hbasic

Imagen de digigalos
0 puntos

Deseo instalar Hbasic en mi máquina y leyendo los pasos a seguir ya me he quedado parado en el primero. Resulta que antes de comenzar la instalación me dicen que debo tener instaladas las librerías libdl.so y ibqt.so en su versión 3. Con la herramienta de buscar he encontrado la primera de ellas, pero no la segunda. En esta página me dan una dirección que no va y el nombre del fichero: dld-*.tar.gz. Buscando en la red e encontrado esto que he descargado, pero ni sé si es lo que necesito ni cómo puedo instalarlo. En definitiva, que estoy perdidísimo. ¿Alguien puede ayudarme?

Imagen de Festor
+1
0
-1

Abre el synaptic y busca  libdl y ibq, si te aparecen paquetes comprueba que sean superiores a la version 3 como mínimo y instalalos.

 

**********************

  • Intentando crear el mejor videjuego de la historia para Ubuntu Gnu/Linux

**********************

+1
0
-1
Imagen de digigalos
+1
0
-1

En primer lugar, gracias por la respuesta. Abro la aplicación  "Añadir y quitar aplicaciones", busco libdl.so y libqt.so y obtengo, para ambas, el mensaje "No hay ninguna aplicación disponible que coincida con su búsqueda" ¿Alguna pista de por donde seguir?

+1
0
-1
Imagen de Festor
+1
0
-1

Yo tengo una, te dije  libdl y no libdl.so y lo mismo con libqt. No los busques con la extension .so porque no te apareceran

**********************

  • Intentando crear el mejor videjuego de la historia para Ubuntu Gnu/Linux

**********************

+1
0
-1
Imagen de digigalos
+1
0
-1

Te debo una. Puedes pedirme lo que quieras .

+1
0
-1
Imagen de Festor
+1
0
-1

Te funciono? Si es asi me alegro, una de las cosas que menos me gustan de Ubuntu es el rollo de las librerias pero cuando le pillas el truco no suele haber nigun problema 

 

**********************

  • Intentando crear el mejor videjuego de la historia para Ubuntu Gnu/Linux

**********************

+1
0
-1
Imagen de digigalos
+1
0
-1

Con tu ayuda he conseguido llegar hasta el 4º paso y aquí me he parado. me he desgarado las fuentes, he descomprimido, he realizado el ./configure y después el make y.... aquí me encuentro parado pues me sale "No se especificó ningún objetivo y no se encontró ningún makefile.  Alto." y con esto me pierdo. Me he bajado también los binarios, pero me lío aún más. Si puedes echarme una mano, te lo agradecería, y te debería y 2.

+1
0
-1
Imagen de Festor
+1
0
-1

Repite el proceso ./configure y asegurate que no salga nigun error. Si te funciona acuerdate de que el tercer comando es sudo make install y no make install solo ya que si no no te funcionará 

 

**********************

  • Intentando crear el mejor videjuego de la historia para Ubuntu Gnu/Linux

**********************

+1
0
-1
Imagen de digigalos
+1
0
-1

Ahora me sale:

  • sudo make INSTALL  => make: No se hace nada para `INSTALL'.
  • sudo make => make: *** No se especificó ningún objetivo y no se encontró ningún makefile.  Alto.

No hay ningun fichero install, los más parecidos son INSTALL  e install-sh, pero ninguno hace nada con make. Estoy a punto de rendirme.

+1
0
-1
Imagen de Festor
+1
0
-1

Prueba a hacer una cosa. Si tienes un install-sh, entra en la carpeta donde este el archivo desde la terminal (escribe cd ruta_del_archivo, la cual puedes averiguar arrastrando la carptea a la terminal) y luego escribe sudo sh install-sh

Espero que te funcione. 

 

**********************

  • Intentando crear el mejor videjuego de la historia para Ubuntu Gnu/Linux

**********************

+1
0
-1