ubuntu no me deja acceder a Windows

Imagen de darzee
0 puntos

Situación:

Disco duro primario, 80 gigas, con win XP,

Disco duro esclavo, 40 gigas, con las particiones de Ubuntu.

Problema: 

Después de problemas varios con Ubuntu decidí hacer una instalación "limpia" de ubuntu. Formateé el disco duro esclavo e instalé de nuevo ubuntu desde cero.
 Lo cierto es que ubuntu me va fenomenal pero (siempre hay peros) no puedo acceder a mi XP. Total que me pongo a buscar respuestas en la comunidad. Instalo ntfs-3g y nada, me da error. Decido reiniciar para acceder al Grub y pasar mis documentos de trabajo y personales a la partición FAT32 que cree en la instalación de Ubuntu y me encuentro con que Windows tampoco está en el Grub :-(

Vuelvo a los foros de ubuntu-es, ubuntu-fr y unos cuantos más, pruebo toda clase de soluciones como reinstalar el Grub, modificarlo pero nada y empiezo a desesperarme. Nisiquiera me reconoce el disco de instalación del XP....

Necesito urgentemente acceder a mis documentos de windows. Tengo copias de seguridad, claro, pero la última tiene cinco días de antiguedad. ¿No se supone que la instalación de ubuntu no afecta más que al disco donde se instala?

Enfín, ésta es mi situación, quiero librarme del windows pero no así, necesito mis documentos no es una cuestión baladí. Si a alguien le ha pasado algo parecido y me puede ayudar...

 

 

gracias,

darzee 

Imagen de gotxa
+1
0
-1

hola darzee
acabas de empezar de la mejor manera... cargándote al innombrable... creo.

Antes de que te tires de los pelos, te vas al menu "sistema --- administración --- gestión de discos" (o por ahí, que no tengo Gnome a la mano) o abre un terminal y pones:
$ sudo fdisk -l
(muestra la tabla de particiones de los discos que ve tu sistema; te preguntará contraseña, dásela)
$ df -h
(muestra las particiones montadas)

y haces las cuentas y comparas lo que hiciste, lo que se supone que hiciste, lo que tienes...

---

Si todo anda bien (o sea, la partición de windows está ahí viva y "culeando"), haces:

$ cat /etc/fstab
(muestra el archivo que maneja los sistemas de archivos)

$ sudo umount -a ; sudo mount -a
(desmonta todo lo desmontable y lo volvemos a montar, para que tire errores si los hay... es justo lo que interesa, de los errores se aprende ;-D)

y posteas el resultado de estas 4 instrucciones.

suerte y valor
GoTXa
linux counter #116453

+1
0
-1

GoTXa
linux counter #116453
Klaatu barada nikto

Imagen de darzee
+1
0
-1

$ sudo fdisk -l me da:

Disco /dev/hda: 80.0 GB, 80026361856 bytes
255 cabezas, 63 sectores/pista, 9729 cilindros
Unidades = cilindros de 16065 * 512 = 8225280 bytes

Disposit. Inicio    Comienzo      Fin      Bloques  Id  Sistema
/dev/hda1   *           1        9728    78140128+   7  HPFS/NTFS

Disco /dev/hdb: 40.0 GB, 40020664320 bytes
255 cabezas, 63 sectores/pista, 4865 cilindros
Unidades = cilindros de 16065 * 512 = 8225280 bytes

Disposit. Inicio    Comienzo      Fin      Bloques  Id  Sistema
/dev/hdb1   *           1        2422    19454683+  83  Linux
/dev/hdb2            4679        4865     1502077+   5  Extendida
/dev/hdb3            2423        4678    18121320    b  W95 FAT32
/dev/hdb5            4679        4865     1502046   82  Linux swap / Solaris

Las entradas de la tabla de particiones no están en el orden del disco

  $ df -h me da: 

S.ficheros            Tamaño Usado  Disp Uso% Montado en
/dev/hdb1              19G  2,4G   16G  14% /
varrun                252M   80K  252M   1% /var/run
varlock               252M     0  252M   0% /var/lock
procbususb             10M  140K  9,9M   2% /proc/bus/usb
udev                   10M  140K  9,9M   2% /dev
devshm                252M     0  252M   0% /dev/shm
lrm                   252M   18M  235M   7% /lib/modules/2.6.17-11-generic/volatile
/dev/hdb3              18G  3,4G   14G  20% /media/hdb3
/dev/hdd              3,3G  3,3G     0 100% /media/cdrom1

 $ cat /etc/fstab me da esto:

# /etc/fstab: static file system information.
#
#  -- This file has been automaticly generated by ntfs-config --
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>

proc /proc proc defaults 0 0
# Entry for /dev/hdb1 :
UUID=1485fd10-94a5-47bc-901f-f7509abb5c38 / ext3 defaults,errors=remount-ro 0 1
# Entry for /dev/hdb3 :
UUID=97B6-E8A6 /media/hdb3 vfat defaults,utf8,umask=007,gid=46 0 1
# Entry for /dev/hdb5 :
UUID=38e16e8c-54ca-4c57-a721-1141696b420d none swap sw 0 0
/dev/hdc /media/cdrom0 udf,iso9660 user,noauto 0 0
/dev/hdd /media/cdrom1 udf,iso9660 user,noauto 0 0
/dev/ /media/floppy0 auto rw,user,noauto 0 0
/dev/hda1 /media/winxp ntfs-3g defaults,locale=es_ES.UTF-8 0 0
 

$ sudo umount -a ; sudo mount -a me da lo siguiente:

umount: /dev: dispositivo ocupado
umount: /proc/bus/usb: dispositivo ocupado
umount: /var/run: dispositivo ocupado
umount: /sys: dispositivo ocupado
umount: /: dispositivo ocupado
Unexpected clusters per mft record (-127).
Failed to startup volume: Argumento inválido
Failed to mount '/dev/hda1': Argumento inválido
The device '/dev/hda1' doesn't have a valid NTFS.
Maybe you selected the wrong device? Or the whole disk instead of a
partition (e.g. /dev/hda, not /dev/hda1)? Or the other way around?

 

Todo ello me resulta más terrorífico que una inscripción de la lengua de Mordor en un anillo único...  Se aceptan propuestas

darzee, las preguntas nunca son impertinentes, las respuestas sólo a veces...

+1
0
-1

 

 

darzee, las preguntas nunca son impertinentes, las respuestas sólo a veces...

El Noveno Mapache, mi blog literario y de experiencia vital

Imagen de gotxa
+1
0
-1

Hola
como en los chistes, 2 noticias: una buena y una mala

Empiezo por la buena: tu WinXP sigue ahí, intacto lo más seguro.

La mala noticia es que creo que lo que no está intacto es el MBR del disco del Win... en sí no es mala noticia, es fácil de arreglar si es justo esa la causa. Lo chungo es "pelearse" con instrucciones DOS, si encuentras ese disquette/CD que tendrás por ahí no se sabe dónde :-)
http://www.ubuntu-es.org/index.php?q=node/39405

Suertes
GoTXa
linux counter #116453

+1
0
-1

GoTXa
linux counter #116453
Klaatu barada nikto

Imagen de darzee
+1
0
-1

Vale, gracias GoTXa. Ahora sólo es necesario que consiga que mi ordenador arranque con el disco de instalación del XP que por el momento se niega y me salta directamente al GRUB.

 

Por lo menos me quedo más tranquilo sabiendo que mis datos duermen cuales pequeñas blancanieves a la espera de que el apuesto Ubuntu les pegue un morreo y se las traiga al pais de nunca jamás (de nunca jamás volveré a confiarme y hacer cambios sin guardar copias de seguridad de todo). 

 

darzee, las preguntas nunca son impertinentes, las respuestas sólo a veces...

+1
0
-1

 

 

darzee, las preguntas nunca son impertinentes, las respuestas sólo a veces...

El Noveno Mapache, mi blog literario y de experiencia vital

Imagen de gotxa
+1
0
-1

...para que coja primero el CD
+suerte
GoTXa
linux counter #116453

+1
0
-1

GoTXa
linux counter #116453
Klaatu barada nikto

Imagen de darzee
+1
0
-1

Eso mismo probé pero no me lee el disco, y sé que ese disco funciona porque no es la primera vez que el XP me hace esto.

 

darzee, las preguntas nunca son impertinentes, las respuestas sólo a veces...

+1
0
-1

 

 

darzee, las preguntas nunca son impertinentes, las respuestas sólo a veces...

El Noveno Mapache, mi blog literario y de experiencia vital

Imagen de gotxa
+1
0
-1

diría.

GoTXa
linux counter #116453

+1
0
-1

GoTXa
linux counter #116453
Klaatu barada nikto

Imagen de darzee
+1
0
-1

Despues de darle muchas vueltas encontré la solución (con vuestra ayuda, claro):

El XP está en un disco duro,

Ubuntu en otro,

La solución era tan sencilla como desconectar el disco de ubuntu y forzar el sistema a arrancar a través del disco de instalación del XP. Luego en consola de recuperación usé el comando fixmdr y listo!! Mi windows volvió a la vida.

Ahora me queda enchufar de nuevo el segundo disco duro y que Ubuntu rule aunque eso no me preocupa porque ya hice copias de seguridad de todo.

 

Gracias a todos los que contestaron mis mensajes y me pusieron en la pista... 

 

darzee, las preguntas nunca son impertinentes, las respuestas sólo a veces...

+1
0
-1

 

 

darzee, las preguntas nunca son impertinentes, las respuestas sólo a veces...

El Noveno Mapache, mi blog literario y de experiencia vital

Imagen de gubuntu
+1
0
-1

podrias explicarme como modificar el grub para que el S.O. de arranque sea windows y no ubuntu como predifinido??

gracias

 

+1
0
-1
Imagen de cdar
+1
0
-1

Casi al final de el arcivo: /boot/grub/menu.lst

encontraras la siguiente linea: ## ## End Default Options ## 

esta señala el final de la configuración y el comienzo de la descripción de los kernel que va a montar. Mira como tengo los mios para que me arranque con windows:

# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/hda1
title Microsoft Windows XP Professional
root (hd0,0)
savedefault
makeactive
chainloader +1

#Kernel's de linux
#
title        GNU/Linux
root        (hd0,1)
kernel        /boot/vmlinuz-2.6.20-15-generic root=UUID=065bad29-6477-4ac9-a1b8-f2422b73e538 ro quiet splash locale=es_ES
initrd        /boot/initrd.img-2.6.20-15-generic
quiet
savedefault

title        RM
root        (hd0,1)
kernel        /boot/vmlinuz-2.6.20-15-generic root=UUID=065bad29-6477-4ac9-a1b8-f2422b73e538 ro single
initrd        /boot/initrd.img-2.6.20-15-generic

 Como vez primero esta el kernel de windows y luego los de linux; el lugar si importa y es el primero el que arranca por default.

 Solo muevelo de lugar pero ten cuidado de no alterar nada, solo corta y pega el bloque del windows antes de los de linux.

Los cambios a este archivo solo los puede hacer el super usuario, por tal necesitaras editarlo con el poderoso sudo

-------------------------------------------------

CDar Soft (c)

"Apoyar el software libre,

es fomentar el saber humano".

| Mi Web | Blog OTHLIX

+1
0
-1

-------------------------------------------------

CDar Soft (c)

"Apoyar el software libre,

es fomentar el saber humano".

| Mi Web | Blog OTHLIX