No puedo entrar a Ubuntu

Imagen de gumagu
0 puntos

Bueno, como era de esperarse ... acabo de mandarme un ERROR.......tras 3 horas de tratar de instalar mi Geforce lo logre, pero como estaba tan ansioso no termine de hacer la Guia que esta en esta pagina, ya me aparecia el panel de control de Nvidia y me olvide de seguir con los pasos.......bueno cuando volvi a leer la guia me di cuenta de eso, me faltaba hacer esto:

  • Ahora sólo falta indicarle al servidor gráfico que cargue el módulo de nVIDIA. Para ello debemos editar el archivo /etc/X11/xorg.conf y buscar la línea donde dice:
driver "nv"

y sustituirla por:

driver "nvidia"

Por ejemplo:

Section "Device"
Identifier "NVIDIA Corporation NVIDIA Default Card"
Driver "nvidia"

Comentamos las siguientes líneas con un numeral (#) en la sección Module (Section "Module"):

driver "dri"
driver "GLcore"

Nos quedará algo parecido a lo siguiente:

Section "Module"
Load "i2c"
Load "bitmap"
Load "ddc"
# Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "type1"
Load "vbe"
EndSection
  • Al final, actualizamos GDM
$ sudo dpkg-reconfigure gdm

Guardamos los cambios (Ctrl X guardar cambios) y reiniciamos

 

Bueno todo eso me faltaba y me dispuse a hacerlo, pero como en la parte que dice que hay que cambiar "nv" por "nvidia" no hacia falta porque a mi me aparecia "nvidia" de una y no tenia que cambiarlo........y despues eso de "comentar" no se que quiere decir ni donde tengo que colocarlo, porque eso de "GLcore" no me aparece........y bueno lo dejé asi y reinicie la cpu, cuando quiso iniciar el escritorio me salto un error de que server X no podia iniciarse y me dijo que arregle la configuracion y reinicie ...............PERO aque está el tema, como hago esto??.....porque con windows era facil, ponias iniciar en modo a pruebas de fallos y listo......pero con Ubuntu como hago??.........espero que me ayuden porque ya me faltaba tan poquito par instalar la placa de video y ya me estaba acostumbrando a Linux, claro esto no quiere decir que me rendi, al contrario, ahora tengo mas ganas de seguir usandolo jejeje.......metiendo la pata se aprende no??....jajajaja.........saludos y gracias!!

Imagen de ferroniquel
+1
0
-1

Bueno lo primero, si tienes instalado windows y ubuntu con la opción de elegir cual quieres que se inicie al encender el ordenador, si eliges "ubuntu single mode user" o algo parecido entraras a una especie de consola sin cargar el servidor gráfico.

Si no tienes esa opción o sólo tienes ubuntu al entrar hasta donde te entre, que pasa después, ¿Te salen unas letras pidiéndote nombre de usuario y la contraseña? si es asi pon tu nombre y la contraseña.

Despues para modificar el xorg.conf pon lo siguiente:

"sudo nano /etc/X11/xorg.conf"

mete la contraseña si te la pide y modifica lo que necesites y lo guardas con Contro+O y sales con Control+X

comentar significa poner delante del comando una o dos almohadillas (##) que sirven para que no sean tenidas en cuenta o algo así, si no tienes la opción GLcore no hace falta que hagas nada, solo comentar la seccion dri.

 

Pero vamos para instalar los drivers lo mejor es hacerlo desde un archivo .run de la pagina de nvidia que te modifica el xorg el solito y además te aseguras de tener la última versón, creo que antes necesitas instalar paquetes con un "sudo apt-get install build-essential xserver-xorg-dev pkg-config" o algo así busca mas por ahí.

 

Sigue metiendo la pata es la única forma de aprender. ;)

 

+1
0
-1
Imagen de gumagu
+1
0
-1

TEngo Windows y Ubuntu instalados.......si me aparecen varias opciones, cuatro son de Ubuntu (2 del mismo kernel y 2 de recovery o algo asi)......cuando entro a la mas actual (2.6.20-15) me sale ese error, es decir me sale la barra de carga de ubuntu y luego me sale un cuadro diciendome que no se puede iniciar el entorno grafico por un problema con los drivers de Nvidia y luego me dice que arregle eso y reinicie de nuevo, pero no se como arreglarlo...........despues reinicio y entro a la otra opcion (2.6.20-15 recovery system o algo asi) pero no se moverme dentro de esa opcion, ya que me aparece todo como si fuera una terminal.............pero ahora que me estas dando esos comandos voy a intentar hacerlo como decis aver si me funciona.......luego te cuento!!...gracias!!

P/D: he intentado mil formas de instalar la placa (automatix2, por medio de la consola, ejecutando directamente el driver de nvidia pero nada) y la que finalmente me resulto fue la forma que está en la GUIA, pero de despistado que soy no la hice bien jejeje.........AHH una cosita mas, para guardar los cambios es CONTROL+O .....o ......CONTROL+Q ???

+1
0
-1
Imagen de Yolagp
+1
0
-1

También puedes arrancar el live cd y editar el xorg.conf desde allí... A mí me ha pasado varias veces y lo he solucionado así.

Saludos.

YolaGP 

+1
0
-1
Imagen de gumagu
+1
0
-1

Gracias!!.........voy a intentar de las dos formas a ver cual me soluciona esta metida de pata......jajaja......este Linux no me va a vencer tan facil!!...jejeje

+1
0
-1