Resolucion en portatil Packard Bell S4045

Imagen de pablo9000
0 puntos

Hola a todos.

Tengo un portatil packard bell que en teoria aguanta reoluciones mas altas que 1024x768 pero no consigo configurárselas.

He estado mirando por el foro, y he probado de todo en el xorg.conf. Lo último que he probado es a poner esta linea  ModeLine "1280x800_60.00" 83.5 1280 1344 1480 1680 800 801 804 828 -hsync +vsync  en la sección de "Monitor" y a cambiar todos los modes de la sección "Screen" unicamente a 1280x800. Al reiniciar las X (Ctrl+Alt+Del) nada de nada, cuando quiero cambiar la resolución desde gnome, solo me deja elegir las 3 de siempre 1024x768, 800x600, 640x480 (¿no tira en teoría del archivo xorg.conf?). He probado ya bastantes cosas y no lo consigo así que de momento he dejado el xorg.conf como venia despues de instalarlo.

La controladora de video es Intel Graphics Media Accelerator 900 embebida en el Intel chipset (segun la página de Packard Bell).

El monitor es in TFT 15,4 pantalla LCD.

 I

Os pongo el contenido del archivo (la parte correspondiente a monito y tarjeta gráfica como lo tengo ahora) por si véis algo raro:

Section "Device"
    Identifier    "Tarjeta de vídeo genérica"
    Driver        "vesa"
    BusID        "PCI:0:2:0"
EndSection

Section "Monitor"
    Identifier    "Generic Monitor"
    Option        "DPMS"
    HorizSync    28-64
    VertRefresh    75
EndSection

Section "Screen"
    Identifier    "Default Screen"
    Device        "Tarjeta de vídeo genérica"
    Monitor        "Generic Monitor"
    DefaultDepth    24
    SubSection "Display"
        Depth        1
        Modes        "1024x768"
    EndSubSection
    SubSection "Display"
        Depth        4
        Modes        "1024x768"
    EndSubSection
    SubSection "Display"
        Depth        8
        Modes        "1024x768"
    EndSubSection
    SubSection "Display"
        Depth        15
        Modes        "1024x768"
    EndSubSection
    SubSection "Display"
        Depth        16
        Modes        "1024x768"
    EndSubSection
    SubSection "Display"
        Depth        24
        Modes        "1024x768"
    EndSubSection
EndSection

Muchas gracias, eserpo a ver si alguien me puede echar una mano (soy un principiante en esto de linux). 

 

Imagen de nata.loko
+1
0
-1

Creo que el problema puede estar en el driver que utilizas para la gráfica (VESA) no sé si dará mucho de sí... no estoy seguro.

+1
0
-1

 

 n.l

Imagen de oskarloko
+1
0
-1

Bueno, has instalado el  i915resolution

Es un programita ( hack ) que ayuda con esos problemas, sobretodo en portatiles.

 

Se instala con Synaptic... busca por 915 resolution, y mejor deja el Xorg.conf como estaba antes

 

http://intellinuxgraphics.org/user.html 

http://www.geocities.com/stomljen/

 

A mi me funciono, espero te resulte a ti tambien ! 

 

:evil: Oskarloko

+1
0
-1

:evil: Oskarloko

Imagen de pablo9000
+1
0
-1

Ya lo he conseguido.

He instalado el paquete xserver-xorg-video-intel (estaba utilizando el driver generico vesa) y he modificado el xorg para que tire del driver de intel. Me ha quedado así:

Section "Device"
    Identifier    "Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller"
    Driver        "intel"
    BusID        "PCI:0:2:0"
    Option         "UseFBDev" "true"
    Option         "EnablePageFlip"
    Option         "ColorTiling"
EndSection

Section "Monitor"
    Identifier    "Generic Monitor"
    Option        "DPMS"
    HorizSync    28-64
    VertRefresh    75
EndSection

Section "Screen"
    Identifier    "Default Screen"
    Device        "Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller"
    Monitor        "Generic Monitor"
    DefaultDepth    24
    SubSection "Display"
        Depth        1
        Modes        "1280x800" "1280x768" "1200x768"
    EndSubSection
    SubSection "Display"
        Depth        4
        Modes        "1280x800" "1280x768" "1200x768" 
    EndSubSection
    SubSection "Display"
        Depth        8
        Modes        "1280x800" "1280x768" "1200x768"
    EndSubSection
    SubSection "Display"
        Depth        15
        Modes        "1280x800" "1280x768" "1200x768"
    EndSubSection
    SubSection "Display"
        Depth        16
        Modes        "1280x800" "1280x768" "1200x768" 
    EndSubSection
    SubSection "Display"
        Depth        24
        Modes        "1280x800" "1280x768" "1200x768"
    EndSubSection
EndSection

 En un principio me había instalado 915resolution tb, pero no hace falta.

Muchas gracias a todos, un saludo

Pablo

 PD: "Si insistes aprendes, se un cabezón!!!!"

 

+1
0
-1