no reconoce disco duro ni tarjeta SD

Imagen de amalzal
0 puntos

hola a todos,

tengo un pequeño (gran) problema desde que actualicé al feisty fawn. como soy algo novata (y algo torpe también), espero que alguien me pueda ayudar. 

el caso es que con la versión 6.10, ubuntu me reconocía perfectamente el disco duro externo que tengo (conceptronic con USB 2.0). me aparecía un iconito monísimo en el escritorio. y estaba instalado en la carpeta /media con toda mi música, mis pelis y mis documentos.

sin embargo, con la nueva actualización, tararí que te vi, no aparece por ninguna parte. no sé si tengo que instalar algo, tocar alguna configuración o qué.

por otra parte, el lector de tarjetas SD de mi portátil (un acer travelmate 4150) nunca funcionó. ni con la versión edgy, ni con la actual. 

si alguien me puede ayudar le estaré eternamente agradecida y hasta le daré un besito en la frente.

Imagen de slap
+1
0
-1

Hola.
Comprueba que en el directorio /media exista otro directorio con el nombre de tu disco duro externo (por ejemplo: discoext)

Si no existe créala con: sudo mkdir /media/discoext

Ahora prueba a montar el disco con:
sudo mount -t vfat /dev/sda1 /media/discoext

Si no sabes en qué /dev está tu disco, ejecuta: fdisk -l y te lo dirá.

Si tu disco no está formateado en FAT32 y sí en NTFS cambia vfat por ntfs

Saludos.
sLap

+1
0
-1

Saludos.

0000 start out (+FD),A
           ld  BC, +7FFF
           jp 03CB, RAM-CHECK

http://www.injiniero.es

Imagen de amalzal
+1
0
-1

cuando ejecuto fdisk me dice que estos son mis devs:

Device Boot Start End Blocks Id System
/dev/sda1 1 255 2048256 12 Compaq diagnostics
/dev/sda2 * 256 3764 28186042+ c W95 FAT32 (LBA)
/dev/sda3 3765 5467 13679347+ f W95 Ext'd (LBA)
/dev/sda4 5468 7296 14691442+ 83 Linux
/dev/sda5 3765 5385 13020651 b W95 FAT32
/dev/sda6 5386 5467 658633+ 82 Linux swap / Solaris

cuál puede ser el disco duro externo?

  • El SDA 1 es uno que me pone como PQ Service cuyo origen desconozco.
  • SDA 2 es el disco Acer, donde está windows.
  • El SDA 3 no sé qué puede ser.
  • El SDA 4 tampoco sé.
  • El SDA 5 es el Acer Data donde supongo que instalé Ubuntu.
  • El SDA 6, no sé.

Ains, por qué seré tan palurda... 

+1
0
-1
Imagen de slap
+1
0
-1

No sé por qué te sale la información en inglés; pero bueno, ése es otro tema.

Repite el comando fdisk pero así (asegúrate antes que tienes el disco externo conectado por usb y encendido):
sudo fdisk -l

Por lo que has puesto, tu único disco es /dev/sda y los /dev/sda(x) son las particiones.
sda1: debe ser la partición de rescate del portátil. Para restaurar el S.O. de fábrica.
sda2: Windows con FAT32
sda3: es una partición extendida que contiene las particiones lógicas: sda5 y 6
sda4: Ubuntu
sda5: partición FAT32 (la podrás ver desde windows y desde ubuntu)
sda6: partición swap.

Teóricamente tu disco externo debería verse como /dev/sdb
Dime lo que te sale (completo) con el comando fdisk que te he puesto al principio de este mensaje.

sLap

+1
0
-1

Saludos.

0000 start out (+FD),A
           ld  BC, +7FFF
           jp 03CB, RAM-CHECK

http://www.injiniero.es

Imagen de amalzal
+1
0
-1

Gracias por tu paciencia slap. esto es lo que aparece:

Disk /dev/sda: 60.0 GB, 60011642880 bytes
255 heads, 63 sectors/track, 7296 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1               1         255     2048256   12  Compaq diagnostics
/dev/sda2   *         256        3764    28186042+   c  W95 FAT32 (LBA)
/dev/sda3            3765        5467    13679347+   f  W95 Ext'd (LBA)
/dev/sda4            5468        7296    14691442+  83  Linux
/dev/sda5            3765        5385    13020651    b  W95 FAT32
/dev/sda6            5386        5467      658633+  82  Linux swap / Solaris

juro por mis antepasados que el disco duro está encendido y enchufado por usb

 

+1
0
-1
Imagen de slap
+1
0
-1

Es raro que no te lo detecte.
¿Has intentado apagarlo y encenderlo en caliente?
¿Tienes activada la opción: Montar unidades extraíbles al enchufarlas en caliente, en Preferencias-> Unidades y soportes extraíbles?

¿Te detecta algún pendrive que tengas?

sLap

+1
0
-1

Saludos.

0000 start out (+FD),A
           ld  BC, +7FFF
           jp 03CB, RAM-CHECK

http://www.injiniero.es

Imagen de amalzal
+1
0
-1

tampoco me lo detecta. ni nada que se enchufe vía USB menos el ratón.

+1
0
-1
Imagen de slap
+1
0
-1

Tiene mala pinta.

Ejecuta: lsmod | grep usb

Deberías tener algo como esto:

usb_storage            72256  0 
libusual               17936  1 usb_storage
scsi_mod              142348  4 sg,sd_mod,usb_storage,libata
usbcore               134280  4 usb_storage,libusual,uhci_hcd

sLap

+1
0
-1

Saludos.

0000 start out (+FD),A
           ld  BC, +7FFF
           jp 03CB, RAM-CHECK

http://www.injiniero.es

Imagen de slap
+1
0
-1

También interesaría ver el contenido del archivo /proc/bus/usb/devices.

cat /proc/usb/devices

Deberías ver algo como esto:

T:  Bus=01 Lev=02 Prnt=11 Port=00 Cnt=01 Dev#= 12 Spd=12  MxCh= 0
D:  Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
P:  Vendor=04b4 ProdID=6830 Rev= 0.01
S:  Manufacturer= 
S:  Product= 
S:  SerialNumber=D
C:* #Ifs= 1 Cfg#= 1 Atr=c0 MxPwr=  0mA
I:  If#= 0 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=usb-storage
E:  Ad=02(O) Atr=02(Bulk) MxPS=  64 Ivl=0ms
E:  Ad=88(I) Atr=02(Bulk) MxPS=  64 Ivl=0ms

sLap

+1
0
-1

Saludos.

0000 start out (+FD),A
           ld  BC, +7FFF
           jp 03CB, RAM-CHECK

http://www.injiniero.es

Imagen de TASADAR-F
+1
0
-1

Las actualizaciones de version a version traen de vez en cuando algunos fallos por eso yo siempre las hago y recomiendo hacerlas limpias (formateando la particion de linux).

Copiame el comando lspci para saber lo de tu lector de tarjetas esperemos que no sea el "ENE" 

+1
0
-1
Imagen de amalzal
+1
0
-1

aquí tienes el comando lspci. me temo que sí es el ENE:

00:00.0 Host bridge: Intel Corporation Mobile 915GM/PM/GMS/910GML Express Processor to DRAM Controller (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #1 (rev 04)
00:1d.1 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #2 (rev 04)
00:1d.2 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #3 (rev 04)
00:1d.3 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #4 (rev 04)
00:1d.7 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB2 EHCI Controller (rev 04)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev d4)
00:1e.2 Multimedia audio controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Audio Controller (rev 04)
00:1e.3 Modem: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Modem Controller (rev 04)
00:1f.0 ISA bridge: Intel Corporation 82801FBM (ICH6M) LPC Interface Bridge (rev 04)
00:1f.2 IDE interface: Intel Corporation 82801FBM (ICH6M) SATA Controller (rev 04)
00:1f.3 SMBus: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) SMBus Controller (rev 04)
01:00.0 FireWire (IEEE 1394): Texas Instruments TSB43AB21 IEEE-1394a-2000 Controller (PHY/Link)
01:01.0 Ethernet controller: Broadcom Corporation BCM4401-B0 100Base-TX (rev 02)
01:02.0 Network controller: Intel Corporation PRO/Wireless 2200BG Network Connection (rev 05)
01:04.0 CardBus bridge: ENE Technology Inc CB-712/4 Cardbus Controller (rev 10)
01:04.1 FLASH memory: ENE Technology Inc ENE PCI Memory Stick Card Reader Controller (rev 01)
01:04.2 Generic system peripheral [0805]: ENE Technology Inc ENE PCI Secure Digital Card Reader Controller (rev 01)
01:04.3 FLASH memory: ENE Technology Inc FLASH memory: ENE Technology Inc: (rev 01)
01:04.4 FLASH memory: ENE Technology Inc Unknown device 0551 (rev 01)
 

+1
0
-1
Imagen de amalzal
+1
0
-1

al final, y no sé cómo ni por qué, he conseguido que aparecieran los usbs y con ellos, el disco duro externo.

he apagado el ordenador, y vuelto a encender. qué solemne chorrada.

por qué no me hizo esto desde el principio?

sin embargo, la tarjeta SD sigue sin funcionar.

 

+1
0
-1
Imagen de slap
+1
0
-1

Al final: solución informática por excelencia, apagar y volver a encender... ;)

sLap

+1
0
-1

Saludos.

0000 start out (+FD),A
           ld  BC, +7FFF
           jp 03CB, RAM-CHECK

http://www.injiniero.es

Imagen de amalzal
+1
0
-1

pues sí. sin embargo lo de la tarjeta me tiene preocupada. aunque no tanto, siempre se puede utilizar un cable USB (si es que funciona, claro). de todos modos, el funcionamiento de los USB es raro. mú raro.

espero se mejore con el tiempo.

 muchas gracias por todo y siento haberte hecho perder el tiempo!

+1
0
-1
Imagen de Tostadilla
+1
0
-1

Jelou, yo tengo el mismo problema en Feisty. Parece que las unidades externas atraves de USB no son reconocidas a no ser que las tengas enchufadas al arrancar, lo que quita bastante de sus ventajas.

¿Alguien ha dado ya con la forma de arreglar esto?

+1
0
-1
Imagen de PokeP
+1
0
-1

Alguien ha dado con la solución con el lector de tarjeta SD de los portatiles Acer, en mi caso es un Texas Instrument. El caso que con las versiones Dapper y Edgy, no había problema, pero desde que tengo Feisty, no hay manera.

Seguiré buscando, para ver si entre todos encontramos alguna solución. 

+1
0
-1
Imagen de cherOKe
+1
0
-1

No se si llegará demasiado tarde mi respuesta, pero a mi si me detecta el lector de ttas de mi portatil hp, es un texas instruments, y después de buscar por todas partes, encontre la solución, te pego el trozo que me copie a un archivo por si acaso.

*********************************************************************

Lector tarjetas SD - Posible solucion

Enviado por juan_ferrer_toribio el Mié, 07/03/2007 - 01:52

Wenas yo tenia el mismo problema que tu con el lector de tarjetas SD Texas Instruments 5 en 1 que lleva mi portatil.

$ lspci

06:00.0 CardBus bridge: Texas Instruments Unknown device 8039
06:00.2 Mass storage controller: Texas Instruments Unknown device 803b

Mi salida del lspci es esta si la tuya es parecida quiza te sirva.

Para provar tu lector de tarjetas, abre un terminal y introduce los siguientes comandos:

$ sudo modprobe tifm_7xx1
$ sudo modprobe tifm_core
$ sudo modprobe tifm_sd

Ahora si introduces una tarjeta deberia de automontarse. Si todo ha ido bien podras acceder a tu tarjeta desde Lugares > Equipo.

Si quieres que los cambios sean permanentes cada vez que inicies el equipo, puedes acerlo editando el archivo /etc/modules:

$ sudo gedit /etc/modules

Y añadiendo las siguientes lineas:

tifm_7xx1
tifm_core
tifm_sd

Guarda y cierra el archivo (recuerda dejar una línea en blanco despues de la ultima linea)

********************************************************************

Con esto consigues que te detecte las tarjetas, .... aunque no te puedo certificar que funcionen todas,.... tengo una de sd de 32Mb que me la reconoce en menos de un segundo, pero la de 1GB ni de coña, y probe una de 4GB de mi primo y tampoco... asi que no se,... espero que te sirva.

 

________________________

Salu2 :: cherOKe :)

+1
0
-1

_______________________________

Salu2 :: cherOKe :) :: #452641

http://unpinguinoenlaisla.blogspot.com (de windows a ubuntu) 

Imagen de g-kar
+1
0
-1

Oye y para los aspire que tiene otro tipo de lector de tarjetas sabes como se haria??

Copio y pego la salida del lspci

06:04.0 CardBus bridge: ENE Technology Inc CB-712/4 Cardbus Controller (rev 10)
06:04.1 FLASH memory: ENE Technology Inc ENE PCI Memory Stick Card Reader Controller (rev 01)
06:04.2 Generic system peripheral [0805]: ENE Technology Inc ENE PCI Secure Digital Card Reader Controller (rev 01)
06:04.3 FLASH memory: ENE Technology Inc FLASH memory: ENE Technology Inc: (rev 01)
06:04.4 FLASH memory: ENE Technology Inc Unknown device 0551 (rev 01)

+1
0
-1
Imagen de cherOKe
+1
0
-1

pues no tengo ni idea, soy relativamente nuevo en esto de linux y todo lo que he hago es a base de pelearme con el google.

Intenta buscar con tu marca y modelo, a ver si tienes suerte..... siento no poder ayudarte mas. 

________________________

Salu2 :: cherOKe :) :: #452641

+1
0
-1

_______________________________

Salu2 :: cherOKe :) :: #452641

http://unpinguinoenlaisla.blogspot.com (de windows a ubuntu) 

Imagen de TASADAR-F
+1
0
-1

Yo tengo el portatil tambien con SD ENE y estoy siguiendo el bug de cerca.

Hay un parche para conseguir que funcione.

No se si al final han sacado una actualizacion oficial que lo arreglaba porque no  he probado desde hace tiempo el lector.

+1
0
-1