alguien sabe como instalar correctamente un programa en ubuntu?

Imagen de malakero18
0 puntos

Esta claro que no me refiero a el modo añadir/quitar programas, lo que pasa es que, por ejemplo, yo uso ubuntu edgy y en los repositorios aún no incluyen gaim beta6, por lo que para actualizar, me baje gaim-2.0.0beta6.tar.gz y lo convertí a deb (sudo alien gaim-2.0.0beta6.tar.gz), pero al momento de instalar con el deb me indicaba que ya había una versión más reciente instalada o.O?

No hice caso y, primero desinstale gaim desde synaptic (se me desinstalaron también nautilos-sendtoy oro que no recuerdo), luego instale gaim beta6 desde el deb, instalo todo perfectamente, pero, como lo suponía, no hay ningún lanzador en el menu, peor aún, pongo gaim en la consola y me indica que el comando no existe ¬¬

En promer lugar, no tengo idea de donde queda un programa una vez instalado, en segundo lugar, al parecer si no instalo desde añadir/quitar o desde synaptic no me instala el lanzador, entonces, como se supone que sepa cual es el comando lanzador de un programa recien instalado? (en este caso gaim)

Lo mismo me paso con openoffice, instale la versión 2.2 (sin desinstalar la 2.0), simplemente instalo pero ni idea de donde quedo, y OO 2.0 ni se inmutó.  

 

Imagen de MarianoC
+1
0
-1

Antes que nada te recomiendo no estar tan apurado con las nuevas versiones, ya que muchas veces pueden traer problemas. Si la que tenes funciona bien, no cuesta nada esperar unos meses hasta que se empaquete, se pruebe y se ponga a disposicion en los repositorios.
Segundo, no podes convertir un tar.gz con alien asi nomas, ya que lo que bajaste es el archivo con las fuentes, o sea que para instalarlo tenes que compilar. Alien solo permite convertir entre programas ya empaquetados, o sea ya compilados.
Si igualmente queres instalar la nueva verison del gaim, ahora llamado Pidgin vas a tener que compilarlo con el archiconocido ./configure, make, sudo make install.

Con openoffice, una vez que bajas el tar.gz, lo tenes que descomprimir, ahi se te crean unas carpetas donde estan los rpm (paquetes de red hat), lo que tenes que hacer es convertir esos rpm a deb, y luego instalarlos. Con eso basta.

Yo no recomiendo usar alien, salvo en alguna que otra ocacion (ej: openoffice)

Saludos!! 

+1
0
-1
Imagen de zorg
+1
0
-1

para que no te compliques el gaim beta lo tiene el automatix2.

yo algunas veces he tenido que buscar algunos paquetes que parece que no se instalan con el buscador en sistema de archivos y encontrar el rombo application/x-executable y despues editar los menus en la barra de aplicaciones  y crear un elemento nuevo con el enlace al ejecutable.

+1
0
-1