puedo tener python 2.4 y 2.5 al mismo tiempo?

Imagen de earias
0 puntos

hola, soy bastante novato y espero que me podais ayudar. Estoy instalando un programa y me da este error:

  Warning: unsupported python version '2.5'. Only python  2.3, 2.4 are supported.

Tengo ubuntu 7.04, lo he mirado y efectivamente tiene la version 2.5 instalada. Se podria intalar la 2.4 sin desinstalar la 2.5 para que me funcionase el programa? Si no es así como puedo desintalar la 2.5 e instalar la 2.4? soy bastante novato, dadme detalles, porfa. Tendria algun problema en el funcionamiento de mi ordenador si cambio de la 2.5 a la 2.4?

Muchisimas gracias por vuestra ayuda. 

Imagen de medu69
+1
0
-1

Yo tengo las dos herramientas de python instaladas la 2.4 y la 2.5 y no me dan ningún problema.

+1
0
-1

Visita: <a href="http://www.guia-ubuntu.org/index.php?title=Portada">Guía Ubuntu</a>

Imagen de earias
+1
0
-1

me puedes decir que pasos tengo que hacer para instalar la 2.4?

gracias!

+1
0
-1
Imagen de ceportela
+1
0
-1

Pues se me ocurren dos alternativas:

1) Primero haz un apt-cache search python y te fijas en los nombres de los paquetes que la salida del comando te tira. Buscas aquél que sea python2.4-idle o algo similar y luego haz apt-get install python2.4-idle (suponiendo que python2.4-idle sea el nombre del paquete) 

2) Usas Synaptic en el menù del sistema, pon en Buscar Python y recorres la larga lista que te tira el sistema, instalando aquello que quieras.

En realidad, estos pasos son los que debes hacer para instalar casi cualquier otra aplicación. 

Saludos! 

+1
0
-1