Ubuntu 7.04 + Beryl + ATI

Imagen de MalcoM
0 puntos

Hola:

 

Haber si alguien me puede echar una mano....

He instalado U buntu 7.04 + Beryl, tanto en el portatil como en el equipo de sobremesa, ambos con una tarjeta grafica ATI.

Con los drivers que instala por defecto Ubuntu funciona todo perfectamente, aunque creo que el rendimiento es bajo. He intentado usar los drivers especificos de ATI y los propietarios pero nada... siempre me devuelve el mismo error "Composite no esta disponible" y tanto Beryl como Compiz no funcionan.

¿Alguien a conseguido que las tarjetas ATI funcionen con sus drivers propietarios?¿Como?

 

Muchas Gracias. 

Imagen de daniels1982
+1
0
-1

Hola Malcom, te describo mi sistema:

  • Ati Radeon 9250
  • Con drivers por defecto de la instalacion desde live cd.

Yo instale mi ubuntu 7.04 hace ya 3 dias y al principio Compiz y Beril me funcionaron bien,(exepo compiz que aveces no dejaba arrastrar una ventana), despues me di cuenta que el video en totem y en mplayer no funcionaba, se vei aveces algo, pero casi nada, averiguando encontre la solucion, que se debe aplicar a "mano" a ambos por separado, busca en google y la encontraras.

Por otra parte ahora voy a intentar instalar los drivers descargados desde el sitio web de ati (para asi poder usar el tv out de la t de video), ya los habia intentado instalar antes pero termine reinstalando ubuntu 3 veces, espero que esta no sea la cuarta....

Saludos y estoy muy feliz con linux, esta vez si me pego el gran salto parece.

 

+1
0
-1
Imagen de el64
+1
0
-1

Por un lado están los controladores libres, que son los que instala
Ubuntu por defecto, y los propietarios, que se instalan como restringidos
y así lo avisa ubuntu Feisty.
Con el libre el rendimiento es bajo porque han tenido que buscarse la vida
como han podido sin información. Por ello no se soportan todas las ATI ni
todas sus caracteristicas (salida DVI y video). Sin embargo, soporta aiglx
(la extensión de composición "composite").
El controlador propietario soporta casi todas las características de las
tarjetas, no siempre muy bien, y no soporta aiglx ni se sabe cuando lo
hará. En este caso hay que usar XGL para tener compiz/beryl(compiz-com).
En su momento puse como instalarlo aquí.
_________________________
Mas información en... el64.blogspot.com
_________________________
CUIDADO: NO COMPRES dispositivos con DRM.
+1
0
-1
_________________________
Mas información en... el64.blogspot.com
_________________________
CUIDADO: NO COMPRES dispositivos con DRM.
Imagen de MalcoM
+1
0
-1

He mirado el tutorial, pero es para la version 6.10, ¿lo has porbado en la 7.04?

A mi en la 6.10 me funcionaba bien, pero el problema lo tengo al instalarlo en la 7.04, me da el error de "Composite no soportado". 

 

Gracias.

 

Un Saludo. "La única iglesia que ilumina es la que arde"

+1
0
-1

Un Saludo.

"La única iglesia que ilumina es la que arde"

Imagen de daniels1982
+1
0
-1

Anoche estuve hasta las 6:30 de la mañana intentandolo y no hay caso!!!!!

Mi Sistema:

  • Ati Radeon 9250 con TV out.
  • Athlon XP 2500+ 512 ram + 120 GB HDD
  • Ubuntu Feisty 7.04
  • Actualizaciones Al dia.

No logro conseguir en UBUNTU FEISTY 7.04 instalar los drivers de la pagina de ATI, intente con todos estos:

  • ati-driver-installer-8.36.5-x86.x86_64.run
  • ati-driver-installer-8.34.8-x86.x86_64.run
  • ati-driver-installer-8.28.8.run

Lo intente de 2 formas:

1-Escribiendo

sudo sh ./ati-driver-installer-8.*

2-A "pelo" o "manualmente" siguiendo estas indicaciones de esta pagina:

http://wiki.cchtml.com/index.php/Ubuntu_Feisty_Installation_Guide

Con la forma 1 recibia el siguiente error:

Detected configuration:
Architecture: i686 (32-bit)
X Server: X.Org 7.2.x

Detected version of X does not have a matching 'x720' directory
You may override the detected version using the following syntax:
X_VERSION=<xdir> ./ati-driver-installer-<ver>-<arch>.run [--install]

The following values may be used for <xdir>:
x430 XFree86 4.3.x
x430_64a XFree86 4.3.x 64-bit
x680 X.Org 6.8.x
x680_64a X.Org 6.8.x 64-bit
x690 X.Org 6.9.x
x690_64a X.Org 6.9.x 64-bit
x700 X.Org 7.0.x
x700_64a X.Org 7.0.x 64-bit
x710 X.Org 7.1.x
x710_64a X.Org 7.1.x 64-bit
Removing temporary directory: fglrx-install.NY7087

Con la forma 2:

Despues de varias horas, problemas, frio y hambre, logre Instalarla, pero solo pude hacerlo con la version ati-driver-installer-8.36.5-x86.x86_64.run , feliz y contento reinicie el pc y vuala!!! NO FUNCIONA!!! :

  1. sale error y me tira a la consola,
  2. donde ingreso mi nombre de usuario y contraseña,
  3. Voy a /etc/X11
  4. sudo cp respaldo_de.xorg.conf xorg.conf
  5. reinicio el pc y logro entrar de nuevo a ubuntu en modo grafico.
  6. Beryl ya no funciona !!.

NOTA:

Estube leyendo por ahi que el KERNEL de Feisty es el 2.6 el cual no es soportado por los instaladores:

  • ati-driver-installer-8.34.8-x86.x86_64.run
  • ati-driver-installer-8.28.8.run

Intente instalar el/los parches siguientes para sanar esto:

  • fglrx-8.34.8-for-2.6.20.patch
  • fglrx-8.35.5-for-2.6.20.patch

pero obtenia unas lineas con "semi errores", es decir como que se instalaban semi bien,semi mal....

Lo que tambien lei es que el instalador ati-driver-installer-8.36.5-x86.x86_64.run si esta diseñado para el KERNEL 2.6 de Ubuntu Feisty y quisas por eso fue el unico que pude instalar a "mano".

Help, help.

 

+1
0
-1
Imagen de MalcoM
+1
0
-1

Pero no sigas probando mas....

Despues de mucho buscar he visto que ubuntu 7.04 los drives de ati, tanto los de la pagina como los fglrx no soportan algo llamado "Composite", sin esta opcion no funciona ni compiz ni beryl. 

 Yo he conseguido aceleracion con fglrx, pero me quedo sin beryl....

 

Un Saludo. "La única iglesia que ilumina es la que arde"

+1
0
-1

Un Saludo.

"La única iglesia que ilumina es la que arde"

Imagen de daniels1982
+1
0
-1

Vean la pagina http://ati.amd.com/support/drivers/sp/linux64/radeonprevious-linux64.html

Donde dice que la version 8.28 SI funciona con la radeon 9250 

¿ Funcionaria la version 8.28.8 en caso de que la pudiese llegar a instalar en Ubuntu 7.04 Feisty?

Gracias 

+1
0
-1
Imagen de daniel1476
+1
0
-1

hola

primero comentarles que soy nuevo en este mundo de linux (2 o 3 semanas aprox).

en mi maqina tengo una ati x1600pro agp, y pude instalar beryl despues de muchas vueltas.

en cuanto a los driver propietario, no pude instalarlos (ver la siguiente guia) http://69.60.114.106/www.kubuntu-es.org/public_html/?q=node/2621

pero si pude habilitar la aceleracion 3d de esta otra guia

http://www.mikesplanet.net/2007/04/installing-ubuntu-704-ati-x-cards/

una vez que tenia aceleracion 3d me tire a instalar beryl siguiendo estas guias

http://69.60.114.106/www.kubuntu-es.org/public_html/?q=node/2622

http://rcda.wordpress.com/2006/11/02/howto-completito-de-instalar-xgl-be...

espero que puedan servirte.

saludos

+1
0
-1
Imagen de MalcoM
+1
0
-1

Has conseguido que te funcione la aceleracion de ATI + Beryl???

 

Un Saludo. "La única iglesia que ilumina es la que arde"

+1
0
-1

Un Saludo.

"La única iglesia que ilumina es la que arde"

Imagen de daniels1982
+1
0
-1

No e logrado hacer funcionar mi ati radeon 9250 con los drivers de ati descargados desde la pagina oficial de ati, si me a funcionado beryl y compiz cuando recien instale ubunty 7.04 , pero ahora trate de volver a mi configuracion anterior y ya no me funciona ni berul ni compiz. IDEAS???

+1
0
-1
Imagen de MalcoM
+1
0
-1

"Pero no sigas probando mas....

Despues de mucho buscar he visto que ubuntu 7.04 los drives de ati, tanto los de la pagina como los fglrx no soportan algo llamado "Composite", sin esta opcion no funciona ni compiz ni beryl. 

Yo he conseguido aceleracion con fglrx, pero me quedo sin beryl...."

 

 

 

Un Saludo. "La única iglesia que ilumina es la que arde"

+1
0
-1

Un Saludo.

"La única iglesia que ilumina es la que arde"

Imagen de MalcoM
+1
0
-1

He probado los tutoriales que aparecen anteriormente y no me han funcionado, en todos termino con errores y bueno... volemos a formatear.

voy a probar este... haber si alguien lo prueba conmigo y luego nos comenta si funciona

http://ubuntu1501.blogspot.com/2007/04/beryl-in-feisty-with-xgl.html

 

Un Saludo. "La única iglesia que ilumina es la que arde"

+1
0
-1

Un Saludo.

"La única iglesia que ilumina es la que arde"

Imagen de MalcoM
+1
0
-1

Aqui os dejo una pagina donde esplica paso a paso como teneis que hacerlo.

Os recomiendo que lo hagais cuando tengais Ubuntu 7.04 recien instalado, antes de tocar nada.

 

http://ubuntuguide.org/wiki/Ubuntu:Feisty#How_to_install_Beryl_.28ATI.29

 

Lo he probado, con un portatil que tiene una ATI 9700 de 64MB y con una ATI 9600 de 256MB y funciona perfectamente.

 

 

Un Saludo.

"La única iglesia que ilumina es la que arde"

+1
0
-1

Un Saludo.

"La única iglesia que ilumina es la que arde"