como instalar un archivo.tar.gz

Imagen de 1usuario
0 puntos

Me bajo cualquier programa comprimido, ejemplo programa.tar.gz y lo desempaqueto en una carpeta eejemplo programa, entonces me leo el readme o el install que suelen llevar, y me dice que realize las ordenes:

$ ./Configure 

$ sudo make

$ make all

pero la cuando ejecuto ./Configure siempre me dice que no existe el archivo o la carpeta y alguna vez incorret interpreter

Me pasa con todos los archivos que bajo. En este momento quiero instalar un adaptador Wifi usb DWL-G122 y me estoy volviendo loco, poque heprobado con cualquier archivo que bajo y me pasa lo mismo.

Por cierto tengo instalado el build-essential ¿Alguien puede ayudarme?. Gracias

Imagen de Goyo
+1
0
-1

El problema podría ser esa C mayúscula.

Antes de poner ./configure pon ls y comprueba que el archivo está ahí. 

+1
0
-1
Imagen de hectorr
+1
0
-1

Lo primero que debes hacer es desempaquetar el paquete, es decir si es un tar.bz2 --> tar -jxvf /home/pepito/Desktop/nombre del archivo.tar.bz2 (por ejemplo)

Si es tar.gz --> tar - zxvf /.... (ya sabes..)

Una vez hecho esto, debes leer el readme del paquete quehas descargado, si bien como tu dices, dice hacer configure,make y make install, deberas situarte dentro del directorio descomprimido que se a creado al descomprimir el paquete y, una vez dentro, hacer el ./configure, make y make install. Sin acabas de instalar ubuntu te pedira algun compilador, vete a sinaptyc y agrega cualquiera, gcc etc.

Espero que te sirva. Un saludo

 

+1
0
-1
Imagen de 1usuario
+1
0
-1

Acabo de instalar gcc y esta es la respuesta a la orden confuure

$ ./Configure
bash: ./Configure: /bin/bash^M: intérprete incorrecto: No existe el fichero ó directorio
 Ya no se si es que he instalado alguna librería más antigua o que, pero sigo sin poder compilar las aplicaciones.

Por favor cualquier ayuda será bien recibida 

+1
0
-1
Imagen de abate
+1
0
-1

hola saludos

sin querer ser redundante te has leido bien el post anterior tienes que

poner    ./configure             el error esta en escribir       ./Configure

creo que asi se resuelve al menos esta parte del problema

saludos 

+1
0
-1
Imagen de GameZelda
+1
0
-1

te has situado en el directorio?

+1
0
-1