171 actualizaciones disponibles en ubuntu 6.10 recien instalado, ayer las acepte y un desastre con las dependencias

Imagen de gerwif
0 puntos

Saludos al los miembros del foro de un recien incorporado a Linux.

Como he comentado, ayer acepte las actualizaciones y en pricipio todo bien. Los problemas empezaron al intentar instalar una Ati 9500, siguiendo un manual http://www.aprendelinux.es/como1.php?id=13

En las primeros pasos el update me resulto imposible, comenzaron mensajes de error en las dependencias con programas como ekiga, evince  y otros muchos que no recuerdo.

sudo apt-get update
sudo apt-get install module-assistant build-essential
sudo apt-get install fakeroot dh-make debconf libstdc++5 linux-headers-$(uname -r)

 

Acabo de reinstalar y otra vez tengo las actualizaciones hay, como podria actualizar sin que se creen problemas de dependencias.

Gracias    


Imagen de banyut
+1
0
-1

Hola,

A mi me paso exactamente lo mismo pero en mi caso con una nvidia, tambien reinstale varias veces y al final encontre el problema, no se si sera el mismo que el tuyo, ya diras.

al instalar las actualizaciones la version del nucleo se actualiza pero no sus dependencias. Yo hice lo siguiente, al arrancar en el grup te da la opcion de arrancar con la version anterior, entra con ella y probablemente te deje sin ningun problema.

Entra en  el gestor de paquetes Synaptic y busca la palabra linux-headers, observa y veras que tienes instalada una version que no es la ultima, selecciona para instalar la ultima y reinicia.

Tambien se puede hacer desde consola pero yo soy nuevo en linux y aun no controlo los nombres de los paquestes pero creo que podria ser algo asi.

sudo apt-get install linux-header-2.6.17-11

bueno espero que te siva, ya diras. 

La Inteligencia me persigue, pero ..... YO SOY MÁS RÁPIDO!!!!!

+1
0
-1

La Inteligencia me persigue, pero ..... YO SOY MÁS RÁPIDO!!!!!

Usuario Linux #453776              Ubuntu User # 17343

 

Imagen de gerwif
+1
0
-1

Saludos y gracias por responder.

En primer lugar solo tengo una versión del núcleo instalada 2.6.17-10.33 y arranca sin problemas de momento.

En Synaptic estan marcadados como instalados algunos paquetes de esa version y tienen un asterisco en el recuadro al lado del nombre.

Ademas se indican otros de la version 2.6.17-11 pero estos ultimos no estan instalados (recuadro vacio).

-Entiendo que debo marcar los paquetes de la ultima version e instalarlos?

-Los marco todos o solo aquellos que ya estan en la version 2.6.17-10?

-Acepto despues de reiniciar la instalacion de las actualizaciones restantes ?

Gracias de nuevo.

 

+1
0
-1
Imagen de banyut
+1
0
-1

No hace falta que instales todo, solo lo que vayas ha necessitar, que necessitas?,  pues no se, jo por ejemplo no instale los generics, fijate en el grup (inicio), tienes varias opciones para elegir, supongo que estas opciones coinciden con los paquetes que me dices.

Referente a las versiones, lo importante es que coincidan entre ellas, por lo que he entendido ahora te va bien porque aun no has actualizado, en el momento en que actualices, veras que la version del nucleo pasa a ser la 2.6.17-11 y sin embargo los headers instalados seran los 2.6.17-10.

suerte

La Inteligencia me persigue, pero .....  YO SOY MÁS RÁPIDO!!!!!

+1
0
-1

La Inteligencia me persigue, pero ..... YO SOY MÁS RÁPIDO!!!!!

Usuario Linux #453776              Ubuntu User # 17343